aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-11-14 01:36:35 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-11-14 01:36:35 +0800
commit323c52802ed818d36ce06e58ea1e40688cae454a (patch)
treedcaa988f31a739985286bed72b91946ec6f5e16d /misc
parentee9842e171ae92d29301bcc3999359357521e052 (diff)
downloadfreebsd-ports-gnome-323c52802ed818d36ce06e58ea1e40688cae454a.tar.gz
freebsd-ports-gnome-323c52802ed818d36ce06e58ea1e40688cae454a.tar.zst
freebsd-ports-gnome-323c52802ed818d36ce06e58ea1e40688cae454a.zip
- Revert the removal of PERL_LEVEL check
Notified by: mat
Diffstat (limited to 'misc')
-rw-r--r--misc/p5-Geo-Coder-OpenCage/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/misc/p5-Geo-Coder-OpenCage/Makefile b/misc/p5-Geo-Coder-OpenCage/Makefile
index f3ced45ef4b0..d9814510fbdd 100644
--- a/misc/p5-Geo-Coder-OpenCage/Makefile
+++ b/misc/p5-Geo-Coder-OpenCage/Makefile
@@ -25,4 +25,13 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-HTTP-Tiny>=0.028:www/p5-HTTP-Tiny \
+ p5-Pod-Perldoc>=3.21:textproc/p5-Pod-Perldoc
+RUN_DEPENDS+= p5-HTTP-Tiny>=0.028:www/p5-HTTP-Tiny \
+ p5-Pod-Perldoc>=3.21:textproc/p5-Pod-Perldoc
+.endif
+
+.include <bsd.port.post.mk>