aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2013-03-28 23:51:16 +0800
committereadler <eadler@FreeBSD.org>2013-03-28 23:51:16 +0800
commit90bf33f701948af1f7c39c8734ccd7343a700c94 (patch)
tree06488cf5d0a666243bc87a55c904edf7520f8ef2 /misc
parent159424c8ed8c23b899017787e812f5b9033e7af5 (diff)
downloadfreebsd-ports-gnome-90bf33f701948af1f7c39c8734ccd7343a700c94.tar.gz
freebsd-ports-gnome-90bf33f701948af1f7c39c8734ccd7343a700c94.tar.zst
freebsd-ports-gnome-90bf33f701948af1f7c39c8734ccd7343a700c94.zip
Drop support for old versions of FreeBSD from unmaintained ports
Reviewed by: miwi
Diffstat (limited to 'misc')
-rw-r--r--misc/compat5x/Makefile4
-rw-r--r--misc/compat6x/Makefile8
-rw-r--r--misc/gplink/Makefile6
-rw-r--r--misc/kdeedu3/Makefile4
4 files changed, 0 insertions, 22 deletions
diff --git a/misc/compat5x/Makefile b/misc/compat5x/Makefile
index c14884e6ba6f..a19740e2379f 100644
--- a/misc/compat5x/Makefile
+++ b/misc/compat5x/Makefile
@@ -62,17 +62,13 @@ PLIST_SUB+= SPARC64="@comment "
do-install:
@${MKDIR} -m 0755 ${TARGET_DIR}
-.if ${OSVERSION} >= 800105
${RM} -f ${WRKSRC}/libpthread.so.1
(cd ${TARGET_DIR} && ${LN} -sf libthr.so.1 libpthread.so.1)
-.endif
(cd ${WRKSRC} && ${INSTALL_DATA} *.so.* ${TARGET_DIR})
.if ${ARCH} == amd64
@${MKDIR} ${TARGET32_DIR}
-. if ${OSVERSION} >= 800105
${RM} -f ${WRKSRC}/lib32/libpthread.so.1
(cd ${TARGET32_DIR} && ${LN} -sf libthr.so.1 libpthread.so.1)
-. endif
(cd ${WRKSRC}/lib32 && ${INSTALL_DATA} *.so.* ${TARGET32_DIR})
.endif
diff --git a/misc/compat6x/Makefile b/misc/compat6x/Makefile
index 967762ae134b..91f4a64cdd82 100644
--- a/misc/compat6x/Makefile
+++ b/misc/compat6x/Makefile
@@ -24,10 +24,6 @@ USE_LDCONFIG= ${TARGET_DIR}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700043
-IGNORE= is for FreeBSD 7.x and newer
-.endif
-
.if ${ARCH} == "sparc64"
BROKEN= Does not install on sparc64: fails to link lib/compat/libpthread.so.2
.endif
@@ -39,17 +35,13 @@ USE_LDCONFIG32= ${TARGET32_DIR}
do-install:
@${MKDIR} -m 755 ${TARGET_DIR}
-.if ${OSVERSION} >= 800105
${RM} -f ${WRKSRC}/lib/libpthread.so.2
(cd ${TARGET_DIR} && ${LN} -sf libthr.so.2 libpthread.so.2)
-.endif
(cd ${WRKSRC}/lib && ${INSTALL_DATA} *.so.* ${TARGET_DIR})
.if ${ARCH} == amd64
@${MKDIR} ${TARGET32_DIR}
-. if ${OSVERSION} >= 800105
${RM} -f ${WRKSRC}/lib32/libpthread.so.2
(cd ${TARGET32_DIR} && ${LN} -sf libthr.so.2 libpthread.so.2)
-. endif
(cd ${WRKSRC}/lib32 && ${INSTALL_DATA} *.so.* ${TARGET32_DIR})
.endif
diff --git a/misc/gplink/Makefile b/misc/gplink/Makefile
index 7b0483bec77b..568d225cdeac 100644
--- a/misc/gplink/Makefile
+++ b/misc/gplink/Makefile
@@ -25,14 +25,8 @@ PLIST_FILES= bin/gplink
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800069
-LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
-USB_CFLAGS= `libusb-config --cflags`
-USB_LDFLAGS= `libusb-config --libs`
-.else
USB_CFLAGS= # none
USB_LDFLAGS= -lusb
-.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gplink ${PREFIX}/bin
diff --git a/misc/kdeedu3/Makefile b/misc/kdeedu3/Makefile
index 3ad6a708ad6d..74674008a008 100644
--- a/misc/kdeedu3/Makefile
+++ b/misc/kdeedu3/Makefile
@@ -36,10 +36,6 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800069
-LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
-.endif
-
pre-configure:
${REINPLACE_CMD} \
-e 's|pylibdir in.*|pylibdir in "${LOCALBASE}/lib" \\|g' \