aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2019-02-08 10:50:09 +0800
committeryuri <yuri@FreeBSD.org>2019-02-08 10:50:09 +0800
commit00ceb501377785c13dd84e1882c6d1e59f664775 (patch)
tree6ec5effa77b8e54d9bd0c776b60ed0a788592462 /misc
parent8866cf0205dc171b9f4bbe58a56640c6b289223f (diff)
downloadfreebsd-ports-gnome-00ceb501377785c13dd84e1882c6d1e59f664775.tar.gz
freebsd-ports-gnome-00ceb501377785c13dd84e1882c6d1e59f664775.tar.zst
freebsd-ports-gnome-00ceb501377785c13dd84e1882c6d1e59f664775.zip
New port: misc/soapysdr-hackrf: Soapy SDR module for Hack RF
Submitted by: Diane Bruce <db@db.net>
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/soapysdr-hackrf/Makefile23
-rw-r--r--misc/soapysdr-hackrf/distinfo3
-rw-r--r--misc/soapysdr-hackrf/pkg-descr7
4 files changed, 34 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 3889c71f5366..13b0e9b20f1b 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -457,6 +457,7 @@
SUBDIR += smssend
SUBDIR += snakemake
SUBDIR += soapysdr
+ SUBDIR += soapysdr-hackrf
SUBDIR += solarized
SUBDIR += spamcalc
SUBDIR += sshbuddy
diff --git a/misc/soapysdr-hackrf/Makefile b/misc/soapysdr-hackrf/Makefile
new file mode 100644
index 000000000000..1706d15ae77f
--- /dev/null
+++ b/misc/soapysdr-hackrf/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= SoapyHackRF
+DISTVERSIONPREFIX= soapy-hackrf-
+DISTVERSION= 0.3.3
+CATEGORIES= misc hamradio
+
+MAINTAINER= hamradio@FreeBSD.org
+COMMENT= Soapy SDR module for Hack RF
+
+LICENSE= BSL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libhackrf.so:comms/hackrf \
+ libSoapySDR.so:misc/soapysdr
+
+USES= cmake compiler:c++11-lang
+USE_GITHUB= yes
+GH_ACCOUNT= pothosware
+
+PLIST_FILES= lib/SoapySDR/modules0.7/libHackRFSupport.so
+
+.include <bsd.port.mk>
diff --git a/misc/soapysdr-hackrf/distinfo b/misc/soapysdr-hackrf/distinfo
new file mode 100644
index 000000000000..b971f60f4331
--- /dev/null
+++ b/misc/soapysdr-hackrf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1549400142
+SHA256 (pothosware-SoapyHackRF-soapy-hackrf-0.3.3_GH0.tar.gz) = 7b24a47cee42156093bf82982b4fc6184a7c86101c3b8ee450274e57ee1c4b90
+SIZE (pothosware-SoapyHackRF-soapy-hackrf-0.3.3_GH0.tar.gz) = 15853
diff --git a/misc/soapysdr-hackrf/pkg-descr b/misc/soapysdr-hackrf/pkg-descr
new file mode 100644
index 000000000000..4737d458a144
--- /dev/null
+++ b/misc/soapysdr-hackrf/pkg-descr
@@ -0,0 +1,7 @@
+This is the Soapy SDR module for Hack RF, an open source software defined radio
+(SDR) platform.
+
+SoapySDR is an open-source generalized C/C++ API and runtime library for
+interfacing with SDR devices.
+
+WWW: https://github.com/pothosware/SoapySDR