aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-02-14 01:26:35 +0800
committerijliao <ijliao@FreeBSD.org>2001-02-14 01:26:35 +0800
commit2bcdacbc18275ef41ad4f8261f471e79968b1d94 (patch)
treee05e7d987722d703b88170f12fc4d0890893c554 /misc
parent50ae281d8b8388a7ba3eb9db9a3c8474cc11d216 (diff)
downloadfreebsd-ports-gnome-2bcdacbc18275ef41ad4f8261f471e79968b1d94.tar.gz
freebsd-ports-gnome-2bcdacbc18275ef41ad4f8261f471e79968b1d94.tar.zst
freebsd-ports-gnome-2bcdacbc18275ef41ad4f8261f471e79968b1d94.zip
add ttyrec, a tty recorder
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/ttyrec/Makefile21
-rw-r--r--misc/ttyrec/distinfo1
-rw-r--r--misc/ttyrec/pkg-comment1
-rw-r--r--misc/ttyrec/pkg-descr7
-rw-r--r--misc/ttyrec/pkg-plist2
6 files changed, 33 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 33efdf573376..c6ac30fb6cd7 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -153,6 +153,7 @@
SUBDIR += tkman
SUBDIR += tkregexp
SUBDIR += tkrunit
+ SUBDIR += ttyrec
SUBDIR += tvguide
SUBDIR += uk-phone
SUBDIR += uk-postcodes
diff --git a/misc/ttyrec/Makefile b/misc/ttyrec/Makefile
new file mode 100644
index 000000000000..4905c3f01a1c
--- /dev/null
+++ b/misc/ttyrec/Makefile
@@ -0,0 +1,21 @@
+# ex:ts=8
+# New ports collection makefile for: ttyrec
+# Date created: Feb 14, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ttyrec
+PORTVERSION= 1.0.2
+CATEGORIES= misc
+MASTER_SITES= http://namazu.org/~satoru/ttyrec/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+do-install:
+.for file in ttyrec ttyplay
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/misc/ttyrec/distinfo b/misc/ttyrec/distinfo
new file mode 100644
index 000000000000..9c65d4674eaa
--- /dev/null
+++ b/misc/ttyrec/distinfo
@@ -0,0 +1 @@
+MD5 (ttyrec-1.0.2.tar.gz) = 5c02bd189c5de5aed0d16ffed70025cb
diff --git a/misc/ttyrec/pkg-comment b/misc/ttyrec/pkg-comment
new file mode 100644
index 000000000000..d06bee5cd597
--- /dev/null
+++ b/misc/ttyrec/pkg-comment
@@ -0,0 +1 @@
+ttyrec is a tty recorder
diff --git a/misc/ttyrec/pkg-descr b/misc/ttyrec/pkg-descr
new file mode 100644
index 000000000000..38c55d659f15
--- /dev/null
+++ b/misc/ttyrec/pkg-descr
@@ -0,0 +1,7 @@
+ttyrec is a tty recorder. Recorded data can be played back with the
+included ttyplay command. ttyrec is just a derivative of script
+command for recording timing information with microsecond accuracy
+as well. It can record emacs -nw, vi, lynx, or any programs running
+on tty.
+
+WWW: http://namazu.org/~satoru/ttyrec/
diff --git a/misc/ttyrec/pkg-plist b/misc/ttyrec/pkg-plist
new file mode 100644
index 000000000000..39e0ca69a7f7
--- /dev/null
+++ b/misc/ttyrec/pkg-plist
@@ -0,0 +1,2 @@
+bin/ttyrec
+bin/ttyplay