aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
committertcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
commit49081780dbf920e309ccc96ab737f85e04f46c66 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /misc
parent08b2e1c36dfd47eb173836d5b9826e537512dc18 (diff)
downloadfreebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.gz
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.zst
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Diffstat (limited to 'misc')
-rw-r--r--misc/artikulate/Makefile2
-rw-r--r--misc/bibletime/Makefile2
-rw-r--r--misc/console-bridge/Makefile2
-rw-r--r--misc/ignition-fuel-tools/Makefile2
-rw-r--r--misc/kde-thumbnailer-chm/Makefile2
-rw-r--r--misc/kde-thumbnailer-epub-kde4/Makefile2
-rw-r--r--misc/kde-thumbnailer-epub/Makefile2
-rw-r--r--misc/kde-thumbnailer-fb2-kde4/Makefile2
-rw-r--r--misc/kde-thumbnailer-fb2/Makefile2
-rw-r--r--misc/kdeedu-data/Makefile2
-rw-r--r--misc/kf5-purpose/Makefile2
-rw-r--r--misc/kgeography-kde4/Makefile2
-rw-r--r--misc/kgeography/Makefile2
-rw-r--r--misc/klettres-kde4/Makefile2
-rw-r--r--misc/klettres/Makefile2
-rw-r--r--misc/ktouch-kde4/Makefile2
-rw-r--r--misc/ktouch/Makefile2
-rw-r--r--misc/kwordquiz-kde4/Makefile2
-rw-r--r--misc/kwordquiz/Makefile2
-rw-r--r--misc/libemos/Makefile2
-rw-r--r--misc/libkdeedu-kde4/Makefile2
-rw-r--r--misc/libkeduvocdocument/Makefile2
-rw-r--r--misc/libpredict/Makefile2
-rw-r--r--misc/libsweep-lidar/Makefile2
-rw-r--r--misc/molequeue/Makefile2
-rw-r--r--misc/morse/Makefile2
-rw-r--r--misc/ompl/Makefile2
-rw-r--r--misc/openhmd/Makefile2
-rw-r--r--misc/openmvg/Makefile2
-rw-r--r--misc/parley-kde4/Makefile2
-rw-r--r--misc/parley/Makefile2
-rw-r--r--misc/py-SoapySDR/Makefile2
-rw-r--r--misc/py-molequeue/Makefile2
-rw-r--r--misc/raspberrypi-userland/Makefile2
-rw-r--r--misc/sdformat/Makefile2
-rw-r--r--misc/soapysdr/Makefile2
-rw-r--r--misc/urdfdom-headers/Makefile2
-rw-r--r--misc/urdfdom/Makefile2
-rw-r--r--misc/visp/Makefile2
39 files changed, 39 insertions, 39 deletions
diff --git a/misc/artikulate/Makefile b/misc/artikulate/Makefile
index d233a48e370f..0a94779650ab 100644
--- a/misc/artikulate/Makefile
+++ b/misc/artikulate/Makefile
@@ -10,7 +10,7 @@ COMMENT= Pronunciation trainer for KDE
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libQt5GStreamer-1.0.so:multimedia/gstreamer1-qt@qt5
-USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= archive attica auth codecs config configwidgets coreaddons \
crash doctools ecm i18n kdeclarative newstuff service \
widgetsaddons xmlgui
diff --git a/misc/bibletime/Makefile b/misc/bibletime/Makefile
index 6c15a5f6ab69..b9dda2a12138 100644
--- a/misc/bibletime/Makefile
+++ b/misc/bibletime/Makefile
@@ -15,7 +15,7 @@ BROKEN_powerpc64= fails to compile: btosismorphsegmentation.cpp.o: undefined ref
LIB_DEPENDS= libclucene-core.so:textproc/clucene \
libsword.so:misc/sword
-USES= cmake:outsource qt:5 tar:xz ssl
+USES= cmake qt:5 tar:xz ssl
USE_QT= buildtools core dbus gui linguist_build network script svg \
webkit xml qmake_build
.include <bsd.port.mk>
diff --git a/misc/console-bridge/Makefile b/misc/console-bridge/Makefile
index 067a6035a228..b5f8874d781d 100644
--- a/misc/console-bridge/Makefile
+++ b/misc/console-bridge/Makefile
@@ -10,7 +10,7 @@ COMMENT= Package for logging that seamlessly pipes into rosconsole
LICENSE= BSD3CLAUSE
-USES= cmake:outsource compiler:c++11-lang
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= ros
GH_PROJECT= ${PORTNAME:S/-/_/}
diff --git a/misc/ignition-fuel-tools/Makefile b/misc/ignition-fuel-tools/Makefile
index 95551c1f27eb..9e4668101460 100644
--- a/misc/ignition-fuel-tools/Makefile
+++ b/misc/ignition-fuel-tools/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libyaml.so:textproc/libyaml \
libzip.so:archivers/libzip
-USES= cmake:outsource compiler:c++17-lang pkgconfig
+USES= cmake compiler:c++17-lang pkgconfig
USE_LDCONFIG= yes
CMAKE_OFF= BUILD_TESTING
diff --git a/misc/kde-thumbnailer-chm/Makefile b/misc/kde-thumbnailer-chm/Makefile
index 8380e94f4ca9..21c79e830c2e 100644
--- a/misc/kde-thumbnailer-chm/Makefile
+++ b/misc/kde-thumbnailer-chm/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libchm.so:misc/chmlib
-USES= cmake:outsource kde:5 qt:5
+USES= cmake kde:5 qt:5
USE_KDE= ecm_build kio
USE_QT= buildtools_build qmake_build gui
diff --git a/misc/kde-thumbnailer-epub-kde4/Makefile b/misc/kde-thumbnailer-epub-kde4/Makefile
index a1efdf9d4886..0b84f4248881 100644
--- a/misc/kde-thumbnailer-epub-kde4/Makefile
+++ b/misc/kde-thumbnailer-epub-kde4/Makefile
@@ -16,7 +16,7 @@ EXPIRATION_DATE= 2018-12-31
PORTSCOUT= limit:^1\.0
-USES= cmake:outsource kde:4 qt:4
+USES= cmake kde:4 qt:4
USE_KDE= kdelibs automoc4
USE_QT= moc_build qmake_build rcc_build uic_build
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/misc/kde-thumbnailer-epub/Makefile b/misc/kde-thumbnailer-epub/Makefile
index 4a32f8029fdb..0a165f6c33a8 100644
--- a/misc/kde-thumbnailer-epub/Makefile
+++ b/misc/kde-thumbnailer-epub/Makefile
@@ -11,7 +11,7 @@ COMMENT= KDE thumbnail generator for ePub files
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource kde:5 qt:5
+USES= cmake kde:5 qt:5
USE_KDE= archive ecm_build kio
USE_QT= buildtools_build qmake_build gui xmlpatterns
diff --git a/misc/kde-thumbnailer-fb2-kde4/Makefile b/misc/kde-thumbnailer-fb2-kde4/Makefile
index df4d44d3467c..3c5756300fb6 100644
--- a/misc/kde-thumbnailer-fb2-kde4/Makefile
+++ b/misc/kde-thumbnailer-fb2-kde4/Makefile
@@ -14,7 +14,7 @@ COMMENT= KDE thumbnail generator for fb2 files
DEPRECATED= Qt4 has been EOL since december 2015
EXPIRATION_DATE= 2018-12-31
-USES= cmake:outsource kde:4 qt:4
+USES= cmake kde:4 qt:4
USE_KDE= kdelibs automoc4
USE_QT= moc_build qmake_build rcc_build uic_build
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/misc/kde-thumbnailer-fb2/Makefile b/misc/kde-thumbnailer-fb2/Makefile
index 68e2ebbe565f..5ee84c4c3368 100644
--- a/misc/kde-thumbnailer-fb2/Makefile
+++ b/misc/kde-thumbnailer-fb2/Makefile
@@ -11,7 +11,7 @@ COMMENT= KDE thumbnail generator for fb2 files
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource kde:5 qt:5
+USES= cmake kde:5 qt:5
USE_KDE= archive ecm_build kio
USE_QT= buildtools_build qmake_build gui
diff --git a/misc/kdeedu-data/Makefile b/misc/kdeedu-data/Makefile
index dff312190d21..ac1e4967fdcc 100644
--- a/misc/kdeedu-data/Makefile
+++ b/misc/kdeedu-data/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= misc kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE edu data files
-USES= cmake:outsource kde:5 qt:5 tar:xz
+USES= cmake kde:5 qt:5 tar:xz
USE_KDE= ecm
USE_QT= buildtools_build qmake_build
diff --git a/misc/kf5-purpose/Makefile b/misc/kf5-purpose/Makefile
index e0413035cd95..930917619301 100644
--- a/misc/kf5-purpose/Makefile
+++ b/misc/kf5-purpose/Makefile
@@ -10,7 +10,7 @@ COMMENT= Offers available actions for a specific purpose
LIB_DEPENDS= libaccounts-qt5.so:net-im/libaccounts-qt5 \
libkaccounts.so:net-im/kaccounts-integration
-USES= cmake:outsource compiler:c++11-lang gettext \
+USES= cmake compiler:c++11-lang gettext \
kde:5 pkgconfig qt:5 tar:xz
USE_GNOME= intltool
USE_KDE= config coreaddons ecm i18n kdeclarative kio service widgetsaddons
diff --git a/misc/kgeography-kde4/Makefile b/misc/kgeography-kde4/Makefile
index a7bb33371da7..b2d92e87c159 100644
--- a/misc/kgeography-kde4/Makefile
+++ b/misc/kgeography-kde4/Makefile
@@ -11,7 +11,7 @@ COMMENT= KDE 4 geography trainer
DEPRECATED= KDE4 is EOL upstream
EXPIRATION_DATE= 2018-12-31
-USES= cmake:outsource kde:4 qt:4 tar:xz
+USES= cmake kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
USE_QT= xml moc_build qmake_build rcc_build uic_build
diff --git a/misc/kgeography/Makefile b/misc/kgeography/Makefile
index 45ba2abd3267..d8e4874aa838 100644
--- a/misc/kgeography/Makefile
+++ b/misc/kgeography/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= misc kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE geography trainer
-USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash doctools ecm \
i18n iconthemes itemviews service widgetsaddons xmlgui
USE_QT= core dbus gui widgets xml \
diff --git a/misc/klettres-kde4/Makefile b/misc/klettres-kde4/Makefile
index 25cbbabcf0e3..ece7569d6ff0 100644
--- a/misc/klettres-kde4/Makefile
+++ b/misc/klettres-kde4/Makefile
@@ -11,7 +11,7 @@ COMMENT= Alphabet learning tool for KDE 4
DEPRECATED= KDE4 is EOL upstream
EXPIRATION_DATE= 2018-12-31
-USES= cmake:outsource kde:4 qt:4 tar:xz
+USES= cmake kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
USE_QT= xml moc_build qmake_build rcc_build uic_build
diff --git a/misc/klettres/Makefile b/misc/klettres/Makefile
index e9fac644b549..1c06af043dc0 100644
--- a/misc/klettres/Makefile
+++ b/misc/klettres/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= misc kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Alphabet learning tool for KDE
-USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= attica auth codecs completion config configwidgets coreaddons \
crash doctools ecm emoticons i18n init itemmodels \
kdelibs4support newstuff service widgetsaddons xmlgui
diff --git a/misc/ktouch-kde4/Makefile b/misc/ktouch-kde4/Makefile
index 8a912ec9b53a..82a1886b1231 100644
--- a/misc/ktouch-kde4/Makefile
+++ b/misc/ktouch-kde4/Makefile
@@ -13,7 +13,7 @@ EXPIRATION_DATE= 2018-12-31
RUN_DEPENDS= ${LOCALBASE}/lib/kde4/imports/org/kde/charts/qmldir:graphics/kqtquickcharts-kde4
-USES= cmake:outsource kde:4 qt:4 tar:xz
+USES= cmake kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
USE_QT= corelib declarative opengl phonon script sql xmlpatterns \
moc_build qmake_build rcc_build uic_build
diff --git a/misc/ktouch/Makefile b/misc/ktouch/Makefile
index acaa6bfa69e6..15f0bbb7d311 100644
--- a/misc/ktouch/Makefile
+++ b/misc/ktouch/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= misc kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Touch typing tutor for KDE
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons doctools \
ecm i18n itemviews kcmutils kdeclarative kio newstuff package \
parts service sonnet texteditor textwidgets widgetsaddons \
diff --git a/misc/kwordquiz-kde4/Makefile b/misc/kwordquiz-kde4/Makefile
index 116938093fe2..25e28fa8cd1e 100644
--- a/misc/kwordquiz-kde4/Makefile
+++ b/misc/kwordquiz-kde4/Makefile
@@ -11,7 +11,7 @@ COMMENT= Flash card trainer for KDE 4
DEPRECATED= KDE4 is EOL upstream
EXPIRATION_DATE= 2018-12-31
-USES= cmake:outsource kde:4 qt:4 tar:xz
+USES= cmake kde:4 qt:4 tar:xz
USE_KDE= kdelibs libkeduvocdocument automoc4
USE_QT= moc_build qmake_build rcc_build uic_build
diff --git a/misc/kwordquiz/Makefile b/misc/kwordquiz/Makefile
index fbccf9a15861..e20cc3492797 100644
--- a/misc/kwordquiz/Makefile
+++ b/misc/kwordquiz/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= misc kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Flash card trainer for KDE Applications
-USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= attica auth bookmarks codecs completion config configwidgets \
coreaddons crash doctools ecm emoticons guiaddons i18n \
iconthemes init itemmodels itemviews jobwidgets kdeclarative \
diff --git a/misc/libemos/Makefile b/misc/libemos/Makefile
index f57f8a60dcab..b17b43da32ee 100644
--- a/misc/libemos/Makefile
+++ b/misc/libemos/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libeccodes.so:science/eccodes \
libfftw3.so:math/fftw3 \
libpng16.so:graphics/png
-USES= cmake:outsource,noninja fortran
+USES= cmake:noninja fortran
CMAKE_ON= BUILD_SHARED_LIBS # not respected: https://jira.ecmwf.int/browse/SUP-2691
diff --git a/misc/libkdeedu-kde4/Makefile b/misc/libkdeedu-kde4/Makefile
index 6d9a225d58e8..e6b1496d08a9 100644
--- a/misc/libkdeedu-kde4/Makefile
+++ b/misc/libkdeedu-kde4/Makefile
@@ -11,7 +11,7 @@ COMMENT= Libraries used by KDE educational applications
DEPRECATED= KDE4 is EOL upstream
EXPIRATION_DATE= 2018-12-31
-USES= cmake:outsource kde:4 qt:4 tar:xz
+USES= cmake kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
USE_QT= corelib gui xml moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/misc/libkeduvocdocument/Makefile b/misc/libkeduvocdocument/Makefile
index a923775f7fbb..422a8e9156be 100644
--- a/misc/libkeduvocdocument/Makefile
+++ b/misc/libkeduvocdocument/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= misc kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Library for reading and writing vocabulary files
-USES= cmake:outsource compiler:c++11-lang gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= archive config coreaddons ecm i18n kio service
USE_QT= core gui xml \
buildtools_build qmake_build
diff --git a/misc/libpredict/Makefile b/misc/libpredict/Makefile
index acd2a768cbab..90ea8c11aac7 100644
--- a/misc/libpredict/Makefile
+++ b/misc/libpredict/Makefile
@@ -11,7 +11,7 @@ COMMENT= Satellite orbit prediction library
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource
+USES= cmake
USE_GITHUB= yes
GH_ACCOUNT= la1k
USE_LDCONFIG= yes
diff --git a/misc/libsweep-lidar/Makefile b/misc/libsweep-lidar/Makefile
index bfb9d675468d..a417e7ea96d8 100644
--- a/misc/libsweep-lidar/Makefile
+++ b/misc/libsweep-lidar/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_powerpc64= fails to compile: unrecognized command line option "-Weverything"
-USES= cmake:outsource
+USES= cmake
USE_GITHUB= yes
GH_ACCOUNT= scanse
GH_PROJECT= sweep-sdk
diff --git a/misc/molequeue/Makefile b/misc/molequeue/Makefile
index 8f0a8224c641..6d1fde0643ea 100644
--- a/misc/molequeue/Makefile
+++ b/misc/molequeue/Makefile
@@ -12,7 +12,7 @@ COMMENT= Desktop integration of high performance computing resources
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake:outsource compiler:c++11-lang qt:5
+USES= cmake compiler:c++11-lang qt:5
USE_QT= core gui network widgets buildtools_build qmake_build
USE_LDCONFIG= yes
diff --git a/misc/morse/Makefile b/misc/morse/Makefile
index fca1de1d1710..e3159e5e93b0 100644
--- a/misc/morse/Makefile
+++ b/misc/morse/Makefile
@@ -12,7 +12,7 @@ COMMENT= Modular OpenRobots Simulation Engine
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake:outsource pkgconfig python:3.4+ shebangfix
+USES= cmake pkgconfig python:3.4+ shebangfix
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}-simulator
SHEBANG_FILES= bin/morse_inspector
diff --git a/misc/ompl/Makefile b/misc/ompl/Makefile
index 8dd82cd196cb..e49314da0bfb 100644
--- a/misc/ompl/Makefile
+++ b/misc/ompl/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libboost_system.so:devel/boost-libs
-USES= cmake:outsource eigen:3 pkgconfig zip
+USES= cmake eigen:3 pkgconfig zip
USE_LDCONFIG= yes
CMAKE_OFF= OMPL_REGISTRATION OMPL_BUILD_TESTS OMPL_BUILD_DEMOS
diff --git a/misc/openhmd/Makefile b/misc/openhmd/Makefile
index 8840be24fbad..7944c6c2ac3e 100644
--- a/misc/openhmd/Makefile
+++ b/misc/openhmd/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libhidapi.so:comms/hidapi
-USES= cmake:outsource compiler:c++11-lang
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
USE_LDCONFIG= yes
diff --git a/misc/openmvg/Makefile b/misc/openmvg/Makefile
index 3d1f1f69768d..bc2ce1daa96e 100644
--- a/misc/openmvg/Makefile
+++ b/misc/openmvg/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libflann_cpp.so:math/flann \
libpng.so:graphics/png \
libtiff.so:graphics/tiff
-USES= cmake:outsource eigen:3 jpeg qt:5
+USES= cmake eigen:3 jpeg qt:5
USE_GITHUB= yes
GH_ACCOUNT= openMVG
GH_PROJECT= openMVG
diff --git a/misc/parley-kde4/Makefile b/misc/parley-kde4/Makefile
index ac369f57fd47..668427ac8b6b 100644
--- a/misc/parley-kde4/Makefile
+++ b/misc/parley-kde4/Makefile
@@ -11,7 +11,7 @@ COMMENT= Vocabulary trainer for KDE 4
DEPRECATED= KDE4 is EOL upstream
EXPIRATION_DATE= 2018-12-31
-USES= cmake:outsource kde:4 qt:4 tar:xz
+USES= cmake kde:4 qt:4 tar:xz
USE_GNOME= libxml2 libxslt
USE_KDE= kdelibs libkeduvocdocument attica automoc4
USE_QT= corelib gui moc_build qmake_build rcc_build uic_build
diff --git a/misc/parley/Makefile b/misc/parley/Makefile
index cd5ece6d378f..20e212f91c3c 100644
--- a/misc/parley/Makefile
+++ b/misc/parley/Makefile
@@ -10,7 +10,7 @@ COMMENT= Vocabulary trainer for KDE
BUILD_DEPENDS= ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:textproc/docbook-xsl \
docbook-xml>0:textproc/docbook-xml
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake gettext kde:5 qt:5 tar:xz
USE_GNOME= libxml2 libxslt
USE_KDE= attica auth codecs completion configwidgets coreaddons config \
crash doctools ecm i18n jobwidgets kcmutils kio newstuff \
diff --git a/misc/py-SoapySDR/Makefile b/misc/py-SoapySDR/Makefile
index b674657684b6..20a88ef34eb0 100644
--- a/misc/py-SoapySDR/Makefile
+++ b/misc/py-SoapySDR/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/../LICENSE_1_0.txt
BUILD_DEPENDS= swig3.0:devel/swig30
LIB_DEPENDS= libSoapySDR.so:misc/soapysdr
-USES= cmake:outsource compiler:c++11-lang gettext-runtime python
+USES= cmake compiler:c++11-lang gettext-runtime python
USE_GITHUB= yes
GH_ACCOUNT= pothosware
USE_PYTHON= flavors
diff --git a/misc/py-molequeue/Makefile b/misc/py-molequeue/Makefile
index 9979f17dc4bf..0585a1144d55 100644
--- a/misc/py-molequeue/Makefile
+++ b/misc/py-molequeue/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/../LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyzmq>0:net/py-pyzmq@${PY_FLAVOR}
-USES= cmake:outsource compiler:c++11-lang python
+USES= cmake compiler:c++11-lang python
USE_PYTHON= flavors
WRKSRC_SUBDIR= python
diff --git a/misc/raspberrypi-userland/Makefile b/misc/raspberrypi-userland/Makefile
index ca2c67c3ab0e..7b514276cd20 100644
--- a/misc/raspberrypi-userland/Makefile
+++ b/misc/raspberrypi-userland/Makefile
@@ -14,7 +14,7 @@ ONLY_FOR_ARCHS= armv6 armv7
CONFLICTS_INSTALL= mesa-libs
-USES= cmake:outsource pkgconfig shebangfix
+USES= cmake pkgconfig shebangfix
USE_LDCONFIG= yes
diff --git a/misc/sdformat/Makefile b/misc/sdformat/Makefile
index 15e71188a517..7838be717ff1 100644
--- a/misc/sdformat/Makefile
+++ b/misc/sdformat/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libignition-math6.so:math/ignition-math \
liburdfdom_world.so:misc/urdfdom
RUN_DEPENDS= ignition-tools>0:devel/ignition-tools
-USES= cmake:outsource compiler:c++17-lang pkgconfig
+USES= cmake compiler:c++17-lang pkgconfig
USE_LDCONFIG= yes
CMAKE_OFF= BUILD_TESTING
diff --git a/misc/soapysdr/Makefile b/misc/soapysdr/Makefile
index f59661b15e81..a2bded3af9b8 100644
--- a/misc/soapysdr/Makefile
+++ b/misc/soapysdr/Makefile
@@ -12,7 +12,7 @@ COMMENT= Vendor and platform neutral SDR support library
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE_1_0.txt
-USES= cmake:outsource compiler:c++11-lang
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= pothosware
USE_LDCONFIG= yes
diff --git a/misc/urdfdom-headers/Makefile b/misc/urdfdom-headers/Makefile
index 5d4821842244..86671dfb3b05 100644
--- a/misc/urdfdom-headers/Makefile
+++ b/misc/urdfdom-headers/Makefile
@@ -10,7 +10,7 @@ COMMENT= Unified Robot Description Format (URDF) parser headers
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake:outsource
+USES= cmake
USE_GITHUB= yes
GH_ACCOUNT= ros
GH_PROJECT= ${PORTNAME:S/-/_/}
diff --git a/misc/urdfdom/Makefile b/misc/urdfdom/Makefile
index 6bfbdde21d13..691ce5440484 100644
--- a/misc/urdfdom/Makefile
+++ b/misc/urdfdom/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libconsole_bridge.so:misc/console-bridge \
libtinyxml.so:textproc/tinyxml
RUN_DEPENDS= urdfdom-headers>0:misc/urdfdom-headers
-USES= compiler:c++11-lang cmake:outsource
+USES= compiler:c++11-lang cmake
USE_GITHUB= yes
GH_ACCOUNT= ros
USE_LDCONFIG= yes
diff --git a/misc/visp/Makefile b/misc/visp/Makefile
index 77b27c9545c8..acc4ea319089 100644
--- a/misc/visp/Makefile
+++ b/misc/visp/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libblas.so:math/blas \
libpng16.so:graphics/png \
libv4l2.so:multimedia/libv4l
-USES= cmake:outsource eigen:3 fortran jpeg
+USES= cmake eigen:3 fortran jpeg
USE_GNOME= libxml2
USE_XORG= ice sm x11 xext
USE_LDCONFIG= yes