aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-12-12 19:12:57 +0800
committersobomax <sobomax@FreeBSD.org>2000-12-12 19:12:57 +0800
commit77c2d6d03b7d8856bcf0404263aa673a86b0ccd3 (patch)
tree24dfa010b73a017cbef30ef7ee8e1ff6d7b12fae /misc
parent9c7016b4c570ace8dd5cb2b31e895cf8e6b6dd53 (diff)
downloadfreebsd-ports-gnome-77c2d6d03b7d8856bcf0404263aa673a86b0ccd3.tar.gz
freebsd-ports-gnome-77c2d6d03b7d8856bcf0404263aa673a86b0ccd3.tar.zst
freebsd-ports-gnome-77c2d6d03b7d8856bcf0404263aa673a86b0ccd3.zip
Add misterproper. Mister Proper is a GNOME tool designed to schedule your
cyclic tasks. It will keep track of what you should have done, what you really did, and is able to adjust each task's frequency until the optimal organization is found.
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/misterproper/Makefile31
-rw-r--r--misc/misterproper/distinfo1
-rw-r--r--misc/misterproper/files/patch-aa20
-rw-r--r--misc/misterproper/pkg-comment1
-rw-r--r--misc/misterproper/pkg-descr13
-rw-r--r--misc/misterproper/pkg-plist8
7 files changed, 75 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index dee87bb27d77..4eb6783eee2e 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -93,6 +93,7 @@
SUBDIR += mc
SUBDIR += metatheme
SUBDIR += mgp-mode.el
+ SUBDIR += misterproper
SUBDIR += mmv
SUBDIR += most
SUBDIR += moviedb
diff --git a/misc/misterproper/Makefile b/misc/misterproper/Makefile
new file mode 100644
index 000000000000..d09a77bbe6b5
--- /dev/null
+++ b/misc/misterproper/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: misterproper
+# Date created: 12 December 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= misterproper
+PORTVERSION= 0.3
+CATEGORIES= misc gnome
+MASTER_SITES= ftp://misterproper.sourceforge.net/pub/misterproper/releases/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>
diff --git a/misc/misterproper/distinfo b/misc/misterproper/distinfo
new file mode 100644
index 000000000000..de29944d13d0
--- /dev/null
+++ b/misc/misterproper/distinfo
@@ -0,0 +1 @@
+MD5 (misterproper-0.3.tar.gz) = 27a142501fe902e785859f6597cfe3b0
diff --git a/misc/misterproper/files/patch-aa b/misc/misterproper/files/patch-aa
new file mode 100644
index 000000000000..2e7d00f4828b
--- /dev/null
+++ b/misc/misterproper/files/patch-aa
@@ -0,0 +1,20 @@
+--- src/main.c 2000/12/12 10:59:00 1.1
++++ src/main.c 2000/12/12 11:00:32
+@@ -208,7 +208,7 @@
+ g_free(thing);
+ continue;
+ }
+- if ((thing->frequency = (time_t) strtoull(skunk, NULL, 10)) ==
++ if ((thing->frequency = (time_t) strtoul(skunk, NULL, 10)) ==
+ (time_t) 0ULL) {
+ g_warning(_("Corrupted database : null frequency\n"));
+ g_free(thing);
+@@ -219,7 +219,7 @@
+ g_free(thing);
+ continue;
+ }
+- thing->last = (time_t) strtoull(skunk, NULL, 10);
++ thing->last = (time_t) strtoul(skunk, NULL, 10);
+ if ((skunk = strtok(NULL, DBSEP)) == NULL) {
+ g_warning(_("Corrupted database : wrong line format\n"));
+ g_free(thing);
diff --git a/misc/misterproper/pkg-comment b/misc/misterproper/pkg-comment
new file mode 100644
index 000000000000..b2286a7c5996
--- /dev/null
+++ b/misc/misterproper/pkg-comment
@@ -0,0 +1 @@
+A GNOME application designed to manage cyclic tasks
diff --git a/misc/misterproper/pkg-descr b/misc/misterproper/pkg-descr
new file mode 100644
index 000000000000..501ef74ec9ba
--- /dev/null
+++ b/misc/misterproper/pkg-descr
@@ -0,0 +1,13 @@
+Mister Proper is a GNOME application designed to manage cyclic tasks. It was
+especially designed to keep you house clean with the best possible tidying
+organization.
+
+Altough Mister Proper is really handy for as a time-scheduler for your home
+tidying, it is also good at any cyclic task such as going to the doctor's,
+giving your grandmother a phone call, and so on.
+
+English and French locales are supported. If you are able to translate that
+piece of software in other languages, please do. Patches, comments and
+suggestions are also welcome.
+
+WWW: http://misterproper.sourceforge.net/
diff --git a/misc/misterproper/pkg-plist b/misc/misterproper/pkg-plist
new file mode 100644
index 000000000000..024a47d0c863
--- /dev/null
+++ b/misc/misterproper/pkg-plist
@@ -0,0 +1,8 @@
+bin/misterproper
+share/gnome/pixmaps/misterproper/misterproper.xpm
+share/locale/de/LC_MESSAGES/misterproper.mo
+share/locale/es/LC_MESSAGES/misterproper.mo
+share/locale/fr/LC_MESSAGES/misterproper.mo
+share/locale/pt/LC_MESSAGES/misterproper.mo
+share/locale/sv/LC_MESSAGES/misterproper.mo
+@dirrm share/gnome/pixmaps/misterproper