aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-21 21:56:24 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-21 21:56:24 +0800
commitb8004b23e6e5099016da718b0e28316e23df63c2 (patch)
treecfff188c5b60e757b530a6aec5eaffe5f57ea433 /misc
parent1ebdd941e6736e73d6d1b9663cd3638a8b9882fb (diff)
downloadfreebsd-ports-gnome-b8004b23e6e5099016da718b0e28316e23df63c2.tar.gz
freebsd-ports-gnome-b8004b23e6e5099016da718b0e28316e23df63c2.tar.zst
freebsd-ports-gnome-b8004b23e6e5099016da718b0e28316e23df63c2.zip
Support staging
Diffstat (limited to 'misc')
-rw-r--r--misc/table.el/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/misc/table.el/Makefile b/misc/table.el/Makefile
index b9a32eb99970..9d55ee67643f 100644
--- a/misc/table.el/Makefile
+++ b/misc/table.el/Makefile
@@ -17,18 +17,14 @@ NO_WRKSUBDIR= yes
EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
-NO_STAGE= yes
do-extract:
${MKDIR} ${WRKDIR}
${GUNZIP_CMD} -c ${DISTDIR}/${DISTNAME} > ${WRKDIR}/${PORTNAME}
do-install:
- ${MKDIR} ${EMACSLISPDIR}
- ${MKDIR} ${XEMACSLISPDIR}
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME} ${EMACSLISPDIR}
- ${LN} -sf ${EMACSLISPDIR}/${PORTNAME} ${XEMACSLISPDIR}
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${EMACSLISPDIR}
+ ${MKDIR} ${STAGEDIR}${XEMACSLISPDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${EMACSLISPDIR}
+ ${LN} -sf ${PORTNAME} ${STAGEDIR}${XEMACSLISPDIR}
.include <bsd.port.mk>