aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-04-08 03:37:31 +0800
committerwill <will@FreeBSD.org>2001-04-08 03:37:31 +0800
commitc096677a0063451af5f9ac14b1e0b88d732e8c86 (patch)
treef335fa36084a23bb3e1e0438afea97b48b29e8b8 /misc
parentc5b33934a22e5daf6e8f8e9c39462e9980bf9cb7 (diff)
downloadfreebsd-ports-gnome-c096677a0063451af5f9ac14b1e0b88d732e8c86.tar.gz
freebsd-ports-gnome-c096677a0063451af5f9ac14b1e0b88d732e8c86.tar.zst
freebsd-ports-gnome-c096677a0063451af5f9ac14b1e0b88d732e8c86.zip
Add cuecat 1.0, tools for decoding and using the output of a
:Cue:Cat(TM) wand scanner. PR: 22104 Submitted by: mwm@mired.org
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/cuecat/Makefile34
-rw-r--r--misc/cuecat/distinfo1
-rw-r--r--misc/cuecat/pkg-comment1
-rw-r--r--misc/cuecat/pkg-descr7
-rw-r--r--misc/cuecat/pkg-plist3
6 files changed, 47 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index d9004494817c..6c57892aa167 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -32,6 +32,7 @@
SUBDIR += colortail
SUBDIR += crosspad
SUBDIR += cstream
+ SUBDIR += cuecat
SUBDIR += cwish
SUBDIR += deco
SUBDIR += dejagnu
diff --git a/misc/cuecat/Makefile b/misc/cuecat/Makefile
new file mode 100644
index 000000000000..aec47802812c
--- /dev/null
+++ b/misc/cuecat/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cuecat
+# Date created: 18 October 2000
+# Whom: mwm@mired.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cuecat
+PORTVERSION= 1.0
+CATEGORIES= misc python
+MASTER_SITES= http://www.mired.org/downloads/ \
+ http://mwm.tzo.com/downloads/
+
+MAINTAINER= mwm@mired.org
+
+NO_BUILD= yes
+MAN1= cuecat.1
+USE_PYTHON= yes
+WRKSRC= ${WRKDIR}/cuecat
+
+pre-install:
+ @${MV} ${WRKSRC}/cuecat.py ${WRKSRC}/cuecat.py-orig
+ @${SED} 's;/usr/opt;${PREFIX};' ${WRKSRC}/cuecat.py-orig >${WRKSRC}/cuecat.py
+ @${MV} ${WRKSRC}/barcode.py ${WRKSRC}/barcode.py-orig
+ @${SED} 's;/usr/opt;${PREFIX};' ${WRKSRC}/barcode.py-orig >${WRKSRC}/barcode.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cuecat.py ${PYTHON_SITELIBDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/barcode.py ${PYTHON_SITELIBDIR}
+ python -O -c "import barcode, cuecat"
+ ${LN} -sf ${PYTHON_SITELIBDIR}/cuecat.py ${PREFIX}/bin/cuecat
+ ${INSTALL_MAN} ${WRKSRC}/cuecat.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/misc/cuecat/distinfo b/misc/cuecat/distinfo
new file mode 100644
index 000000000000..b47e0665aee0
--- /dev/null
+++ b/misc/cuecat/distinfo
@@ -0,0 +1 @@
+MD5 (cuecat-1.0.tar.gz) = 474e3a58394a47575d45424955e74165
diff --git a/misc/cuecat/pkg-comment b/misc/cuecat/pkg-comment
new file mode 100644
index 000000000000..26e55dafff01
--- /dev/null
+++ b/misc/cuecat/pkg-comment
@@ -0,0 +1 @@
+Tools for decoding and using the output of a :Cue:Cat(TM) wand scanner
diff --git a/misc/cuecat/pkg-descr b/misc/cuecat/pkg-descr
new file mode 100644
index 000000000000..35650a2b2b26
--- /dev/null
+++ b/misc/cuecat/pkg-descr
@@ -0,0 +1,7 @@
+The cuecat script repeatedly reads scan codes from a :Cue:Cat scanner
+via standard input, decodes and processes the scanned value, then
+prompts with Scan! for another scan code. It exists when it reads an
+EOF on standard input.
+
+It can be used print a decoded version of the scan code, or launch
+commands the barcodes, ISBNs or UPCs scanned in.
diff --git a/misc/cuecat/pkg-plist b/misc/cuecat/pkg-plist
new file mode 100644
index 000000000000..3ab139472ab2
--- /dev/null
+++ b/misc/cuecat/pkg-plist
@@ -0,0 +1,3 @@
+bin/cuecat
+lib/%%PYTHON_VERSION%%/site-packages/cuecat.py
+lib/%%PYTHON_VERSION%%/site-packages/barcode.py