aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-11-06 22:57:53 +0800
committergahr <gahr@FreeBSD.org>2013-11-06 22:57:53 +0800
commitd3bdf369e0959e3ff6e22794d3e5ae2cc96a4d74 (patch)
treec8c88bed5fbaf66535ab5e72caa6673e26266c2c /misc
parented72409e3d9567e4942496c5e7bd99af91e3a0b9 (diff)
downloadfreebsd-ports-gnome-d3bdf369e0959e3ff6e22794d3e5ae2cc96a4d74.tar.gz
freebsd-ports-gnome-d3bdf369e0959e3ff6e22794d3e5ae2cc96a4d74.tar.zst
freebsd-ports-gnome-d3bdf369e0959e3ff6e22794d3e5ae2cc96a4d74.zip
- Convert to USES+=tk
- STAGE-clean
Diffstat (limited to 'misc')
-rw-r--r--misc/tkinfo/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/misc/tkinfo/Makefile b/misc/tkinfo/Makefile
index 5a25c8c1751f..a089d8a806d3 100644
--- a/misc/tkinfo/Makefile
+++ b/misc/tkinfo/Makefile
@@ -13,19 +13,18 @@ COMMENT= Tk script to read GNU "info" files and display them
LICENSE= BSD
NO_BUILD= yes
+USES+= tk
-USE_TK_WRAPPER= yes
+PLIST_FILES= bin/tkinfo \
+ man/man1/tkinfo.1.gz
-MAN1= tkinfo.1
-PLIST_FILES= bin/tkinfo
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
- 's|/usr/local/info|${LOCALBASE}/info|' ${WRKSRC}/tkinfo
+ 's|/usr/local/info|${LOCALBASE}/info|; \
+ s|exec wish|exec ${WISH}|' ${WRKSRC}/tkinfo
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/tkinfo ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/tkinfo.1 ${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/tkinfo ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/tkinfo.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>