aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-11-28 13:57:36 +0800
committeredwin <edwin@FreeBSD.org>2005-11-28 13:57:36 +0800
commitf0ac21373e586b0149450b0ac50cd2255d0bfcf3 (patch)
tree7811b3b3634383031fe4f50d594dcea2d1bd25af /misc
parentfa3ace3324e9a47e64782ec58150d1d2b5c49c36 (diff)
downloadfreebsd-ports-gnome-f0ac21373e586b0149450b0ac50cd2255d0bfcf3.tar.gz
freebsd-ports-gnome-f0ac21373e586b0149450b0ac50cd2255d0bfcf3.tar.zst
freebsd-ports-gnome-f0ac21373e586b0149450b0ac50cd2255d0bfcf3.zip
This port is simlar to misc/instant-workstation or misc/instant-server.
It creates a whole lot of often used ports, so that after a cvsup on a tinderbox build system, you can just tinderbuild this port and all primary dependencies are updated. If you think a port is missing, let me know! Author: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/instant-tinderbox/Makefile73
-rw-r--r--misc/instant-tinderbox/pkg-descr8
3 files changed, 82 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index b02ea18255ad..1c7805f98462 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -159,6 +159,7 @@
SUBDIR += hulgalugha
SUBDIR += inplace
SUBDIR += instant-server
+ SUBDIR += instant-tinderbox
SUBDIR += instant-workstation
SUBDIR += iselect
SUBDIR += iso-codes
diff --git a/misc/instant-tinderbox/Makefile b/misc/instant-tinderbox/Makefile
new file mode 100644
index 000000000000..f3088c3a3ace
--- /dev/null
+++ b/misc/instant-tinderbox/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: instant-tinderbox
+# Date created: 28 November 2005
+# Whom: Edwin Groothuis
+#
+# $FreeBSD$
+#
+
+PORTNAME= instant-tinderbox
+PORTVERSION= 1.0
+CATEGORIES= misc
+DISTFILES=
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= Build a whole bunch of often-required ports for a tinderbox environment
+
+###############################################################################
+
+USE_SDL= ${_USE_SDL_ALL}
+
+USE_GNOME= gnomelibs
+
+USE_KDELIBS_VER= 3
+USE_QT_VER= 3
+
+USE_MYSQL= yes
+USE_PGSQL= yes
+USE_BDB= yes
+USE_SQLITE= yes
+
+USE_APACHE= yes
+
+WANT_PHP_PEAR= yes
+USE_PHP= yes
+
+USE_TCL= yes
+USE_TK= yes
+
+USE_XLIB= yes
+USE_PERL5= yes
+
+USE_ICONV= yes
+USE_GETTEXT= yes
+
+USE_GMAKE= yes
+
+USE_GHOSTSCRIPT=yes
+USE_BISON= yes
+USE_FREETYPE= yes
+USE_GL= yes
+USE_XPM= yes
+USE_OPENLDAP= yes
+USE_FAM= yes
+USE_PYTHON= yes
+USE_RUBY= yes
+USE_LINUX= yes
+
+.for v in 213 253 259
+RUN_DEPENDS+= autoconf${v}:${PORTSDIR}/devel/autoconf${v}
+.endfor
+.for v in 14 15 19
+RUN_DEPENDS+= automake${v}:${PORTSDIR}/devel/automake${v}
+.endfor
+
+###############################################################################
+
+NO_BUILD= yes
+PLIST_FILES=
+NO_WRKSUBDIR= yes
+
+do-install:
+ ${DO_NADA}
+
+.include <bsd.port.mk>
diff --git a/misc/instant-tinderbox/pkg-descr b/misc/instant-tinderbox/pkg-descr
new file mode 100644
index 000000000000..5bafc6674c29
--- /dev/null
+++ b/misc/instant-tinderbox/pkg-descr
@@ -0,0 +1,8 @@
+This port is simlar to misc/instant-workstation or misc/instant-server.
+It creates a whole lot of often used ports, so that after a cvsup
+on a tinderbox build system, you can just tinderbuild this port and
+all primary dependencies are updated.
+
+If you think a port is missing, let me know!
+
+Author: Edwin Groothuis <edwin@mavetju.org>