aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-06-18 11:13:01 +0800
committeryuri <yuri@FreeBSD.org>2018-06-18 11:13:01 +0800
commitfef3d02fc15ae16547472eb1f71f009a47f998c0 (patch)
treea8ee6d970f06d8b22ada2195612db867c69caf1f /misc
parentb6774614810200f73cee68b4c786f5a64e03b596 (diff)
downloadfreebsd-ports-gnome-fef3d02fc15ae16547472eb1f71f009a47f998c0.tar.gz
freebsd-ports-gnome-fef3d02fc15ae16547472eb1f71f009a47f998c0.tar.zst
freebsd-ports-gnome-fef3d02fc15ae16547472eb1f71f009a47f998c0.zip
New port: misc/py-soapy_power: Obtain power spectrum from SoapySDR devices
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-soapy_power/Makefile23
-rw-r--r--misc/py-soapy_power/distinfo3
-rw-r--r--misc/py-soapy_power/pkg-descr4
4 files changed, 31 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 7b3e59a701e4..114a08068981 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -429,6 +429,7 @@
SUBDIR += py-qt5-demo
SUBDIR += py-scikit-fusion
SUBDIR += py-serverfiles
+ SUBDIR += py-soapy_power
SUBDIR += py-socli
SUBDIR += py-spdx
SUBDIR += py-spdx-lookup
diff --git a/misc/py-soapy_power/Makefile b/misc/py-soapy_power/Makefile
new file mode 100644
index 000000000000..5fd1d6096697
--- /dev/null
+++ b/misc/py-soapy_power/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= soapy_power
+DISTVERSION= 1.6.1
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Obtain power spectrum from SoapySDR devices
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pyFFTW>0:math/py-pyFFTW@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}SimpleSoapy>=1.5.0:misc/py-SimpleSoapy@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}SimpleSpectral>0:science/py-SimpleSpectral@${FLAVOR}
+
+USES= python:3.4+
+USE_PYTHON= distutils concurrent autoplist
+
+.include <bsd.port.mk>
diff --git a/misc/py-soapy_power/distinfo b/misc/py-soapy_power/distinfo
new file mode 100644
index 000000000000..ea10338da46c
--- /dev/null
+++ b/misc/py-soapy_power/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529288619
+SHA256 (soapy_power-1.6.1.tar.gz) = b5e54841ac2aa85addd60c11077efedad1800a27b998e90fbc656fcc9eaf52e5
+SIZE (soapy_power-1.6.1.tar.gz) = 18956
diff --git a/misc/py-soapy_power/pkg-descr b/misc/py-soapy_power/pkg-descr
new file mode 100644
index 000000000000..8efdc727f14c
--- /dev/null
+++ b/misc/py-soapy_power/pkg-descr
@@ -0,0 +1,4 @@
+Obtain power spectrum from SoapySDR devices
+(RTL-SDR, Airspy, SDRplay, HackRF, bladeRF, USRP, LimeSDR, etc.)
+
+WWW: https://github.com/xmikos/soapy_power