aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/audacious-plugins/Makefile
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-03-16 19:03:15 +0800
committernovel <novel@FreeBSD.org>2006-03-16 19:03:15 +0800
commit9f59aeef9d2264d11f7f615c3fd5e750b24dbfdf (patch)
treea0e91052f3eddbe1accc6233e5683aa7bb73d980 /multimedia/audacious-plugins/Makefile
parentbdf0e35c09a6be23bb2189cbacdf98add0759931 (diff)
downloadfreebsd-ports-gnome-9f59aeef9d2264d11f7f615c3fd5e750b24dbfdf.tar.gz
freebsd-ports-gnome-9f59aeef9d2264d11f7f615c3fd5e750b24dbfdf.tar.zst
freebsd-ports-gnome-9f59aeef9d2264d11f7f615c3fd5e750b24dbfdf.zip
Update to 0.2.2.
PR: 94129 Submitted by: maintainer
Diffstat (limited to 'multimedia/audacious-plugins/Makefile')
-rw-r--r--multimedia/audacious-plugins/Makefile41
1 files changed, 9 insertions, 32 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index a9f68f00eae2..50e90a5283ae 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= audacious
-PORTVERSION= 0.2
-PORTREVISION= 1
+PORTVERSION= 0.2.2
CATEGORIES= multimedia audio
MASTER_SITES= http://audacious-media-player.org/release/ \
${MASTER_SITE_LOCAL}
@@ -18,7 +17,10 @@ EXTRACT_SUFX=.tgz
MAINTAINER= redchrom@gmail.com
COMMENT= A media player based on BMP and XMMS
-LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile \
+ musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
+ curl.3:${PORTSDIR}/ftp/curl \
+ FLAC:${PORTSDIR}/audio/flac
USE_GNOME= gtk20 libglade2
WANT_GNOME= yes
@@ -37,16 +39,15 @@ MAN1= audacious.1
PORTDOCS= README AUTHORS ChangeLog NEWS
-INPUT_PLUGINS= cdaudio,mpg123,wav,tonegen,wma,console,sexypsf
-OUTPUT_PLUGINS= OSS,disk_writer,crossfade
+INPUT_PLUGINS= cdaudio mpg123 wav tonegen wma console \
+ sexypsf aac timidity flac
+OUTPUT_PLUGINS= OSS disk_writer
VISUALIZATION_PLUGINS= blur_scope
OPTIONS= VORBIS "Enable Ogg Vorbis input" on \
- FLAC "Enable flac input" on \
MODPLUG "Enable modplug input" off \
MPC "Enable mpc input" off \
ESOUND "Enable Esound output" off \
- VISUAL "Enable libvisual plugin" off \
ID3V2 "Enable id3v2 editing" off \
SIMD "Build with x86 SIMD(3DNow!/MMX) instructions support" on \
SDL "Enable SDL support" off \
@@ -63,15 +64,6 @@ CONFIGURE_ARGS+= --disable-vorbis
PLIST_SUB+= VORBISPLUGIN="@comment "
.endif
-.if !defined(WITHOUT_FLAC)
-INPUT_PLUGINS+= flac
-PLIST_SUB+= FLACPLUGIN=""
-LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
-.else
-PLIST_SUB+= FLACPLUGIN="@comment "
-CONFIGURE_ARGS+= --disable-flac
-.endif
-
.if !defined(WITHOUT_MODPLUG)
INPUT_PLUGINS+= modplug
PLIST_SUB+= MODPLUG=""
@@ -105,14 +97,6 @@ CONFIGURE_ARGS+= --disable-esd
PLIST_SUB+= ESDPLUGIN="@comment "
.endif
-.if defined(WITH_VISUAL)
-PLIST_SUB+= LIBVISUAL=""
-VISUALIZATION_PLUGINS+= libvisual-proxy
-LIB_DEPENDS+= visual.0:${PORTSDIR}/graphics/libvisual
-.else
-PLIST_SUB+= LIBVISUAL="@comment "
-.endif
-
.if defined(WITH_ID3V2)
LIB_DEPENDS+= id3-3.8.3:${PORTSDIR}/audio/id3lib
.endif
@@ -135,7 +119,7 @@ CONFIGURE_ARGS+= --enable-gnome-vfs --enable-gconf
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ @${REINPLACE_CMD} -e 's|(LIBDIR)/pkgconfig|(prefix)/libdata/pkgconfig|g' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},g' \
${WRKSRC}/configure
@@ -148,13 +132,6 @@ post-install:
@${ECHO_MSG} "ALL PRESETS will be storing in the gconf database."
@${ECHO_MSG} ""
.endif
-.if defined(WITH_VISUAL)
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You have installed audacious with libvisual support."
- @${ECHO_MSG} "If you want to be able to access any visualizations,"
- @${ECHO_MSG} "you must install the graphics/libvisual-plugins port."
- @${ECHO_MSG} ""
-.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for i in README AUTHORS ChangeLog NEWS