aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/audacious-plugins
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2006-12-05 13:59:33 +0800
committeroliver <oliver@FreeBSD.org>2006-12-05 13:59:33 +0800
commitef11622ed259d1d5dbd4408d1ae8b476b3d7d245 (patch)
tree876928328aa2ce68b3b6e0f1dd62c579664b866b /multimedia/audacious-plugins
parent866e52419361e4e769a2f890d2da7372996099b2 (diff)
downloadfreebsd-ports-gnome-ef11622ed259d1d5dbd4408d1ae8b476b3d7d245.tar.gz
freebsd-ports-gnome-ef11622ed259d1d5dbd4408d1ae8b476b3d7d245.tar.zst
freebsd-ports-gnome-ef11622ed259d1d5dbd4408d1ae8b476b3d7d245.zip
properly fix for FreeBSD 4
Diffstat (limited to 'multimedia/audacious-plugins')
-rw-r--r--multimedia/audacious-plugins/Makefile2
-rw-r--r--multimedia/audacious-plugins/files/patch-src-scrobbler-xmms_scrobbler.c13
2 files changed, 13 insertions, 2 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index bfa63cb43e81..160c9d1d4e4e 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -107,8 +107,6 @@ post-patch:
${WRKSRC}/src/alac/stream.h ${WRKSRC}/src/alac/demux.c \
${WRKSRC}/src/alac/demux.h ${WRKSRC}/src/alac/stream.c \
${WRKSRC}/src/aac/mp4ff/mp4ff_int_types.h
- @${REINPLACE_CMD} -e 's| going = 1|int &|' \
- ${WRKSRC}/src/scrobbler/xmms_scrobbler.c
.endif
post-install:
diff --git a/multimedia/audacious-plugins/files/patch-src-scrobbler-xmms_scrobbler.c b/multimedia/audacious-plugins/files/patch-src-scrobbler-xmms_scrobbler.c
new file mode 100644
index 000000000000..b6bfa605386e
--- /dev/null
+++ b/multimedia/audacious-plugins/files/patch-src-scrobbler-xmms_scrobbler.c
@@ -0,0 +1,13 @@
+--- src/scrobbler/xmms_scrobbler.c.orig Mon Dec 4 16:14:52 2006
++++ src/scrobbler/xmms_scrobbler.c Tue Dec 5 06:21:00 2006
+@@ -60,8 +60,9 @@
+ {
+ char *username = NULL, *password = NULL;
+ ConfigDb *cfgfile;
+- going = 1;
+ GError **moo = NULL;
++
++ going = 1;
+ cfgdlg = create_cfgdlg();
+
+ prefswin_page_new(cfgdlg, "Last.FM", DATA_DIR "/images/audioscrobbler.png");