aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/audacious-plugins
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2010-04-19 18:59:37 +0800
committeroliver <oliver@FreeBSD.org>2010-04-19 18:59:37 +0800
commitd3d9923341e527cfbf112bc59e5dd2cb06bde1cf (patch)
tree90f9972697f9ffb0884b04d1d52477079088c63f /multimedia/audacious-plugins
parent6258613c3c402b1d7b5730e8a607d26dbb258755 (diff)
downloadfreebsd-ports-gnome-d3d9923341e527cfbf112bc59e5dd2cb06bde1cf.tar.gz
freebsd-ports-gnome-d3d9923341e527cfbf112bc59e5dd2cb06bde1cf.tar.zst
freebsd-ports-gnome-d3d9923341e527cfbf112bc59e5dd2cb06bde1cf.zip
update audacious to 2.3
bump PORTREVISION on the affected ports
Diffstat (limited to 'multimedia/audacious-plugins')
-rw-r--r--multimedia/audacious-plugins/Makefile36
-rw-r--r--multimedia/audacious-plugins/distinfo6
-rw-r--r--multimedia/audacious-plugins/pkg-plist10
3 files changed, 23 insertions, 29 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index 8d7818b5393d..7c92635c2220 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= audacious-plugins
-PORTVERSION= 2.2
-PORTREVISION= 5
+PORTVERSION= 2.3
CATEGORIES= multimedia audio
MASTER_SITES= http://distfiles.atheme.org/
EXTRACT_SUFX= .tgz
@@ -60,11 +59,10 @@ OPTIONS= DBUS "Enable dbus support" on \
MMS "Enable mms support" off \
MTP "Enable MTP upload support" off \
PARANORMAL "Enable paranormal vis plugin" on \
- XSPF "Enable XSPF support" on \
GNOME "Build with gnomevfs/gconf support" off \
NLS "Native Language Support" on \
- CURL "curl for lastfm/scrobbler support" off \
- SSE2 "Enable SSE2 support" on
+ SSE2 "Enable SSE2 support" on \
+ RESAMPLE "Enable resample support" off
.include <bsd.port.pre.mk>
@@ -301,33 +299,26 @@ CONFIGURE_ARGS+=--disable-mtp_up
PLIST_SUB+= MTPPLUGIN="@comment "
.endif
-.if !defined(WITHOUT_XSPF)
-USE_GNOME+= libxml2
-CONFIGURE_ARGS+=--enable-xspf
-PLIST_SUB+= XSPFPLUGIN=""
-.else
-CONFIGURE_ARGS+=--disable-xspf
-PLIST_SUB+= XSPFPLUGIN="@comment "
-.endif
-
.if defined(WITH_GNOME)
USE_GNOME+= gnomevfs2 gconf2
CONFIGURE_ARGS+=--enable-gnome-vfs --enable-gconf
.endif
-.if !defined(WITHOUT_CURL) || exists(${LOCALBASE}/lib/libcurl.so)
-LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
-PLIST_SUB+= CURLPLUGIN=""
-.else
-PLIST_SUB+= CURLPLUGIN="@comment "
-.endif
-
.if !defined(WITHOUT_SSE2)
CONFIGURE_ARGS+=--disable-sse2
.else
CONFIGURE_ARGS+=--enable-sse2
.endif
+.if !defined(WITHOUT_RESAMPLE)
+LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
+CONFIGURE_ARGS+=--enable-resample
+PLIST_SUB+= RESAMPLEPLUGIN=""
+.else
+CONFIGURE_ARGS+=--disable-resample
+PLIST_SUB+= RESAMPLEPLUGIN="@comment "
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
@@ -347,6 +338,9 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|$$EGREP|egrep|g; \
s| -ldl||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|malloc\.h|stdlib\.h|g' \
+ ${WRKSRC}/src/neon/cert_verification.c \
+ ${WRKSRC}/src/usf/memory.c
pre-configure:
.if defined(WITH_AUDIOCD) && !exists(${LOCALBASE}/lib/libcdio_cdda.so)
diff --git a/multimedia/audacious-plugins/distinfo b/multimedia/audacious-plugins/distinfo
index 0fa721069fc0..006ecd604d0d 100644
--- a/multimedia/audacious-plugins/distinfo
+++ b/multimedia/audacious-plugins/distinfo
@@ -1,3 +1,3 @@
-MD5 (audacious-plugins-2.2.tgz) = ed6790bf5667c824eda72301f0a886a8
-SHA256 (audacious-plugins-2.2.tgz) = aee812b34aa057bfff9e38dda29f1261e8e8cbdde65cf5fe553ab6b6a9ae33c8
-SIZE (audacious-plugins-2.2.tgz) = 3135776
+MD5 (audacious-plugins-2.3.tgz) = de350b7612ff42e3719ae19a36389118
+SHA256 (audacious-plugins-2.3.tgz) = 7da44d2aaccceea6ad838a8b677abd5f3e5e10ad168f6f478d3e5e2c4aacaa41
+SIZE (audacious-plugins-2.3.tgz) = 3273590
diff --git a/multimedia/audacious-plugins/pkg-plist b/multimedia/audacious-plugins/pkg-plist
index d565a8e43959..6d1e0f7bbc7a 100644
--- a/multimedia/audacious-plugins/pkg-plist
+++ b/multimedia/audacious-plugins/pkg-plist
@@ -1,20 +1,21 @@
lib/audacious/Container/m3u.so
lib/audacious/Container/pls.so
-%%XSPFPLUGIN%%lib/audacious/Container/xspf.so
-lib/audacious/Effect/audiocompress.so
+lib/audacious/Container/xspf.so
+lib/audacious/Effect/compressor.so
lib/audacious/Effect/crystalizer.so
lib/audacious/Effect/ladspa.so
lib/audacious/Effect/echo.so
+%%RESAMPLEPLUGIN%%lib/audacious/Effect/resample.so
lib/audacious/Effect/sndstretch.so
lib/audacious/Effect/stereo.so
lib/audacious/Effect/voice_removal.so
lib/audacious/General/alarm.so
%%AOSDPLUGIN%%lib/audacious/General/aosd.so
+%%CDAUDIOPLUGIN%%lib/audacious/General/cd-menu-items.so
%%DBUS%%lib/audacious/General/gnomeshortcuts.so
lib/audacious/General/gtkui.so
lib/audacious/General/hotkey.so
%%LIRCPLUGIN%%lib/audacious/General/lirc.so
-%%CURLPLUGIN%%lib/audacious/General/scrobbler.so
lib/audacious/General/skins.so
lib/audacious/General/song_change.so
%%STATUSICONPLUGIN%%lib/audacious/General/statusicon.so
@@ -86,8 +87,6 @@ lib/audacious/Visualization/spectrum.so
%%PARANORMALPLUGIN%%share/audacious/paranormal/Presets/nenolod_-_worms.pnv
%%PARANORMALPLUGIN%%share/audacious/paranormal/Presets/ticpu_-_colored_beat-o-scope.pnv
%%PARANORMALPLUGIN%%share/audacious/paranormal/Presets/aerdan_-_bloody_vortex.pnv
-%%CURLPLUGIN%%share/audacious/images/audioscrobbler.png
-%%CURLPLUGIN%%share/audacious/images/audioscrobbler_badge.png
share/audacious/images/bookmarks.png
share/audacious/images/shoutcast.png
share/audacious/images/streambrowser-16x16.png
@@ -312,6 +311,7 @@ share/audacious/Skins/TinyPlayer/volume.png
%%NLS%%share/locale/cy/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/de/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/et/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/fr/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/ja/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/lv/LC_MESSAGES/audacious-plugins.mo