aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/avifile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-04-03 16:14:43 +0800
committerwill <will@FreeBSD.org>2001-04-03 16:14:43 +0800
commite282c995211fa7d389e4d3b437d0ff892d4d929b (patch)
treec8e1217a1b00314713ec60f3c0d07c11dc242116 /multimedia/avifile
parenta4c43b9975be01621916750b073e7125e629feba (diff)
downloadfreebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.tar.gz
freebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.tar.zst
freebsd-ports-gnome-e282c995211fa7d389e4d3b437d0ff892d4d929b.zip
Overhaul QT/KDE support:
- bsd.port.mk update to use bsd.kde.mk for USE_{QT,KDE}* - Cleanup corresponding ports for bsd.kde.mk update. - Fix bsd.kde.mk: use correct kdelibs dependency, put qt at the bottom, introduce QT_NONSTANDARD variable for nonstandard configure setup. - Update KDE2 to 2.1.1. Two patches included in x11/kdelibs2 to fix the proxy authentication that was broken for 2.1.1. Remove old patches. - Potentially fix kdelibs build for alpha. - Fix qt-designer 2.3.0 build. - Ruby stuff left alone since it looks like black magic to me. Should still work w/ compat shims for older USE_QT[,2] style. Some others were also left alone for the same reason. Reviewed by: portmgr, ports (bsd.kde.mk+bsd.port.mk) Submitted by: David Faure <faure@kde.org> (proxy auth patches) Alex Zepeda <garbanzo@kde.org> (old patches removal)
Diffstat (limited to 'multimedia/avifile')
-rw-r--r--multimedia/avifile/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/multimedia/avifile/Makefile b/multimedia/avifile/Makefile
index 5a41ad1ef4a2..f1476632e523 100644
--- a/multimedia/avifile/Makefile
+++ b/multimedia/avifile/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl-devel
RUN_DEPENDS= ${CODEC_DETECTION_FILE}:${CODEC_PORT}
ONLY_FOR_ARCHS= i386
-USE_QT2= yes
+USE_QT_VER= 2
USE_XLIB= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
@@ -28,11 +28,8 @@ USE_AUTOCONF= yes
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- MOC="${MOC}" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib \
- --with-win32-path=${LOCALBASE}/lib/win32 \
+CONFIGURE_ARGS= --with-win32-path=${LOCALBASE}/lib/win32 \
--enable-release
PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
@@ -50,7 +47,6 @@ LIB_VERSION= 0
EXTRA_BUILD_DIR= player samples/benchmark samples/qtrecompress
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-MOC?= ${X11BASE}/bin/moc2
DIFF?= /usr/bin/diff
.include <bsd.port.pre.mk>