aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/banshee/files
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2012-10-07 06:04:05 +0800
committerromain <romain@FreeBSD.org>2012-10-07 06:04:05 +0800
commitff87e77a727420c73673572ac41b6852c2da92be (patch)
tree9c981d85eb157b140a3c87d3392d4a81084461e5 /multimedia/banshee/files
parent9629249b189e86af37c9dcc44a6186ea4d1c6748 (diff)
downloadfreebsd-ports-gnome-ff87e77a727420c73673572ac41b6852c2da92be.tar.gz
freebsd-ports-gnome-ff87e77a727420c73673572ac41b6852c2da92be.tar.zst
freebsd-ports-gnome-ff87e77a727420c73673572ac41b6852c2da92be.zip
Looks like recent banshee does not freeze randomly, so:
- Update to 2.6.0; - Remove IGNORE \o/.
Diffstat (limited to 'multimedia/banshee/files')
-rw-r--r--multimedia/banshee/files/patch-src_Backends_Banshee.Gio_Makefile.in14
-rw-r--r--multimedia/banshee/files/patch-src_Clients_Booter_banshee.linux.in14
-rw-r--r--multimedia/banshee/files/patch-src_Libraries_MusicBrainz_Makefile.in13
-rw-r--r--multimedia/banshee/files/patch-src_Libraries_MusicBrainz_MusicBrainz_DiscFreeBSD.cs140
-rw-r--r--multimedia/banshee/files/patch-src_Libraries_MusicBrainz_MusicBrainz_LocalDisc.cs21
5 files changed, 28 insertions, 174 deletions
diff --git a/multimedia/banshee/files/patch-src_Backends_Banshee.Gio_Makefile.in b/multimedia/banshee/files/patch-src_Backends_Banshee.Gio_Makefile.in
new file mode 100644
index 000000000000..0c166d2fb817
--- /dev/null
+++ b/multimedia/banshee/files/patch-src_Backends_Banshee.Gio_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/Backends/Banshee.Gio/Makefile.in.orig
++++ src/Backends/Banshee.Gio/Makefile.in
+@@ -946,7 +946,7 @@
+ @ENABLE_GIO_TRUE@ cp $(srcdir)/$(notdir $@.config) $(top_builddir)/bin; \
+ @ENABLE_GIO_TRUE@ fi;
+ @ENABLE_GIO_TRUE@ @if [ ! -z "$(EXTRA_BUNDLE)" ]; then \
+-@ENABLE_GIO_TRUE@ cp $(EXTRA_BUNDLE) $(top_builddir)/bin; \
++@ENABLE_GIO_TRUE@ cp -f $(EXTRA_BUNDLE) $(top_builddir)/bin; \
+ @ENABLE_GIO_TRUE@ fi;
+
+ @ENABLE_GIO_TRUE@theme-icons: $(THEME_ICONS_SOURCE)
diff --git a/multimedia/banshee/files/patch-src_Clients_Booter_banshee.linux.in b/multimedia/banshee/files/patch-src_Clients_Booter_banshee.linux.in
new file mode 100644
index 000000000000..7257b8f250d6
--- /dev/null
+++ b/multimedia/banshee/files/patch-src_Clients_Booter_banshee.linux.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/Clients/Booter/banshee.linux.in.orig
++++ src/Clients/Booter/banshee.linux.in
+@@ -54,7 +54,7 @@
+ fi
+
+ # Finally - environment is set up, time to run our beloved
+-exec_args="-a $BANSHEE_EXEC_NAME mono $MONO_OPTIONS $MONO_EXE $BANSHEE_DEBUG $BANSHEE_CLIENT"
++exec_args="-a $BANSHEE_EXEC_NAME mono --runtime=v4.0 $MONO_OPTIONS $MONO_EXE $BANSHEE_DEBUG $BANSHEE_CLIENT"
+
+ if [ -z "$BANSHEE_REDIRECT_LOG" ]; then
+ exec $exec_args "$@"
diff --git a/multimedia/banshee/files/patch-src_Libraries_MusicBrainz_Makefile.in b/multimedia/banshee/files/patch-src_Libraries_MusicBrainz_Makefile.in
deleted file mode 100644
index e1cabfda35ed..000000000000
--- a/multimedia/banshee/files/patch-src_Libraries_MusicBrainz_Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- src/Libraries/MusicBrainz/Makefile.in.orig
-+++ src/Libraries/MusicBrainz/Makefile.in
-@@ -347,6 +347,7 @@
- SOURCES = \
- MusicBrainz/Artist.cs \
- MusicBrainz/Disc.cs \
-+ MusicBrainz/DiscFreeBSD.cs \
- MusicBrainz/DiscLinux.cs \
- MusicBrainz/DiscWin32.cs \
- MusicBrainz/Event.cs \
diff --git a/multimedia/banshee/files/patch-src_Libraries_MusicBrainz_MusicBrainz_DiscFreeBSD.cs b/multimedia/banshee/files/patch-src_Libraries_MusicBrainz_MusicBrainz_DiscFreeBSD.cs
deleted file mode 100644
index 7c6464c12b28..000000000000
--- a/multimedia/banshee/files/patch-src_Libraries_MusicBrainz_MusicBrainz_DiscFreeBSD.cs
+++ /dev/null
@@ -1,140 +0,0 @@
-
-$FreeBSD$
-
---- /dev/null
-+++ src/Libraries/MusicBrainz/MusicBrainz/DiscFreeBSD.cs
-@@ -0,0 +1,134 @@
-+// DiskFreeBSD.cs
-+//
-+// Copyright (c) 2009 Romain Tartière <romain@blogreen.org>
-+//
-+// Permission is hereby granted, free of charge, to any person obtaining a copy
-+// of this software and associated documentation files (the "Software"), to deal
-+// in the Software without restriction, including without limitation the rights
-+// to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-+// copies of the Software, and to permit persons to whom the Software is
-+// furnished to do so, subject to the following conditions:
-+//
-+// The above copyright notice and this permission notice shall be included in
-+// all copies or substantial portions of the Software.
-+//
-+// THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+// IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+// FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-+// AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-+// LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-+// OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-+// THE SOFTWARE.
-+
-+using System;
-+using System.Runtime.InteropServices;
-+
-+namespace MusicBrainz
-+{
-+ internal sealed class DiscFreeBSD : LocalDisc
-+ {
-+
-+#region <fcntl.h>
-+ const int O_RDONLY = 0x0000; // open for reading only
-+ const int O_NONBLOCK = 0x0004; // no delay
-+
-+ [DllImport ("libc.so.7", CharSet = CharSet.Auto, SetLastError = true)]
-+ static extern int open (string path, int flags);
-+#endregion
-+
-+#region <unistd.h>
-+ [DllImport ("libc.so.7", SetLastError = true)]
-+ static extern int close (int d);
-+#endregion
-+
-+#region <sys/cdio.h>
-+ struct msf_lba {
-+ public int lba; // network byte order
-+ };
-+
-+ [StructLayout (LayoutKind.Explicit)]
-+ struct cd_toc_entry {
-+ [FieldOffset (2)]
-+ public byte track;
-+ [FieldOffset (4)]
-+ public msf_lba addr;
-+ };
-+
-+ // Ioctls for the CD drive
-+
-+ const byte CD_LBA_FORMAT = 1;
-+
-+ struct ioc_toc_header {
-+ public short len;
-+ public byte starting_track;
-+ public byte ending_track;
-+ };
-+ const ulong CDIOREADTOCHEADER = 1074029316;
-+ [DllImport ("libc.so.7", EntryPoint = "ioctl")]
-+ static extern int cd_read_toc_header (int fd, ulong request, ref ioc_toc_header data);
-+ static int cd_read_toc_header (int fd, ref ioc_toc_header data)
-+ {
-+ return cd_read_toc_header (fd, CDIOREADTOCHEADER, ref data);
-+ }
-+
-+ struct ioc_read_toc_entry {
-+ public byte address_format;
-+ public byte starting_track;
-+ public ushort data_len;
-+ public IntPtr data; // cd_toc_entry*
-+ };
-+ const ulong CDIOREADTOCENTRYS = 3222299397;
-+ [DllImport ("libc.so.7", EntryPoint = "ioctl")]
-+ static extern int cd_read_toc_entrys (int fd, ulong request, ref ioc_read_toc_entry data);
-+ static int cd_read_toc_entrys (int fd, ref ioc_read_toc_entry data)
-+ {
-+ return cd_read_toc_entrys (fd, CDIOREADTOCENTRYS, ref data);
-+ }
-+
-+#endregion
-+
-+ internal DiscFreeBSD (string device)
-+ {
-+ int fd = open (device, O_RDONLY | O_NONBLOCK);
-+
-+ if (fd < 0) throw new LocalDiscException (String.Format ("Cannot open device `{0}'", device));
-+
-+ try {
-+ ioc_toc_header h = new ioc_toc_header ();
-+ if (cd_read_toc_header (fd, ref h) < 0) throw new LocalDiscException ("Cannot read table of contents header");
-+ if (h.ending_track == 0) throw new LocalDiscException ("This disc has no tracks");
-+
-+ first_track = h.starting_track;
-+ last_track = h.ending_track;
-+
-+ int n = h.ending_track - h.starting_track + 1;
-+ int len = (n + 1) * Marshal.SizeOf (typeof (cd_toc_entry));
-+
-+ ioc_read_toc_entry t = new ioc_read_toc_entry ();
-+ t.address_format = CD_LBA_FORMAT;
-+ t.starting_track = 0;
-+ t.data_len = (ushort) len;
-+ t.data = Marshal.AllocHGlobal (len);
-+ try {
-+
-+ if (cd_read_toc_entrys (fd, ref t) < 0) throw new LocalDiscException ("Cannot read table of contents entries");
-+
-+ for (int i = 0; i <= n; i++) {
-+ ulong offset = (ulong) (i * Marshal.SizeOf (typeof (cd_toc_entry)));
-+ cd_toc_entry e = (cd_toc_entry) Marshal.PtrToStructure ((IntPtr) ((ulong)t.data + offset), typeof (cd_toc_entry));
-+ track_offsets[first_track + i] = System.Net.IPAddress.NetworkToHostOrder (e.addr.lba) + 150;
-+ }
-+ // Move Leadout to the beginning.
-+ track_offsets [0] = track_offsets [last_track + 1];
-+ track_offsets [last_track + 1] = 0;
-+ } finally {
-+ Marshal.FreeHGlobal (t.data);
-+ }
-+ } finally {
-+ close (fd);
-+ }
-+
-+ Init ();
-+ }
-+ }
-+}
diff --git a/multimedia/banshee/files/patch-src_Libraries_MusicBrainz_MusicBrainz_LocalDisc.cs b/multimedia/banshee/files/patch-src_Libraries_MusicBrainz_MusicBrainz_LocalDisc.cs
deleted file mode 100644
index 02c09fefe6b7..000000000000
--- a/multimedia/banshee/files/patch-src_Libraries_MusicBrainz_MusicBrainz_LocalDisc.cs
+++ /dev/null
@@ -1,21 +0,0 @@
-
-$FreeBSD$
-
---- src/Libraries/MusicBrainz/MusicBrainz/LocalDisc.cs.orig
-+++ src/Libraries/MusicBrainz/MusicBrainz/LocalDisc.cs
-@@ -133,11 +133,11 @@
- switch (Environment.OSVersion.Platform){
- case PlatformID.Unix:
- // TODO can we actually detect the environment?
-- //try {
-+ try {
- return new DiscLinux (device);
-- //} catch {
-- // return new DiscFreeBSD (device);
-- //}
-+ } catch {
-+ return new DiscFreeBSD (device);
-+ }
- //case PlatformID.Win32NT:
- //return new DiscWin32NT (device);
- default: