aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/clive/Makefile
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2008-05-15 23:50:51 +0800
committernivit <nivit@FreeBSD.org>2008-05-15 23:50:51 +0800
commit91a8a12991131d337091da1ff8537e348294b9df (patch)
tree95bcb58eab499e66fca734c3d107e62d388c0133 /multimedia/clive/Makefile
parentfd611a82febbcdcc188422f7a2c706c6a7f7691f (diff)
downloadfreebsd-ports-gnome-91a8a12991131d337091da1ff8537e348294b9df.tar.gz
freebsd-ports-gnome-91a8a12991131d337091da1ff8537e348294b9df.tar.zst
freebsd-ports-gnome-91a8a12991131d337091da1ff8537e348294b9df.zip
- Update to 0.4.12
- Add option WITH_NEWT (use devel/newt or bundled module) - Add other main features of the program in pkg-descr - Remove option WITH_RSSATOM
Diffstat (limited to 'multimedia/clive/Makefile')
-rw-r--r--multimedia/clive/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/multimedia/clive/Makefile b/multimedia/clive/Makefile
index 7964474d6f21..6bab04999daf 100644
--- a/multimedia/clive/Makefile
+++ b/multimedia/clive/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= clive
-PORTVERSION= 0.4.11
+PORTVERSION= 0.4.12
#PORTREVISION= 0
#PORTEPOCH= 0
CATEGORIES= multimedia
@@ -34,7 +34,7 @@ CONFIGURE_ARGS= --with-doc=no
OPTIONS= FFMPEG "Install ffmpeg for re-encoding" off \
MPLAYER "Install mplayer as video player" off \
- RSSATOM "Enable extraction videos from RSS/Atom feeds" on \
+ NEWT "Use devel/newt instead of bundled module" off \
SQLITE3 "Install sqlite3 for caching visited URLs" off \
VLC "Install vlc as video player" off \
XCLIP "Install xclip (read URLs from clipboard)" off
@@ -50,6 +50,17 @@ RUN_DEPENDS+= ffmpeg:${PORTSDIR}/multimedia/ffmpeg
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
.endif
+.if defined(WITH_NEWT)
+PLIST_SUB+= OPTNEWT="@comment "
+CONFIGURE_ARGS+= --with-newt=no
+LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
+RUN_DEPENDS+= newt${PYTHON_PKGNAMESUFFIX}>=0.51.0_4:${PORTSDIR}/devel/newt
+.else
+PLIST_SUB+= OPTNEWT=""
+LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PYTHON_INCLUDEDIR} $${CPPFLAGS}" LDFLAGS="-L${LOCALBASE}/lib $${LDFLAGS} -L${PYTHON_LIBDIR}" SLANG_LIBS="-lncurses -lslang"
+.endif
+
.if defined(WITH_SQLITE3)
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.5.2_1:${PORTSDIR}/databases/py-sqlite3
.endif
@@ -62,13 +73,4 @@ RUN_DEPENDS+= vlc:${PORTSDIR}/multimedia/vlc
RUN_DEPENDS+= xclip:${PORTSDIR}/x11/xclip
.endif
-.if defined(WITH_RSSATOM)
-PLIST_SUB+= OPTRSSATOM=""
-LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PYTHON_INCLUDEDIR} $${CPPFLAGS}" LDFLAGS="-L${LOCALBASE}/lib $${LDFLAGS} -L${PYTHON_LIBDIR}" SLANG_LIBS="-lncurses -lslang"
-.else
-PLIST_SUB+= OPTRSSATOM="@comment "
-CONFIGURE_ARGS+= --with-newt=no
-.endif
-
.include <bsd.port.post.mk>