aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/clutter-gst
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-12-27 06:05:01 +0800
committermiwi <miwi@FreeBSD.org>2008-12-27 06:05:01 +0800
commit2927a8d7f8be6ab4714456b0edb53b037e903326 (patch)
tree243807611f163aa98253fad0aca3a2f122299aff /multimedia/clutter-gst
parentc33b5bd2579cf1c7569fa0b15db3bc6840137eb3 (diff)
downloadfreebsd-ports-gnome-2927a8d7f8be6ab4714456b0edb53b037e903326.tar.gz
freebsd-ports-gnome-2927a8d7f8be6ab4714456b0edb53b037e903326.tar.zst
freebsd-ports-gnome-2927a8d7f8be6ab4714456b0edb53b037e903326.zip
Clutter-GStreamer (clutter-gst) is an integration library for using GStreamer
with Clutter. Clutter is an open source software library for creating fast, visually rich and animated graphical user interfaces. It uses OpenGL for drawing primitives and has multiple backends, allowing its usage on different platforms. GStreamer is a streaming media framework, based on graphs of filters which operate on media data. Applications using this library can do anything from real-time sound processing to playing videos, and just about anything else media-related. Its plugin-based architecture means that new data types or processing capabilities can be added simply by installing new plug-ins. WWW: http://clutter-project.org/
Diffstat (limited to 'multimedia/clutter-gst')
-rw-r--r--multimedia/clutter-gst/Makefile29
-rw-r--r--multimedia/clutter-gst/distinfo3
-rw-r--r--multimedia/clutter-gst/pkg-descr16
-rw-r--r--multimedia/clutter-gst/pkg-plist32
4 files changed, 80 insertions, 0 deletions
diff --git a/multimedia/clutter-gst/Makefile b/multimedia/clutter-gst/Makefile
new file mode 100644
index 000000000000..278b1b836977
--- /dev/null
+++ b/multimedia/clutter-gst/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: clutter-gst
+# Date created: 2008-12-25
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clutter-gst
+PORTVERSION= 0.8.0
+CATEGORIES= multimedia
+MASTER_SITES= http://www.clutter-project.org/sources/${PORTNAME}/0.8/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Clutter GStreamer integration
+
+LIB_DEPENDS= clutter-glx-0.8:${PORTSDIR}/graphics/clutter
+
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gnomehack ltverhack gnomeprefix
+USE_GSTREAMER= yes
+USE_XORG= xp x11
+USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.include <bsd.port.mk>
diff --git a/multimedia/clutter-gst/distinfo b/multimedia/clutter-gst/distinfo
new file mode 100644
index 000000000000..d12d766cb656
--- /dev/null
+++ b/multimedia/clutter-gst/distinfo
@@ -0,0 +1,3 @@
+MD5 (clutter-gst-0.8.0.tar.gz) = 9ebf9bbe406757472952743ca01870f3
+SHA256 (clutter-gst-0.8.0.tar.gz) = 9e2ccee1380e6712997a6660ef41da8ca6f03d477244562b98d97c0e716a2458
+SIZE (clutter-gst-0.8.0.tar.gz) = 496402
diff --git a/multimedia/clutter-gst/pkg-descr b/multimedia/clutter-gst/pkg-descr
new file mode 100644
index 000000000000..e45e23ccdb1f
--- /dev/null
+++ b/multimedia/clutter-gst/pkg-descr
@@ -0,0 +1,16 @@
+Clutter-GStreamer (clutter-gst) is an integration library for using GStreamer
+with Clutter.
+
+Clutter is an open source software library for creating fast, visually
+rich and animated graphical user interfaces. It uses OpenGL for drawing
+primitives and has multiple backends, allowing its usage on different
+platforms.
+
+GStreamer is a streaming media framework, based on graphs of filters
+which operate on media data. Applications using this library can do
+anything from real-time sound processing to playing videos, and just
+about anything else media-related. Its plugin-based architecture means
+that new data types or processing capabilities can be added simply by
+installing new plug-ins.
+
+WWW: http://clutter-project.org/
diff --git a/multimedia/clutter-gst/pkg-plist b/multimedia/clutter-gst/pkg-plist
new file mode 100644
index 000000000000..764ec2380d4b
--- /dev/null
+++ b/multimedia/clutter-gst/pkg-plist
@@ -0,0 +1,32 @@
+include/clutter-0.8/clutter-gst/clutter-gst-audio.h
+include/clutter-0.8/clutter-gst/clutter-gst-shaders.h
+include/clutter-0.8/clutter-gst/clutter-gst-util.h
+include/clutter-0.8/clutter-gst/clutter-gst-version.h
+include/clutter-0.8/clutter-gst/clutter-gst-video-sink.h
+include/clutter-0.8/clutter-gst/clutter-gst-video-texture.h
+include/clutter-0.8/clutter-gst/clutter-gst.h
+lib/libclutter-gst-0.8.a
+lib/libclutter-gst-0.8.la
+lib/libclutter-gst-0.8.so
+lib/libclutter-gst-0.8.so.0
+libdata/pkgconfig/clutter-gst-0.8.pc
+%%DOCSDIR%%/ClutterGstAudio.html
+%%DOCSDIR%%/ClutterGstVideoSink.html
+%%DOCSDIR%%/ClutterGstVideoTexture.html
+%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/ch02.html
+%%DOCSDIR%%/clutter-gst-Utilities.html
+%%DOCSDIR%%/clutter-gst-Versioning-Macros.html
+%%DOCSDIR%%/clutter-gst.devhelp
+%%DOCSDIR%%/clutter-gst.devhelp2
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/license.html
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up.png
+@dirrmtry %%DOCSDIR%%
+@dirrm include/clutter-0.8/clutter-gst
+@dirrmtry include/clutter-0.8