aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/devede/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-26 20:35:50 +0800
committerbapt <bapt@FreeBSD.org>2013-04-26 20:35:50 +0800
commit3b719f87a14768433dc0cd06f301eeaf9c02fa43 (patch)
tree94d53c5c905021f480b1c80529f6919181c4c73b /multimedia/devede/Makefile
parent6ed47115f3cf9c141188528e8863513cfade4cd8 (diff)
downloadfreebsd-ports-gnome-3b719f87a14768433dc0cd06f301eeaf9c02fa43.tar.gz
freebsd-ports-gnome-3b719f87a14768433dc0cd06f301eeaf9c02fa43.tar.zst
freebsd-ports-gnome-3b719f87a14768433dc0cd06f301eeaf9c02fa43.zip
Remove USE_CDRTOOLS from bsd.port.mk
This macros has been useless since cdrtools-cjk port has gone. This macros also lead to badly handled dependencies assuming that the dependency on cdrtools was most BUILD and RUN dependency. While most of the time it is simply a RUN dependency and sometime a build one. While here: - Trim some headers - Convert some ports to optionsng - Convert some ports to USES= gettext
Diffstat (limited to 'multimedia/devede/Makefile')
-rw-r--r--multimedia/devede/Makefile43
1 files changed, 18 insertions, 25 deletions
diff --git a/multimedia/devede/Makefile b/multimedia/devede/Makefile
index 95faa1d3e744..af9e30e89033 100644
--- a/multimedia/devede/Makefile
+++ b/multimedia/devede/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devede
-# Date created: 2007-06-20
-# Whom: Lars Engels <lars.engels@0x20.net>
-#
+# Created by: Lars Engels <lars.engels@0x20.net>
# $FreeBSD$
-#
PORTNAME= devede
DISTVERSION= 3.23.0
@@ -17,43 +13,40 @@ COMMENT= Create video DVDs, VCDs, sVCDs, or CVDs from any number of video files
RUN_DEPENDS= ffmpeg:${PORTSDIR}/multimedia/ffmpeg \
mencoder:${PORTSDIR}/multimedia/mencoder \
spumux:${PORTSDIR}/multimedia/dvdauthor \
- vcdimager:${PORTSDIR}/multimedia/vcdimager
+ vcdimager:${PORTSDIR}/multimedia/vcdimager \
+ cdrecord:${PORTSDIR}/sysutils/cdrtools
USE_BZIP2= yes
USE_GNOME= pygtk2
USE_ICONV= yes
USE_PYTHON= yes
-USE_CDRTOOLS= yes
NO_BUILD= yes
-OPTIONS= IBUS "Enable iBus support" on \
- PSYCO "Enable devel/py-psyco optimization support" off
+OPTIONS_DEFINE= IBUS NLS
+OPTIONS_DEFINE_i386= PSYCO
+OPTIONS_DEFAULT= IBUS
+IBUS_DESC= iBus support
+PSYCO_DESC= devel/py-psyco optimization support
DEJAVU_FONTSDIR= ${LOCALBASE}/lib/X11/fonts/dejavu
DEJAVU_FONTFILE= ${DEJAVU_FONTSDIR}/DejaVuSans.ttf
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${ARCH} != "i386"
-.undef WITH_PSYCO
-
-WITHOUT_PSYCO= yes
-.endif
-
-.if !defined(WITHOUT_IBUS)
+.if ${PORT_OPTIONS:MIBUS}
RUN_DEPENDS+= ibus-daemon:${PORTSDIR}/textproc/ibus
.endif
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
.endif
PORTDOCS= *
-.if defined(WITH_PSYCO)
+.if ${PORT_OPTIONS:MPSYCO}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
EXTRA_PATCHES+= ${FILESDIR}/extra-psyco-patch-devede.py
.endif
@@ -100,7 +93,7 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/devede.svg ${PREFIX}/share/pixmaps
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
@${INSTALL_DATA} ${WRKSRC}/po/ca.mo ${PREFIX}/share/locale/ca/LC_MESSAGES/devede.mo
@${INSTALL_DATA} ${WRKSRC}/po/cs_CZ.mo ${PREFIX}/share/locale/cs/LC_MESSAGES/devede.mo
@${INSTALL_DATA} ${WRKSRC}/po/da.mo ${PREFIX}/share/locale/da/LC_MESSAGES/devede.mo
@@ -124,9 +117,9 @@ do-install:
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/html
@${INSTALL_DATA} ${WRKSRC}/docs/html/* ${DOCSDIR}/html
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>