aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/dvdauthor
diff options
context:
space:
mode:
authorpb <pb@FreeBSD.org>2010-07-25 00:38:07 +0800
committerpb <pb@FreeBSD.org>2010-07-25 00:38:07 +0800
commitf40280f19becf0224de3b235ba0627a4b618f878 (patch)
tree212655557e46eccae121b7676cc9da656bbc1aa3 /multimedia/dvdauthor
parent3b56ad396e9109222293b3098dea6b2990ba0c02 (diff)
downloadfreebsd-ports-gnome-f40280f19becf0224de3b235ba0627a4b618f878.tar.gz
freebsd-ports-gnome-f40280f19becf0224de3b235ba0627a4b618f878.tar.zst
freebsd-ports-gnome-f40280f19becf0224de3b235ba0627a4b618f878.zip
Description from PR:
With the newer PNG library, spumux is detecting an errors about PNG images being too big (at least on amd64). This patches uses a specific libpng type for width and height. devede was generating a DVD with a menu that was non-functional. It took me awhile to narrow down the problem: spumux was skipping the addition of a subtitle to the menu MPG file but not causing devede to return an error. It seems that DVD's require a subtitle for the menu to function even if it does not say anything. Patch obtained from the dvdauthor repository: http://github.com/ldo/dvdauthor/commit/fd5c2705825762a6361fbcf95099a42471d709d7 PR: ports/148658 Submitted by: scf
Diffstat (limited to 'multimedia/dvdauthor')
-rw-r--r--multimedia/dvdauthor/Makefile2
-rw-r--r--multimedia/dvdauthor/files/patch-src__subgen-image.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index 16811b5abab2..eb73b32b8db8 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dvdauthor
PORTVERSION= 0.6.14
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= multimedia
MASTER_SITES= SF
diff --git a/multimedia/dvdauthor/files/patch-src__subgen-image.c b/multimedia/dvdauthor/files/patch-src__subgen-image.c
new file mode 100644
index 000000000000..9bba393c7ee2
--- /dev/null
+++ b/multimedia/dvdauthor/files/patch-src__subgen-image.c
@@ -0,0 +1,15 @@
+diff -ruN --exclude=CVS /usr/ports/multimedia/dvdauthor.orig/files/patch-src__subgen-image.c /usr/ports/multimedia/dvdauthor/files/patch-src__subgen-image.c
+--- /usr/ports/multimedia/dvdauthor.orig/files/patch-src__subgen-image.c 1969-12-31 18:00:00.000000000 -0600
++++ /usr/ports/multimedia/dvdauthor/files/patch-src__subgen-image.c 2010-07-15 19:58:36.000000000 -0500
+@@ -0,0 +1,11 @@
++--- src/subgen-image.c.orig 2007-01-12 19:40:42.000000000 -0600
+++++ src/subgen-image.c 2010-07-15 19:56:30.000000000 -0600
++@@ -203,7 +203,7 @@
++ png_struct *ps;
++ png_info *pi;
++ png_byte **rowp;
++- unsigned long width,height;
+++ png_uint_32 width,height;
++ int bit_depth,color_type,channels,x,y;
++
++ fp=fopen(s->fname,"rb");