aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/dvdauthor
diff options
context:
space:
mode:
authorpb <pb@FreeBSD.org>2004-12-21 06:06:31 +0800
committerpb <pb@FreeBSD.org>2004-12-21 06:06:31 +0800
commitce57d284dcf080dc0c96d7cec28bdcdaf7d45914 (patch)
tree8d08e7ae0a1c9332dd43b919b4806db0e6070498 /multimedia/dvdauthor
parent1b2288183670a90022f2207e127a7b66f72a7cbb (diff)
downloadfreebsd-ports-gnome-ce57d284dcf080dc0c96d7cec28bdcdaf7d45914.tar.gz
freebsd-ports-gnome-ce57d284dcf080dc0c96d7cec28bdcdaf7d45914.tar.zst
freebsd-ports-gnome-ce57d284dcf080dc0c96d7cec28bdcdaf7d45914.zip
Fix bug in menu creation caused by bad ImageMagick interaction.
PR: ports/75289 Submitted by: Andy Sparrow <spadger@best.com>
Diffstat (limited to 'multimedia/dvdauthor')
-rw-r--r--multimedia/dvdauthor/Makefile2
-rw-r--r--multimedia/dvdauthor/files/patch-subgen-image.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index f6890f7ea0c4..67d40274f79e 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dvdauthor
PORTVERSION= 0.6.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/multimedia/dvdauthor/files/patch-subgen-image.c b/multimedia/dvdauthor/files/patch-subgen-image.c
new file mode 100644
index 000000000000..743989f996fd
--- /dev/null
+++ b/multimedia/dvdauthor/files/patch-subgen-image.c
@@ -0,0 +1,11 @@
+--- src/subgen-image.c.orig Sun Dec 19 22:38:27 2004
++++ src/subgen-image.c Sun Dec 19 22:38:44 2004
+@@ -177,7 +177,7 @@
+ p.r=pdata[x*4];
+ p.g=pdata[x*4+1];
+ p.b=pdata[x*4+2];
+- p.t=255-pdata[x*4+3];
++ p.t=pdata[x*4+3];
+ putpixel(s,y*s->width+x,&p);
+ }
+ }