aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/ffmpeg-devel
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
committeredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
commit5d87bf6f020ae3177a26e679d65b5e50f035bbe1 (patch)
treeca9d8a7830bc4c19ec29804b066fc99d81d7488b /multimedia/ffmpeg-devel
parent476102ca837a76b18c930b013cb486ec3f0ce79e (diff)
downloadfreebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.gz
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.zst
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.zip
Properly use SDL everywhere:
USE_SDL=yes -> USE_SDL=sdl (good examles everywhere) WANT_SDL/HAVE_SDL instead of exists(localbase/lib/lib...) See http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/using-sdl.html for more information on how to use USE_SDL, WANT_SDL and HAVE_SDL. PR: follow-ups of ports/55494, ports/61877 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'multimedia/ffmpeg-devel')
-rw-r--r--multimedia/ffmpeg-devel/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/multimedia/ffmpeg-devel/Makefile b/multimedia/ffmpeg-devel/Makefile
index 67b0f555b100..390da734ce52 100644
--- a/multimedia/ffmpeg-devel/Makefile
+++ b/multimedia/ffmpeg-devel/Makefile
@@ -20,6 +20,7 @@ HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_SIZE= yes
+WANT_SDL= yes
CONFIGURE_ARGS= --cc="${CC}" --prefix="${PREFIX}" \
--make="${GMAKE}" --enable-shared \
--extra-ldflags="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
@@ -59,7 +60,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-bktr-patch-libavformat::Makefile
##
##
## SDL
-.if exists(${LOCALBASE}/lib/libSDL-1.1.so)
+.if ${HAVE_SDL:Msdl}
WITH_SDL=yes
.endif
## freetype2
@@ -116,7 +117,7 @@ CONFIGURE_ARGS+= --disable-mmx
.endif
## SDL
.ifdef(WITH_SDL)
-USE_SDL= yes
+USE_SDL= sdl
PLIST_SUB+= SDL=""
.else