aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/ffmpeg-devel
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2005-05-13 12:00:19 +0800
committerlioux <lioux@FreeBSD.org>2005-05-13 12:00:19 +0800
commit191d1500c61fd2fbde1a008e908e39c424ff2bb6 (patch)
tree7a0203f42f524a71c942a316d9b96c8251fbd120 /multimedia/ffmpeg-devel
parent84613c6f9d80d492de211177ae1954aeba64183d (diff)
downloadfreebsd-ports-gnome-191d1500c61fd2fbde1a008e908e39c424ff2bb6.tar.gz
freebsd-ports-gnome-191d1500c61fd2fbde1a008e908e39c424ff2bb6.tar.zst
freebsd-ports-gnome-191d1500c61fd2fbde1a008e908e39c424ff2bb6.zip
USE_GCC=3.4 is required; thus, mark BROKEN for OSVERSION <= 500000
since the required libraries will be incompatible with the ffmpeg-devel binary code. Patches are being worked on for both 2.95 and 4.0.1 gcc support Submitted by: ahze
Diffstat (limited to 'multimedia/ffmpeg-devel')
-rw-r--r--multimedia/ffmpeg-devel/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/multimedia/ffmpeg-devel/Makefile b/multimedia/ffmpeg-devel/Makefile
index d1b0d7fbd6f9..45eac17a5a34 100644
--- a/multimedia/ffmpeg-devel/Makefile
+++ b/multimedia/ffmpeg-devel/Makefile
@@ -18,6 +18,7 @@ HAS_CONFIGURE= yes
USE_LINUX= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_GCC= 3.4
USE_REINPLACE= yes
WANT_SDL= yes
CONFIGURE_ARGS= --cc="${CC}" --prefix="${PREFIX}" \
@@ -73,6 +74,10 @@ LIB_FILES= libavcodec/libavcodec.a libavformat/libavformat.a
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= 'Does not compile on FreeBSD 4.x'
+.endif
+
.if (exists(${LOCALBASE}/lib/libavformat.so))
BROKEN= 'Please remove previous version of ${PORTNAME} to continue build'
.endif