aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/ffmpeg
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-12-19 09:07:39 +0800
committerjbeich <jbeich@FreeBSD.org>2016-12-19 09:07:39 +0800
commit4ae5a28350b1afa3aa1c4d51db32a3baba772112 (patch)
tree821f80233dbb6f385dffc2af26fbb997660db304 /multimedia/ffmpeg
parent7ee7926c4eb0eba71380cee1a32eefe714a75175 (diff)
downloadfreebsd-ports-gnome-4ae5a28350b1afa3aa1c4d51db32a3baba772112.tar.gz
freebsd-ports-gnome-4ae5a28350b1afa3aa1c4d51db32a3baba772112.tar.zst
freebsd-ports-gnome-4ae5a28350b1afa3aa1c4d51db32a3baba772112.zip
multimedia/ffmpeg: respect CPUTYPE for NEON=on
Diffstat (limited to 'multimedia/ffmpeg')
-rw-r--r--multimedia/ffmpeg/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 15ad4b2891e4..67461b6da56a 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -351,7 +351,9 @@ VDPAU_CONFIGURE_ENABLE= vdpau
# armv6
VFP_CONFIGURE_ENABLE= vfp
NEON_CONFIGURE_ENABLE= neon
+.if ! ${CFLAGS:M-march*}
NEON_CONFIGURE_ON= --cpu=armv7-a
+.endif
# vo-amrwbenc
VO_AMRWBENC_LIB_DEPENDS= libvo-amrwbenc.so:audio/vo-amrwbenc