aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/ffmpeg
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-05-06 11:28:09 +0800
committerjbeich <jbeich@FreeBSD.org>2017-05-06 11:28:09 +0800
commit4b8d3a32c073c5a66c78a6d46e15a79d1929e739 (patch)
tree9695bb762a5dad5d8b15ce154a4dc21be59ed55e /multimedia/ffmpeg
parentd400a6a2dc9fe43355b8edde8e9741b87c4fb1b9 (diff)
downloadfreebsd-ports-gnome-4b8d3a32c073c5a66c78a6d46e15a79d1929e739.tar.gz
freebsd-ports-gnome-4b8d3a32c073c5a66c78a6d46e15a79d1929e739.tar.zst
freebsd-ports-gnome-4b8d3a32c073c5a66c78a6d46e15a79d1929e739.zip
multimedia/ffmpeg: unbreak on aarch64 after r439365
cc -I. -I./ -DLIBICONV_PLUG -isystem /usr/local/include -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DPIC -DZLIB_CONST -fPIC -Qunused-arguments -MMD -MF libavcodec/aarch64/simple_idct_neon.d -MT libavcodec/aarch64/simple_idct_neon.o -c -o libavcodec/aarch64/simple_idct_neon.o libavcodec/aarch64/simple_idct_neon.S <instantiation>:1:14: error: invalid vector kind qualifier smull v7.4S, v26.4, v0.H[1] ^ <instantiation>:1:1: note: while in macro instantiation smull1 v7.4S, v26.4, v0.H[1] ^ <instantiation>:11:9: note: while in macro instantiation idct_col4_top v24 v25 v26 v27 1 4 ^ libavcodec/aarch64/simple_idct_neon.S:222:1: note: while in macro instantiation declare_idct_col4_neon 1 4H ^ [...] PR: 218658 (for tracking) Reported by: pkg-fallout
Diffstat (limited to 'multimedia/ffmpeg')
-rw-r--r--multimedia/ffmpeg/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index de7a0dc97666..1806ea43ac18 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -445,6 +445,7 @@ CONFIGURE_ARGS+=--prefix="${PREFIX}" \
--enable-pthreads \
--cc="${CC}"
+CONFIGURE_ENV_aarch64_clang= ASFLAGS=-no-integrated-as
CONFIGURE_ENV_armv6_clang= ASFLAGS=-no-integrated-as
CONFIGURE_ARGS_armv6= --disable-fast-unaligned