aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gmerlin/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2019-02-25 21:01:06 +0800
committerbapt <bapt@FreeBSD.org>2019-02-25 21:01:06 +0800
commitd557de2a43c2d31c4c66678034e021e2e5c1c9d4 (patch)
treeb76aa1bea357a567ef10de6f0754137fd1a16d17 /multimedia/gmerlin/Makefile
parent2279429d29264ae1b1d8ab297d33655677783f77 (diff)
downloadfreebsd-ports-gnome-d557de2a43c2d31c4c66678034e021e2e5c1c9d4.tar.gz
freebsd-ports-gnome-d557de2a43c2d31c4c66678034e021e2e5c1c9d4.tar.zst
freebsd-ports-gnome-d557de2a43c2d31c4c66678034e021e2e5c1c9d4.zip
First step at deorbitting esound:
remove esound options where it is possible to, category multimedia
Diffstat (limited to 'multimedia/gmerlin/Makefile')
-rw-r--r--multimedia/gmerlin/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/multimedia/gmerlin/Makefile b/multimedia/gmerlin/Makefile
index 8fab8836c478..55ab22bb54b3 100644
--- a/multimedia/gmerlin/Makefile
+++ b/multimedia/gmerlin/Makefile
@@ -24,7 +24,8 @@ USE_GL= gl
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_func_inotify_init=no
CONFIGURE_ARGS= --disable-v4l --disable-v4l2 --disable-v4lconvert \
- --without-doxygen --with-cpuflags=none --disable-musicbrainz
+ --without-doxygen --with-cpuflags=none --disable-musicbrainz \
+ --disable-esd
USE_LDCONFIG= yes
LLD_UNSAFE= yes
INSTALL_TARGET= install-strip
@@ -36,7 +37,7 @@ LDFLAGS+= -Wl,--add-needed
INFO= gmerlin
-OPTIONS_DEFINE= ALSA CDDB CDIO ESOUND JACK JPEG LIBVISUAL \
+OPTIONS_DEFINE= ALSA CDDB CDIO JACK JPEG LIBVISUAL \
OPTIMIZED_CFLAGS PNG PULSEAUDIO QUICKTIME TIFF DOCS
OPTIONS_DEFAULT= CDDB JACK JPEG LIBVISUAL \
OPTIMIZED_CFLAGS PNG PULSEAUDIO QUICKTIME TIFF
@@ -49,8 +50,6 @@ CDDB_CONFIGURE_OFF= --disable-cddb
CDIO_LIB_DEPENDS= libcdio.so:sysutils/libcdio \
libcdio_cdda.so:sysutils/libcdio-paranoia
CDIO_CONFIGURE_OFF= --disable-libcdio
-ESOUND_USE= gnome=esound
-ESOUND_CONFIGURE_OFF= --disable-esd
JACK_LIB_DEPENDS= libjack.so:audio/jack
JACK_CONFIGURE_OFF= --disable-jack
JPEG_USES= jpeg