aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gopchop/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-08-31 01:03:20 +0800
committerkrion <krion@FreeBSD.org>2003-08-31 01:03:20 +0800
commit5f0a84fee2b9f2c4791cbd6274d2c488e917c8b9 (patch)
tree97f1cb5c02783a4ab4734cec19270dbcb61a7a64 /multimedia/gopchop/Makefile
parent57215d9bc352f9bb0102a305deafdc8d64ea8edd (diff)
downloadfreebsd-ports-gnome-5f0a84fee2b9f2c4791cbd6274d2c488e917c8b9.tar.gz
freebsd-ports-gnome-5f0a84fee2b9f2c4791cbd6274d2c488e917c8b9.tar.zst
freebsd-ports-gnome-5f0a84fee2b9f2c4791cbd6274d2c488e917c8b9.zip
- Update to version 0.9.1
PR: 56194 Submitted by: Ports Fury
Diffstat (limited to 'multimedia/gopchop/Makefile')
-rw-r--r--multimedia/gopchop/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/multimedia/gopchop/Makefile b/multimedia/gopchop/Makefile
index 222609279e02..a62a12cec9b1 100644
--- a/multimedia/gopchop/Makefile
+++ b/multimedia/gopchop/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= gopchop
-PORTVERSION= 0.9.0
-PORTREVISION= 0
+PORTVERSION= 0.9.1
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://outflux.net/unix/software/GOPchop/download/
@@ -18,21 +17,18 @@ DISTNAME= GOPchop-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= MPEG2 GOP-accurate editor
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- mpeg2.0:${PORTSDIR}/multimedia/libmpeg2
+LIB_DEPENDS= mpeg2.0:${PORTSDIR}/multimedia/libmpeg2
-SDLCONFIG?= ${LOCALBASE}/bin/sdl11-config
-
-USE_GNOME= gtk12
+USE_SDL= yes
USE_GETOPT_LONG= yes
+USE_GNOME= gnometarget gtk12
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
- SDLCONFIG="${SDLCONFIG}"
+ SDLCONFIG="${SDL_CONFIG}"
CONFIGURE_ARGS= --disable-mlib
-CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
+CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
LDFLAGS= -L${LOCALBASE}/lib
post-patch: