aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer-plugins-all/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2016-01-08 18:28:27 +0800
committerkwm <kwm@FreeBSD.org>2016-01-08 18:28:27 +0800
commitb3c381c64c146667c21ca1b10e9911efd4225087 (patch)
tree76a8f4f0c5eef08fd569cc164694c9344bd1f6af /multimedia/gstreamer-plugins-all/Makefile
parent04271c8cea74c906181bb5b84c961f98af28151a (diff)
downloadfreebsd-ports-gnome-b3c381c64c146667c21ca1b10e9911efd4225087.tar.gz
freebsd-ports-gnome-b3c381c64c146667c21ca1b10e9911efd4225087.tar.zst
freebsd-ports-gnome-b3c381c64c146667c21ca1b10e9911efd4225087.zip
Update gstreamer-plugins-all and gstreamer1-plugins-all
* Filter out "unwanted" plugins before building the OPTIONS * Sync both Makefiles so they only have gstreamer version specifics * Bump portrevision for option changes. Now all bsd.gstreamer.mk elements where listed before. Submitted by: marino@
Diffstat (limited to 'multimedia/gstreamer-plugins-all/Makefile')
-rw-r--r--multimedia/gstreamer-plugins-all/Makefile45
1 files changed, 22 insertions, 23 deletions
diff --git a/multimedia/gstreamer-plugins-all/Makefile b/multimedia/gstreamer-plugins-all/Makefile
index be20ccab73c0..46f4590a5f85 100644
--- a/multimedia/gstreamer-plugins-all/Makefile
+++ b/multimedia/gstreamer-plugins-all/Makefile
@@ -1,10 +1,9 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/multimedia/gstreamer-plugins-all/Makefile,v 1.8 2006/01/25 18:54:32 ahze Exp $
PORTNAME= gstreamer-plugins-all
PORTVERSION= 1.3.${GST_VERSION}.${GST_SHLIB_VERSION}
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= multimedia
MAINTAINER= multimedia@FreeBSD.org
@@ -15,30 +14,30 @@ USE_GSTREAMER= yes
.include "${.CURDIR}/../../Mk/bsd.gstreamer.mk"
-.for all in ${_GSTREAMER_PLUGINS}
-OPTIONS_DEFINE+= ${all:tu}
-${all:tu}_DESC= ${all} plugin
-OPTIONS_DEFAULT+= ${all:tu}
-.endfor
-
-.include <bsd.port.pre.mk>
-
+ALL_PLUGINS:= ${_GSTREAMER_PLUGINS}
# Weed out gst-plugins that can not be packaged. or are broken.
.if defined(PACKAGE_BUILDING)
-PORT_OPTIONS:= ${PORT_OPTIONS:NFAAC} # Mp4 Dolby license , no package
-PORT_OPTIONS:= ${PORT_OPTIONS:NLAME} # MP3 License , no package
-PORT_OPTIONS:= ${PORT_OPTIONS:NPEG2ENC} # Broken
-PORT_OPTIONS:= ${PORT_OPTIONS:NVDPAU} # Needs to be build agains running kernel
-.endif
-
-.if ${ARCH} != "i386"
-PORT_OPTIONS:= ${PORT_OPTIONS:NSPC} # i386 only
+# FAAC: Mp4 Dolby license , no package
+# LAME: MP3 License , no package
+# VDPAU: Needs to be build agains running kernel
+DEF_PLUGINS:= ${_GSTREAMER_PLUGINS:Nfaac:Nlame:Nvdpau}
+.else
+DEF_PLUGINS:= ${_GSTREAMER_PLUGINS}
.endif
-.for f in ${OPTIONS_DEFINE}
-.if ${PORT_OPTIONS:M${f:tu}}
-USE_GSTREAMER+= ${f:tl}
-.endif
+.for all in ${ALL_PLUGINS}
+${all:tu}_DESC= ${all} plugin
+${all:tu}_USE= GSTREAMER=${all}
.endfor
-.include <bsd.port.post.mk>
+# Pull out i386-only plugins, add back conditionally
+ALL_PLUGINS:= ${ALL_PLUGINS:Nspc}
+DEF_PLUGINS:= ${DEF_PLUGINS:Nspc}
+
+OPTIONS_DEFINE= ${ALL_PLUGINS:tu}
+OPTIONS_DEFAULT= ${DEF_PLUGINS:tu}
+
+OPTIONS_DEFAULT_i386= SPC
+OPTIONS_DEFAULT_i386= SPC
+
+.include <bsd.port.mk>