aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer-plugins-gnonlin/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2005-06-02 23:44:53 +0800
committerkwm <kwm@FreeBSD.org>2005-06-02 23:44:53 +0800
commita9945a51432859c7402d1f789fe5208270eeb61c (patch)
tree4596b6bb730a08372a68da8c79ab0415e7a1c1f5 /multimedia/gstreamer-plugins-gnonlin/Makefile
parent5800f16b5fb36d75249f01932df1cd52cad02fc0 (diff)
downloadfreebsd-ports-gnome-a9945a51432859c7402d1f789fe5208270eeb61c.tar.gz
freebsd-ports-gnome-a9945a51432859c7402d1f789fe5208270eeb61c.tar.zst
freebsd-ports-gnome-a9945a51432859c7402d1f789fe5208270eeb61c.zip
Add gnonlin, This was included in pitivi.
Gnonlin is a library built on top of GStreamer which provides support for writing non-linear audio and video editing applications. It introduces the concept of a timeline.
Diffstat (limited to 'multimedia/gstreamer-plugins-gnonlin/Makefile')
-rw-r--r--multimedia/gstreamer-plugins-gnonlin/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/multimedia/gstreamer-plugins-gnonlin/Makefile b/multimedia/gstreamer-plugins-gnonlin/Makefile
new file mode 100644
index 000000000000..b3509e8c18c5
--- /dev/null
+++ b/multimedia/gstreamer-plugins-gnonlin/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gnonlin
+# Date created: 2 June 2005
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnonlin
+PORTVERSION= 0.2.2
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= GStreamer extension library for non-linear editing
+
+LIB_DEPENDS= gstreamer-0.8.5:${PORTSDIR}/multimedia/gstreamer
+
+CONFLICTS= pitivi-0.1.1*
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnometarget
+USE_LIBTOOL_VER= 15
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= gnonlin-config.1
+
+.include <bsd.port.mk>