aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer-plugins/Makefile
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-12-08 07:50:18 +0800
committerahze <ahze@FreeBSD.org>2006-12-08 07:50:18 +0800
commit0999e6c84a4a3d951966be68d6417ace9db85d44 (patch)
treeeee6c702e10685aacbf3874f4901fae8324df9c2 /multimedia/gstreamer-plugins/Makefile
parentaee0a22c2aa6eeb6b1d942e339a69c746cbaf00d (diff)
downloadfreebsd-ports-gnome-0999e6c84a4a3d951966be68d6417ace9db85d44.tar.gz
freebsd-ports-gnome-0999e6c84a4a3d951966be68d6417ace9db85d44.tar.zst
freebsd-ports-gnome-0999e6c84a4a3d951966be68d6417ace9db85d44.zip
Update gstreamer-plugins and base plugins to 0.10.11
Diffstat (limited to 'multimedia/gstreamer-plugins/Makefile')
-rw-r--r--multimedia/gstreamer-plugins/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 13bcab2e96fd..a99c6c07256d 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -29,7 +29,7 @@ LIB_DEPENDS+= gstreamer-0.10.0:${PORTSDIR}/multimedia/gstreamer \
popt.0:${PORTSDIR}/devel/popt \
oil-0.3.1:${PORTSDIR}/devel/liboil
-BASE_PORTVERSION= 0.10.10
+BASE_PORTVERSION= 0.10.11
BASE_DISTNAME= gst-plugins-base-${BASE_PORTVERSION}
BASE_DISTFILE= ${BASE_DISTNAME}${EXTRACT_SUFX}
BAD_PORTVERSION= 0.10.3
@@ -53,6 +53,7 @@ USE_GNOME+= gnomehack gnometarget pkgconfig ltverhack
USE_AUTOTOOLS= libtool:15
GST_PLUGIN?= base
+CONFIGURE_ARGS+=--mandir=${PREFIX}/man
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
CPPFLAGS="${CPPFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${X11BASE}/lib -L${LOCALBASE}/lib ${EXTRA_LIBS} ${PTHREAD_LIBS}"
@@ -138,7 +139,7 @@ post-patch:
@${FIND} ${WRKSRC} -type f | \
${XARGS} -n 10 ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|; \
- s|stdint\.h|inttypes.h|; \
+ s|<stdint\.h|<inttypes.h|; \
s|%%VERSION%%|${VERSION}|'
@${FIND} ${WRKSRC}/ext -name Makefile.in | \
${XARGS} -n 10 ${REINPLACE_CMD} -e \