aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer-plugins/Makefile
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-03-17 15:03:20 +0800
committerahze <ahze@FreeBSD.org>2005-03-17 15:03:20 +0800
commit1872e5c1c0ef42e51a1f784b8c6746eaf9a6f876 (patch)
tree2adb3db4c0a64733679b37407434f593dc0409da /multimedia/gstreamer-plugins/Makefile
parentf542a345adca7403de6fc55b8d018f430d9c20a9 (diff)
downloadfreebsd-ports-gnome-1872e5c1c0ef42e51a1f784b8c6746eaf9a6f876.tar.gz
freebsd-ports-gnome-1872e5c1c0ef42e51a1f784b8c6746eaf9a6f876.tar.zst
freebsd-ports-gnome-1872e5c1c0ef42e51a1f784b8c6746eaf9a6f876.zip
- Fix plist [1]
- Add post-patch line to speed up configure for non-gstreamer-plugins-* Pointed out by: krion via pointyhat [1]
Diffstat (limited to 'multimedia/gstreamer-plugins/Makefile')
-rw-r--r--multimedia/gstreamer-plugins/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 98cc56bbf3fe..5262f64c4e7f 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -137,6 +137,11 @@ post-patch:
.if ${GST_PLUGIN}!="base"
@${REINPLACE_CMD} -E -e 's|ac_config_files=\"*\"|ac_config_files="$$ac_config_files Makefile ${GST_PLUGIN_MAKEFILES}" #|' \
${WRKSRC}/configure
+.else
+.for f in ${GST_ALL_PLUGINS}
+ @${REINPLACE_CMD} -e 's|ext/${f}/Makefile||g' \
+ ${WRKSRC}/configure
+.endfor
.endif
post-build:
@@ -153,7 +158,7 @@ post-install:
. endfor
.endif
# register plugins
- -@${X11BASE}/bin/gst-register-${GST_VERSION} \
- --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml 2>/dev/null
+ -@${X11BASE}/bin/gst-register-${VERSION} \
+ --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null
.include <bsd.port.post.mk>