aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer-plugins/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-06-18 22:58:58 +0800
committerkwm <kwm@FreeBSD.org>2011-06-18 22:58:58 +0800
commitc4c3a478ff4c29c8ce1869f5f28dfd404e866aa0 (patch)
tree55e57d53254d842f64b1619a844f87e1f7bcd176 /multimedia/gstreamer-plugins/Makefile
parent67f4777d7860955035767c5fa768ab51f66af006 (diff)
downloadfreebsd-ports-gnome-c4c3a478ff4c29c8ce1869f5f28dfd404e866aa0.tar.gz
freebsd-ports-gnome-c4c3a478ff4c29c8ce1869f5f28dfd404e866aa0.tar.zst
freebsd-ports-gnome-c4c3a478ff4c29c8ce1869f5f28dfd404e866aa0.zip
Update:
Gstreamer to 0.10.35 Gstreamer-plugins to 0.10.35 Gstreamer-plugins-good to 0.10.30 This is a ad-hoc release to fixes compilation issues after recent chagnes in Glib's atomic ops API (in GLib 2.29.x). Apart from that there are some minor fixes. Move the USE_XORG line from multimedia/gstreamer to multimedia/gstreamer-plugins, multmedia/gstreamer doesn't use it.
Diffstat (limited to 'multimedia/gstreamer-plugins/Makefile')
-rw-r--r--multimedia/gstreamer-plugins/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 6c8470843406..d3b1f9fbb357 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -28,13 +28,13 @@ LIB_DEPENDS+= gstreamer-0.10.0:${PORTSDIR}/multimedia/gstreamer \
CFLAGS:= ${CFLAGS} -O2 -Wno-format
-BASE_PORTVERSION= 0.10.34
+BASE_PORTVERSION= 0.10.35
BASE_DISTNAME= gst-plugins-base-${BASE_PORTVERSION}
BASE_DISTFILE= ${BASE_DISTNAME}${EXTRACT_SUFX}
BAD_PORTVERSION= 0.10.22
BAD_DISTNAME= gst-plugins-bad-${BAD_PORTVERSION}
BAD_DISTFILE= ${BAD_DISTNAME}${EXTRACT_SUFX}
-GOOD_PORTVERSION= 0.10.29
+GOOD_PORTVERSION= 0.10.30
GOOD_DISTNAME= gst-plugins-good-${GOOD_PORTVERSION}
GOOD_DISTFILE= ${GOOD_DISTNAME}${EXTRACT_SUFX}
UGLY_PORTVERSION= 0.10.18
@@ -53,8 +53,8 @@ USE_AUTOTOOLS= libtool
GST_PLUGIN?= base
CONFIGURE_ARGS= --disable-option-checking
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${EXTRA_LIBS} ${PTHREAD_LIBS}"
DEFAULT_AUDIOSINK?= osssink
@@ -72,6 +72,7 @@ PLIST_SUB+= I386="@comment "
gst_base_DIST= base
NO_GSTREAMER_COMMON= yes
USE_LDCONFIG= yes
+USE_XORG= x11 xv xext videoproto xextproto
MAN1= gst-visualise-0.10.1
PLIST_SUB+= VERSION="${VERSION}" \
SHLIB_VERSION="${SHLIB_VERSION}"