aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer-plugins
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2012-06-27 20:35:05 +0800
committerkwm <kwm@FreeBSD.org>2012-06-27 20:35:05 +0800
commit2b39e955a7974b50ccfdb1ac154010e252e2b527 (patch)
tree01f3303ab66fbb0f7e4f3374d8974ffef8b003f8 /multimedia/gstreamer-plugins
parent7af55bc4f2271457f6b173dace5111c540b73008 (diff)
downloadfreebsd-ports-gnome-2b39e955a7974b50ccfdb1ac154010e252e2b527.tar.gz
freebsd-ports-gnome-2b39e955a7974b50ccfdb1ac154010e252e2b527.tar.zst
freebsd-ports-gnome-2b39e955a7974b50ccfdb1ac154010e252e2b527.zip
Update gstreamer ports.
Gstreamer to 0.10.36. Gstreamer-plugins(-base) to 0.10.36. Gstreamer-plugins-bad to 0.10.23. Gstreamer-plugins-good to 0.10.31. Gstreamer-plugins-ugly to 0.10.19. Add hack to unbreak the flite plugin.
Diffstat (limited to 'multimedia/gstreamer-plugins')
-rw-r--r--multimedia/gstreamer-plugins/Makefile27
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common7
-rw-r--r--multimedia/gstreamer-plugins/distinfo16
-rw-r--r--multimedia/gstreamer-plugins/files/patch-ext_pango_Makefile.in20
-rw-r--r--multimedia/gstreamer-plugins/pkg-plist8
5 files changed, 35 insertions, 43 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index c17317b424d7..b0dafa5a6da7 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gstreamer
PORTVERSION?= ${BASE_PORTVERSION}
-PORTREVISION?= 1
+PORTREVISION?= 0
PORTEPOCH= 3
CATEGORIES?= multimedia audio
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-plugins-base/:base \
@@ -21,23 +21,23 @@ MAINTAINER= multimedia@FreeBSD.org
COMMENT?= GStreamer written collection of plugins handling several media types
BUILD_DEPENDS+= v4l_compat>=1.0.20110720:${PORTSDIR}/multimedia/v4l_compat \
- gstreamer>=0.10.34:${PORTSDIR}/multimedia/gstreamer \
+ gstreamer>=0.10.36:${PORTSDIR}/multimedia/gstreamer \
orc>=0.4.14:${PORTSDIR}/devel/orc
LIB_DEPENDS+= gstreamer-0.10.0:${PORTSDIR}/multimedia/gstreamer \
orc-0.4.0:${PORTSDIR}/devel/orc
CFLAGS:= ${CFLAGS} -O2 -Wno-format
-BASE_PORTVERSION= 0.10.35
+BASE_PORTVERSION= 0.10.36
BASE_DISTNAME= gst-plugins-base-${BASE_PORTVERSION}
BASE_DISTFILE= ${BASE_DISTNAME}${EXTRACT_SUFX}
-BAD_PORTVERSION= 0.10.22
+BAD_PORTVERSION= 0.10.23
BAD_DISTNAME= gst-plugins-bad-${BAD_PORTVERSION}
BAD_DISTFILE= ${BAD_DISTNAME}${EXTRACT_SUFX}
-GOOD_PORTVERSION= 0.10.30
+GOOD_PORTVERSION= 0.10.31
GOOD_DISTNAME= gst-plugins-good-${GOOD_PORTVERSION}
GOOD_DISTFILE= ${GOOD_DISTNAME}${EXTRACT_SUFX}
-UGLY_PORTVERSION= 0.10.18
+UGLY_PORTVERSION= 0.10.19
UGLY_DISTNAME= gst-plugins-ugly-${UGLY_PORTVERSION}
UGLY_DISTFILE= ${UGLY_DISTNAME}${EXTRACT_SUFX}
DIST?= good
@@ -127,11 +127,12 @@ DEFAULT_DVD_DEVICE=/dev/acd0
post-patch:
.if ${DIST}=="bad"
- @${REINPLACE_CMD} -e 's|opencv <= 2.2.0|opencv <= 2.3.9|g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|opencv <= 2.2.0|opencv <= 2.3.99|g' \
+ -e 's|GST_LIBVERSION=23:0:0|GST_LIBVERSION=0:0:0|g' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|g' \
- ${WRKSRC}/ext/resindvd/resindvdbin.c \
- ${WRKSRC}/ext/resindvd/resindvdsrc.c
+ ${WRKSRC}/ext/resindvd/resindvdbin.c \
+ ${WRKSRC}/ext/resindvd/resindvdsrc.c
.endif
@${FIND} ${WRKSRC}/ext -name Makefile.in | \
${XARGS} -n 10 ${REINPLACE_CMD} -e \
@@ -157,8 +158,12 @@ post-patch:
s|$$(top_builddir)/gst-libs/gst/cdda/libgstcdda-@GST_MAJORMINOR@.la|${LOCALBASE}/lib/libgstcdda-@GST_MAJORMINOR@.la|'
@${REINPLACE_CMD} -e 's|DEFAULT_AUDIOSINK="alsasink"|DEFAULT_AUDIOSINK="${DEFAULT_AUDIOSINK}"|; \
s|DEFAULT_AUDIOSRC="alsasrc"|DEFAULT_AUDIOSRC="${DEFAULT_AUDIOSRC}"|' \
- -e 's|libpng12.pc|libpng15.pc|g' \
-e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
+.if ${GST_PLUGIN} == "flite"
+# Hack to get all the libraries linked to the flite plugin so it is useable.
+ -@${REINPLACE_CMD} -e 's|-Wl,--as-needed||g' \
+ ${WRKSRC}/../gnome-libtool
+.endif
.include <bsd.port.post.mk>
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 80907686ad6b..4f872ab2ce74 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -184,7 +184,7 @@ gst_amrnb_LIB_DEPENDS+= opencore-amrnb.0:${PORTSDIR}/audio/opencore-amr
gst_amrnb_PLIST_FILES= ${GST_LIB_DIR}/libgstamrnb.la \
${GST_LIB_DIR}/libgstamrnb.so \
share/gstreamer-${VERSION}/presets/GstAmrnbEnc.prs
-gst_amrnb_PLIST_DIRS= share/gstreamer-${VERSION}/presets \
+gst_amrnb_PLIST_DIRSTRY=share/gstreamer-${VERSION}/presets \
share/gstreamer-${VERSION}
gst_amrnb_DIST= ugly
@@ -433,7 +433,6 @@ gst_ogg_DIST= base
# opencv
gst_opencv_LIB_DEPENDS+=opencv_highgui.2:${PORTSDIR}/graphics/opencv
gst_opencv_PLIST_FILES= ${GST_LIB_DIR}/libgstopencv.la \
- ${GST_LIB_DIR}/libgstopencv.a \
${GST_LIB_DIR}/libgstopencv.so
gst_opencv_DIST= bad
@@ -575,7 +574,6 @@ gst_vorbis_DIST= base
# vp8
gst_vp8_LIB_DEPENDS+= vpx.1:${PORTSDIR}/multimedia/libvpx
gst_vp8_PLIST_FILES= ${GST_LIB_DIR}/libgstvp8.la \
- ${GST_LIB_DIR}/libgstvp8.a \
${GST_LIB_DIR}/libgstvp8.so
gst_vp8_DIST= bad
@@ -584,7 +582,7 @@ gst_x264_LIB_DEPENDS+= x264.123:${PORTSDIR}/multimedia/x264
gst_x264_PLIST_FILES= ${GST_LIB_DIR}/libgstx264.la \
${GST_LIB_DIR}/libgstx264.so \
share/gstreamer-${VERSION}/presets/GstX264Enc.prs
-gst_x264_PLIST_DIRS= share/gstreamer-${VERSION}/presets \
+gst_x264_PLIST_DIRSTRY= share/gstreamer-${VERSION}/presets \
share/gstreamer-${VERSION}
gst_x264_DIST= ugly
@@ -628,6 +626,7 @@ LIB_DEPENDS+= ${gst_${GST_PLUGIN}_LIB_DEPENDS}
RUN_DEPENDS+= ${gst_${GST_PLUGIN}_RUN_DEPENDS}
PLIST_FILES= ${gst_${GST_PLUGIN}_PLIST_FILES}
PLIST_DIRS= ${gst_${GST_PLUGIN}_PLIST_DIRS}
+PLIST_DIRSTRY= ${gst_${GST_PLUGIN}_PLIST_DIRSTRY}
EXTRA_LIBS+= ${gst_${GST_PLUGIN}_EXTRA_LIBS}
USE_GNOME+= ${gst_${GST_PLUGIN}_USE_GNOME}
CONFIGURE_ENV+= ${gst_${GST_PLUGIN}_CONFIGURE_ENV}
diff --git a/multimedia/gstreamer-plugins/distinfo b/multimedia/gstreamer-plugins/distinfo
index a011b038e387..c293ab2469e5 100644
--- a/multimedia/gstreamer-plugins/distinfo
+++ b/multimedia/gstreamer-plugins/distinfo
@@ -1,8 +1,8 @@
-SHA256 (gst-plugins-base-0.10.35.tar.bz2) = cd24f01bb5258a1f400bc4f2c212bb7cee9ee23c9ffb80d537a24ef366d17103
-SIZE (gst-plugins-base-0.10.35.tar.bz2) = 2782902
-SHA256 (gst-plugins-bad-0.10.22.tar.bz2) = d8f7102f43ffea076646427115ffdccb3975954f1e9367bd304f7ee01e12070c
-SIZE (gst-plugins-bad-0.10.22.tar.bz2) = 3539722
-SHA256 (gst-plugins-ugly-0.10.18.tar.bz2) = f9c16748cd9269fae86422d8254a579fa6db073797a5a19a9dc5c72cd66c8e14
-SIZE (gst-plugins-ugly-0.10.18.tar.bz2) = 1070222
-SHA256 (gst-plugins-good-0.10.30.tar.bz2) = b12cba90b27d8423cd0a808939098d19db3996cfb9bf528507c6321782e095f6
-SIZE (gst-plugins-good-0.10.30.tar.bz2) = 3361361
+SHA256 (gst-plugins-base-0.10.36.tar.bz2) = 2cd3b0fa8e9b595db8f514ef7c2bdbcd639a0d63d154c00f8c9b609321f49976
+SIZE (gst-plugins-base-0.10.36.tar.bz2) = 3036143
+SHA256 (gst-plugins-bad-0.10.23.tar.bz2) = 0eae7d1a1357ae8377fded6a1b42e663887beabe0e6cc336e2ef9ada42e11491
+SIZE (gst-plugins-bad-0.10.23.tar.bz2) = 4001543
+SHA256 (gst-plugins-ugly-0.10.19.tar.bz2) = 1ca90059275c0f5dca71d4d1601a8f429b7852baed0723e820703b977e2c8df0
+SIZE (gst-plugins-ugly-0.10.19.tar.bz2) = 1083623
+SHA256 (gst-plugins-good-0.10.31.tar.bz2) = 7e27840e40a7932ef2dc032d7201f9f41afcaf0b437daf5d1d44dc96d9e35ac6
+SIZE (gst-plugins-good-0.10.31.tar.bz2) = 3390378
diff --git a/multimedia/gstreamer-plugins/files/patch-ext_pango_Makefile.in b/multimedia/gstreamer-plugins/files/patch-ext_pango_Makefile.in
deleted file mode 100644
index cec86b2009aa..000000000000
--- a/multimedia/gstreamer-plugins/files/patch-ext_pango_Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- ext/pango/Makefile.in.orig 2008-07-26 06:39:00.827210159 -0700
-+++ ext/pango/Makefile.in 2008-07-26 06:57:02.595333482 -0700
-@@ -86,7 +86,7 @@
- pluginLTLIBRARIES_INSTALL = $(INSTALL)
- LTLIBRARIES = $(plugin_LTLIBRARIES)
- am__DEPENDENCIES_1 =
--libgstpango_la_DEPENDENCIES = $(top_builddir)/gst-libs/gst/video/libgstvideo-$(GST_MAJORMINOR).la \
-+libgstpango_la_DEPENDENCIES = \
- $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
- $(am__DEPENDENCIES_1)
- am_libgstpango_la_OBJECTS = libgstpango_la-gstclockoverlay.lo \
-@@ -481,7 +481,7 @@
-
- libgstpango_la_LIBADD = \
- $(GST_PLUGINS_BASE_LIBS) \
-- $(top_builddir)/gst-libs/gst/video/libgstvideo-$(GST_MAJORMINOR).la \
-+ -lgstvideo-$(GST_MAJORMINOR) \
- $(GST_BASE_LIBS) \
- $(GST_LIBS) \
- $(PANGO_LIBS)
diff --git a/multimedia/gstreamer-plugins/pkg-plist b/multimedia/gstreamer-plugins/pkg-plist
index 3197bf83a480..f1b098961ab1 100644
--- a/multimedia/gstreamer-plugins/pkg-plist
+++ b/multimedia/gstreamer-plugins/pkg-plist
@@ -6,6 +6,9 @@ include/gstreamer-%%VERSION%%/gst/app/gstappsrc.h
include/gstreamer-%%VERSION%%/gst/audio/audio.h
include/gstreamer-%%VERSION%%/gst/audio/audio-enumtypes.h
include/gstreamer-%%VERSION%%/gst/audio/gstaudioclock.h
+include/gstreamer-%%VERSION%%/gst/audio/gstaudiodecoder.h
+include/gstreamer-%%VERSION%%/gst/audio/gstaudioencoder.h
+include/gstreamer-%%VERSION%%/gst/audio/gstaudioiec61937.h
include/gstreamer-%%VERSION%%/gst/audio/gstaudiofilter.h
include/gstreamer-%%VERSION%%/gst/audio/gstaudiosink.h
include/gstreamer-%%VERSION%%/gst/audio/gstaudiosrc.h
@@ -67,12 +70,14 @@ include/gstreamer-%%VERSION%%/gst/rtsp/gstrtspurl.h
include/gstreamer-%%VERSION%%/gst/sdp/gstsdp.h
include/gstreamer-%%VERSION%%/gst/sdp/gstsdpmessage.h
include/gstreamer-%%VERSION%%/gst/tag/gsttagdemux.h
+include/gstreamer-%%VERSION%%/gst/tag/gsttagmux.h
include/gstreamer-%%VERSION%%/gst/tag/tag.h
include/gstreamer-%%VERSION%%/gst/tag/xmpwriter.h
include/gstreamer-%%VERSION%%/gst/video/gstvideofilter.h
include/gstreamer-%%VERSION%%/gst/video/gstvideosink.h
include/gstreamer-%%VERSION%%/gst/video/video.h
include/gstreamer-%%VERSION%%/gst/video/video-enumtypes.h
+include/gstreamer-%%VERSION%%/gst/video/video-overlay-composition.h
lib/girepository-1.0/GstApp-%%VERSION%%.typelib
lib/girepository-1.0/GstAudio-%%VERSION%%.typelib
lib/girepository-1.0/GstFft-%%VERSION%%.typelib
@@ -207,6 +212,7 @@ share/gir-1.0/GstRtsp-%%VERSION%%.gir
share/gir-1.0/GstSdp-%%VERSION%%.gir
share/gir-1.0/GstTag-%%VERSION%%.gir
share/gir-1.0/GstVideo-%%VERSION%%.gir
+share/gst-plugins-base/license-translations.dict
share/locale/af/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
share/locale/az/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
share/locale/bg/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
@@ -216,6 +222,7 @@ share/locale/da/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
share/locale/de/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
share/locale/el/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
share/locale/en_GB/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
+share/locale/eo/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
share/locale/es/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
share/locale/eu/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
share/locale/fi/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
@@ -243,6 +250,7 @@ share/locale/uk/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
share/locale/vi/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
share/locale/ru/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
share/locale/zh_CN/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
+@dirrm share/gst-plugins-base
@dirrm include/gstreamer-%%VERSION%%/gst/video
@dirrm include/gstreamer-%%VERSION%%/gst/tag
@dirrm include/gstreamer-%%VERSION%%/gst/sdp