aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer1-qt4
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-09-19 04:29:51 +0800
committertcberner <tcberner@FreeBSD.org>2016-09-19 04:29:51 +0800
commit90df0ef63586989cdd0419a6ef68d0ea3e061501 (patch)
treeed79864c07771cd5f43ae157129425215a06d9b1 /multimedia/gstreamer1-qt4
parenta979a6e8ea7239416bc64ba747aac57dd699500d (diff)
downloadfreebsd-ports-gnome-90df0ef63586989cdd0419a6ef68d0ea3e061501.tar.gz
freebsd-ports-gnome-90df0ef63586989cdd0419a6ef68d0ea3e061501.tar.zst
freebsd-ports-gnome-90df0ef63586989cdd0419a6ef68d0ea3e061501.zip
Add a new port multimeda/gstreamer1-qt5 (as slave of multimedia/gstreamer1-qt4)
The port for multimedia/gstreamer1-qt5 has existed in area51 for a while now, and has been worked on by rakuco@ and myself. It used the same distfile as multimedia/gstreamer1-qt4, but requires an additional patch over the qt4-based one to fix compilation in C++11 mode. To bring this port now into the official ports-tree the following was done: * Add multimedia/gstreamer1-qt5 (obvously) as as a slaveport * Replace the two patches in multimedia/gstreamer1-qt4 obtained from OpenBSD by the git commit from upstream (we already had it like that in the qt5 one) * Import the C++11 (not strictly necessary for the qt4 one, but doesn't/shouldn't hurt) * Add proxy deps to make stage-qa happy Reviewed by: rakuco Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D7907
Diffstat (limited to 'multimedia/gstreamer1-qt4')
-rw-r--r--multimedia/gstreamer1-qt4/Makefile37
-rw-r--r--multimedia/gstreamer1-qt4/files/patch-CMakeLists.txt14
-rw-r--r--multimedia/gstreamer1-qt4/files/patch-cmake_modules_FindGStreamer.cmake14
-rw-r--r--multimedia/gstreamer1-qt4/files/patch-git_1d2edcc935
-rw-r--r--multimedia/gstreamer1-qt4/files/patch-git_fc159e5c463
-rw-r--r--multimedia/gstreamer1-qt4/pkg-plist285
6 files changed, 272 insertions, 176 deletions
diff --git a/multimedia/gstreamer1-qt4/Makefile b/multimedia/gstreamer1-qt4/Makefile
index ec3788183da9..b3da1f6f2fab 100644
--- a/multimedia/gstreamer1-qt4/Makefile
+++ b/multimedia/gstreamer1-qt4/Makefile
@@ -1,28 +1,43 @@
# $FreeBSD$
-PORTNAME= gstreamer
+PORTNAME= gstreamer1-qt
PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTREVISION?= 2
CATEGORIES= multimedia
-MASTER_SITES= http://gstreamer.freedesktop.org/src/qt-${PORTNAME}/
-PKGNAMESUFFIX= 1-qt4
-DISTNAME= qt-${PORTNAME}-${PORTVERSION}
+MASTER_SITES= http://gstreamer.freedesktop.org/src/qt-gstreamer/
+PKGNAMESUFFIX?= 4
+DISTNAME= qt-gstreamer-${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
-COMMENT= Qt 4 bindings for GStreamer 1.x multimedia library
+COMMENT= Qt ${PKGNAMESUFFIX} bindings for GStreamer 1.x multimedia library
-LIB_DEPENDS= libboost_thread.so:devel/boost-libs
+LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
+ libgstreamer-1.0.so:multimedia/gstreamer1
-CONFLICTS_INSTALL= gstreamer-qt4-*
+CONFLICTS_INSTALL= gstreamer-qt${PKGNAMESUFFIX}-*
USES= bison cmake:outsource pathfix pkgconfig tar:xz
USE_GSTREAMER1= yes
-USE_QT4= corelib gui opengl declarative \
+
+USE_GL= gl
+USE_GNOME= glib20
+. if ${PKGNAMESUFFIX:M4}
+USE_QT4= corelib gui opengl declarative script \
qmake_build moc_build rcc_build uic_build qtestlib_build
+PLIST_SUB= QT4_ONLY="" QT5_ONLY="@comment "
+. else
+USE_QT5= buildtools_build qmake_build core gui network opengl \
+ qml quick testlib widgets
+QTVER_SUFFIX= 5
+PLIST_SUB= QT4_ONLY="@comment " QT5_ONLY=""
+. endif
+
USE_LDCONFIG= yes
CMAKE_ARGS= -DUSE_GST_PLUGIN_DIR=off \
- -DUSE_QT_PLUGIN_DIR=off
+ -DUSE_QT_PLUGIN_DIR=off \
+ -DQT_VERSION=${PKGNAMESUFFIX}
-PLIST_SUB= SHLIB_VER="${PORTVERSION}"
+PLIST_SUB+= SHLIB_VER="${PORTVERSION}" \
+ QTVER_SUFFIX="${QTVER_SUFFIX}"
.include <bsd.port.mk>
diff --git a/multimedia/gstreamer1-qt4/files/patch-CMakeLists.txt b/multimedia/gstreamer1-qt4/files/patch-CMakeLists.txt
deleted file mode 100644
index 11d3ed14de15..000000000000
--- a/multimedia/gstreamer1-qt4/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-$OpenBSD: patch-CMakeLists_txt,v 1.1 2015/09/27 08:23:55 ajacoutot Exp $
-
-https://bugzilla.gnome.org/show_bug.cgi?id=751382
-
---- CMakeLists.txt.orig Tue Jul 8 20:38:36 2014
-+++ CMakeLists.txt Sun Sep 27 09:12:31 2015
-@@ -106,6 +106,7 @@ find_package(GObject)
- macro_log_feature(GOBJECT_FOUND "GObject" "Required to build QtGLib" "http://www.gtk.org/" TRUE)
-
- set(CMAKE_REQUIRED_INCLUDES ${QTGSTREAMER_INCLUDES})
-+add_definitions(${GSTREAMER_DEFINITIONS})
- include(CheckCXXSourceCompiles)
- check_cxx_source_compiles("
- #include <QtCore/QtGlobal>
diff --git a/multimedia/gstreamer1-qt4/files/patch-cmake_modules_FindGStreamer.cmake b/multimedia/gstreamer1-qt4/files/patch-cmake_modules_FindGStreamer.cmake
deleted file mode 100644
index 3a10a86ab3a8..000000000000
--- a/multimedia/gstreamer1-qt4/files/patch-cmake_modules_FindGStreamer.cmake
+++ /dev/null
@@ -1,14 +0,0 @@
-$OpenBSD: patch-cmake_modules_FindGStreamer_cmake,v 1.1 2015/09/27 08:23:55 ajacoutot Exp $
-
-https://bugzilla.gnome.org/show_bug.cgi?id=751382
-
---- cmake/modules/FindGStreamer.cmake.orig Tue Jul 8 20:38:36 2014
-+++ cmake/modules/FindGStreamer.cmake Sun Sep 27 09:12:31 2015
-@@ -36,6 +36,7 @@ if (PKG_CONFIG_FOUND)
- exec_program(${PKG_CONFIG_EXECUTABLE}
- ARGS --variable pluginsdir gstreamer-${GSTREAMER_ABI_VERSION}
- OUTPUT_VARIABLE PKG_GSTREAMER_PLUGIN_DIR)
-+ set(GSTREAMER_DEFINITIONS ${PKG_GSTREAMER_CFLAGS})
- endif()
-
- find_library(GSTREAMER_LIBRARY
diff --git a/multimedia/gstreamer1-qt4/files/patch-git_1d2edcc9 b/multimedia/gstreamer1-qt4/files/patch-git_1d2edcc9
new file mode 100644
index 000000000000..079d20e770a3
--- /dev/null
+++ b/multimedia/gstreamer1-qt4/files/patch-git_1d2edcc9
@@ -0,0 +1,35 @@
+From e2ca8094aa8d0eac1c3a98df66fe94ce0c754088 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jos=C3=A9=20Manuel=20Santamar=C3=ADa?= <panfaust@gmail.com>
+Date: Fri, 2 Oct 2015 15:00:29 +0300
+Subject: Fix compilation with GStreamer >= 1.5.1
+
+apply gstreamer pkg-config definitions To ensure gstreamer builds correctly,
+pick up its cflags in FindGstreamer and apply them to the build as definitions
+
+https://lists.ubuntu.com/archives/kubuntu-devel/2015-August/009819.html
+
+https://bugzilla.gnome.org/show_bug.cgi?id=751382
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -106,6 +106,7 @@ find_package(GObject)
+ macro_log_feature(GOBJECT_FOUND "GObject" "Required to build QtGLib" "http://www.gtk.org/" TRUE)
+
+ set(CMAKE_REQUIRED_INCLUDES ${QTGSTREAMER_INCLUDES})
++add_definitions(${GSTREAMER_DEFINITIONS})
+ include(CheckCXXSourceCompiles)
+ check_cxx_source_compiles("
+ #include <QtCore/QtGlobal>
+--- cmake/modules/FindGStreamer.cmake
++++ cmake/modules/FindGStreamer.cmake
+@@ -36,6 +36,7 @@ if (PKG_CONFIG_FOUND)
+ exec_program(${PKG_CONFIG_EXECUTABLE}
+ ARGS --variable pluginsdir gstreamer-${GSTREAMER_ABI_VERSION}
+ OUTPUT_VARIABLE PKG_GSTREAMER_PLUGIN_DIR)
++ set(GSTREAMER_DEFINITIONS ${PKG_GSTREAMER_CFLAGS})
+ endif()
+
+ find_library(GSTREAMER_LIBRARY
+--
+cgit v0.10.2
+
diff --git a/multimedia/gstreamer1-qt4/files/patch-git_fc159e5c4 b/multimedia/gstreamer1-qt4/files/patch-git_fc159e5c4
new file mode 100644
index 000000000000..a1f6b9a60fdb
--- /dev/null
+++ b/multimedia/gstreamer1-qt4/files/patch-git_fc159e5c4
@@ -0,0 +1,63 @@
+From fc159e5c4c8ffeabdc7319514c6bb19c9c9e1d3b Mon Sep 17 00:00:00 2001
+From: Aleix Pol <aleixpol@kde.org>
+Date: Mon, 13 Jun 2016 10:36:34 +0200
+Subject: Fix build with Clang 3.8
+
+error: invalid suffix on literal; C++11 requires a space between literal and identifier
+
+https://bugzilla.gnome.org/show_bug.cgi?id=767578
+
+diff --git elements/gstqtvideosink/delegates/basedelegate.cpp elements/gstqtvideosink/delegates/basedelegate.cpp
+index 7dde59c..65f364c 100644
+--- elements/gstqtvideosink/delegates/basedelegate.cpp
++++ elements/gstqtvideosink/delegates/basedelegate.cpp
+@@ -155,7 +155,7 @@ bool BaseDelegate::event(QEvent *event)
+ BufferEvent *bufEvent = dynamic_cast<BufferEvent*>(event);
+ Q_ASSERT(bufEvent);
+
+- GST_TRACE_OBJECT(m_sink, "Received buffer %"GST_PTR_FORMAT, bufEvent->buffer);
++ GST_TRACE_OBJECT(m_sink, "Received buffer %" GST_PTR_FORMAT, bufEvent->buffer);
+
+ if (isActive()) {
+ gst_buffer_replace (&m_buffer, bufEvent->buffer);
+diff --git elements/gstqtvideosink/delegates/qwidgetvideosinkdelegate.cpp elements/gstqtvideosink/delegates/qwidgetvideosinkdelegate.cpp
+index 8f23dc2..c42513f 100644
+--- elements/gstqtvideosink/delegates/qwidgetvideosinkdelegate.cpp
++++ elements/gstqtvideosink/delegates/qwidgetvideosinkdelegate.cpp
+@@ -36,7 +36,7 @@ QWidget *QWidgetVideoSinkDelegate::widget() const
+
+ void QWidgetVideoSinkDelegate::setWidget(QWidget *widget)
+ {
+- GST_LOG_OBJECT(m_sink, "Setting \"widget\" property to %"GST_PTR_FORMAT, widget);
++ GST_LOG_OBJECT(m_sink, "Setting \"widget\" property to %" GST_PTR_FORMAT, widget);
+
+ if (m_widget) {
+ m_widget.data()->removeEventFilter(this);
+diff --git elements/gstqtvideosink/gstqtquick2videosink.cpp elements/gstqtvideosink/gstqtquick2videosink.cpp
+index 7889fbf..bedc074 100644
+--- elements/gstqtvideosink/gstqtquick2videosink.cpp
++++ elements/gstqtvideosink/gstqtquick2videosink.cpp
+@@ -248,7 +248,7 @@ gst_qt_quick2_video_sink_show_frame(GstVideoSink *sink, GstBuffer *buffer)
+ {
+ GstQtQuick2VideoSink *self = GST_QT_QUICK2_VIDEO_SINK (sink);
+
+- GST_TRACE_OBJECT(self, "Posting new buffer (%"GST_PTR_FORMAT") for rendering.", buffer);
++ GST_TRACE_OBJECT(self, "Posting new buffer (%" GST_PTR_FORMAT ") for rendering.", buffer);
+
+ QCoreApplication::postEvent(self->priv->delegate, new BaseDelegate::BufferEvent(buffer));
+
+diff --git elements/gstqtvideosink/gstqtvideosinkbase.cpp elements/gstqtvideosink/gstqtvideosinkbase.cpp
+index 118d0a2..a707e02 100644
+--- elements/gstqtvideosink/gstqtvideosinkbase.cpp
++++ elements/gstqtvideosink/gstqtvideosinkbase.cpp
+@@ -207,7 +207,7 @@ GstFlowReturn GstQtVideoSinkBase::show_frame(GstVideoSink *video_sink, GstBuffer
+ {
+ GstQtVideoSinkBase *sink = GST_QT_VIDEO_SINK_BASE(video_sink);
+
+- GST_TRACE_OBJECT(sink, "Posting new buffer (%"GST_PTR_FORMAT") for rendering.", buffer);
++ GST_TRACE_OBJECT(sink, "Posting new buffer (%" GST_PTR_FORMAT ") for rendering.", buffer);
+
+ QCoreApplication::postEvent(sink->delegate, new BaseDelegate::BufferEvent(buffer));
+
+--
+cgit v0.10.2
diff --git a/multimedia/gstreamer1-qt4/pkg-plist b/multimedia/gstreamer1-qt4/pkg-plist
index 147ca9e68d3c..358422e485e6 100644
--- a/multimedia/gstreamer1-qt4/pkg-plist
+++ b/multimedia/gstreamer1-qt4/pkg-plist
@@ -1,137 +1,148 @@
-include/QtGStreamer/QGlib/Connect
-include/QtGStreamer/QGlib/Error
-include/QtGStreamer/QGlib/Global
-include/QtGStreamer/QGlib/Init
-include/QtGStreamer/QGlib/Object
-include/QtGStreamer/QGlib/ParamSpec
-include/QtGStreamer/QGlib/Quark
-include/QtGStreamer/QGlib/RefPointer
-include/QtGStreamer/QGlib/Signal
-include/QtGStreamer/QGlib/Type
-include/QtGStreamer/QGlib/Value
-include/QtGStreamer/QGlib/connect.h
-include/QtGStreamer/QGlib/connectimpl.h
-include/QtGStreamer/QGlib/emitimpl.h
-include/QtGStreamer/QGlib/error.h
-include/QtGStreamer/QGlib/global.h
-include/QtGStreamer/QGlib/init.h
-include/QtGStreamer/QGlib/object.h
-include/QtGStreamer/QGlib/paramspec.h
-include/QtGStreamer/QGlib/qglib_signal.h
-include/QtGStreamer/QGlib/quark.h
-include/QtGStreamer/QGlib/refpointer.h
-include/QtGStreamer/QGlib/type.h
-include/QtGStreamer/QGlib/value.h
-include/QtGStreamer/QGlib/wrap.h
-include/QtGStreamer/QGst/Allocator
-include/QtGStreamer/QGst/Bin
-include/QtGStreamer/QGst/Buffer
-include/QtGStreamer/QGst/BufferList
-include/QtGStreamer/QGst/Bus
-include/QtGStreamer/QGst/Caps
-include/QtGStreamer/QGst/ChildProxy
-include/QtGStreamer/QGst/Clock
-include/QtGStreamer/QGst/ClockTime
-include/QtGStreamer/QGst/ColorBalance
-include/QtGStreamer/QGst/Discoverer
-include/QtGStreamer/QGst/DoubleRange
-include/QtGStreamer/QGst/Element
-include/QtGStreamer/QGst/ElementFactory
-include/QtGStreamer/QGst/Event
-include/QtGStreamer/QGst/Fourcc
-include/QtGStreamer/QGst/Fraction
-include/QtGStreamer/QGst/FractionRange
-include/QtGStreamer/QGst/GhostPad
-include/QtGStreamer/QGst/Global
-include/QtGStreamer/QGst/Init
-include/QtGStreamer/QGst/Int64Range
-include/QtGStreamer/QGst/IntRange
-include/QtGStreamer/QGst/Memory
-include/QtGStreamer/QGst/Message
-include/QtGStreamer/QGst/MiniObject
-include/QtGStreamer/QGst/Object
-include/QtGStreamer/QGst/Pad
-include/QtGStreamer/QGst/Parse
-include/QtGStreamer/QGst/Pipeline
-include/QtGStreamer/QGst/PluginFeature
-include/QtGStreamer/QGst/Query
-include/QtGStreamer/QGst/Sample
-include/QtGStreamer/QGst/Segment
-include/QtGStreamer/QGst/StreamVolume
-include/QtGStreamer/QGst/Structure
-include/QtGStreamer/QGst/TagList
-include/QtGStreamer/QGst/Ui/GraphicsVideoSurface
-include/QtGStreamer/QGst/Ui/GraphicsVideoWidget
-include/QtGStreamer/QGst/Ui/VideoWidget
-include/QtGStreamer/QGst/Ui/global.h
-include/QtGStreamer/QGst/Ui/graphicsvideosurface.h
-include/QtGStreamer/QGst/Ui/graphicsvideowidget.h
-include/QtGStreamer/QGst/Ui/videowidget.h
-include/QtGStreamer/QGst/UriHandler
-include/QtGStreamer/QGst/Utils/ApplicationSink
-include/QtGStreamer/QGst/Utils/ApplicationSource
-include/QtGStreamer/QGst/Utils/applicationsink.h
-include/QtGStreamer/QGst/Utils/applicationsource.h
-include/QtGStreamer/QGst/Utils/global.h
-include/QtGStreamer/QGst/VideoOrientation
-include/QtGStreamer/QGst/VideoOverlay
-include/QtGStreamer/QGst/allocator.h
-include/QtGStreamer/QGst/bin.h
-include/QtGStreamer/QGst/buffer.h
-include/QtGStreamer/QGst/bufferlist.h
-include/QtGStreamer/QGst/bus.h
-include/QtGStreamer/QGst/caps.h
-include/QtGStreamer/QGst/childproxy.h
-include/QtGStreamer/QGst/clock.h
-include/QtGStreamer/QGst/clocktime.h
-include/QtGStreamer/QGst/colorbalance.h
-include/QtGStreamer/QGst/discoverer.h
-include/QtGStreamer/QGst/element.h
-include/QtGStreamer/QGst/elementfactory.h
-include/QtGStreamer/QGst/enums.h
-include/QtGStreamer/QGst/event.h
-include/QtGStreamer/QGst/ghostpad.h
-include/QtGStreamer/QGst/global.h
-include/QtGStreamer/QGst/init.h
-include/QtGStreamer/QGst/memory.h
-include/QtGStreamer/QGst/message.h
-include/QtGStreamer/QGst/miniobject.h
-include/QtGStreamer/QGst/object.h
-include/QtGStreamer/QGst/pad.h
-include/QtGStreamer/QGst/parse.h
-include/QtGStreamer/QGst/pipeline.h
-include/QtGStreamer/QGst/pluginfeature.h
-include/QtGStreamer/QGst/query.h
-include/QtGStreamer/QGst/sample.h
-include/QtGStreamer/QGst/segment.h
-include/QtGStreamer/QGst/streamvolume.h
-include/QtGStreamer/QGst/structs.h
-include/QtGStreamer/QGst/structure.h
-include/QtGStreamer/QGst/taglist.h
-include/QtGStreamer/QGst/urihandler.h
-include/QtGStreamer/QGst/videoorientation.h
-include/QtGStreamer/QGst/videooverlay.h
-lib/cmake/QtGStreamer/QtGStreamerConfig.cmake
-lib/cmake/QtGStreamer/QtGStreamerConfigCommon.cmake
-lib/cmake/QtGStreamer/QtGStreamerConfigVersion.cmake
-lib/cmake/QtGStreamer/QtGStreamerTargets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/QtGStreamer/QtGStreamerTargets.cmake
-lib/gstreamer-1.0/libgstqtvideosink.so
-lib/libQtGLib-2.0.so
-lib/libQtGLib-2.0.so.0
-lib/libQtGLib-2.0.so.%%SHLIB_VER%%
-lib/libQtGStreamer-1.0.so
-lib/libQtGStreamer-1.0.so.0
-lib/libQtGStreamer-1.0.so.%%SHLIB_VER%%
-lib/libQtGStreamerUi-1.0.so
-lib/libQtGStreamerUi-1.0.so.0
-lib/libQtGStreamerUi-1.0.so.%%SHLIB_VER%%
-lib/libQtGStreamerUtils-1.0.so
-lib/libQtGStreamerUtils-1.0.so.0
-lib/libQtGStreamerUtils-1.0.so.%%SHLIB_VER%%
-%%QT_IMPORTDIR%%/QtGStreamer/libQtGStreamerQuick1.so
-%%QT_IMPORTDIR%%/QtGStreamer/qmldir
-libdata/pkgconfig/QtGLib-2.0.pc
-libdata/pkgconfig/QtGStreamer-1.0.pc
-libdata/pkgconfig/QtGStreamerUi-1.0.pc
-libdata/pkgconfig/QtGStreamerUtils-1.0.pc
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Connect
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Error
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Global
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Init
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Object
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/ParamSpec
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Quark
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/RefPointer
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Signal
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Type
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/Value
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/connect.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/connectimpl.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/emitimpl.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/error.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/global.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/init.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/object.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/paramspec.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/qglib_signal.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/quark.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/refpointer.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/type.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/value.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGlib/wrap.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Allocator
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Bin
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Buffer
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/BufferList
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Bus
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Caps
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/ChildProxy
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Clock
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/ClockTime
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/ColorBalance
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Discoverer
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/DoubleRange
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Element
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/ElementFactory
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Event
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Fourcc
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Fraction
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/FractionRange
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/GhostPad
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Global
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Init
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Int64Range
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/IntRange
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Memory
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Message
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/MiniObject
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Object
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Pad
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Parse
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Pipeline
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/PluginFeature
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Query
+%%QT5_ONLY%%include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Quick/VideoItem
+%%QT5_ONLY%%include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Quick/VideoSurface
+%%QT5_ONLY%%include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Quick/global.h
+%%QT5_ONLY%%include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Quick/videoitem.h
+%%QT5_ONLY%%include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Quick/videosurface.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Sample
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Segment
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/StreamVolume
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Structure
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/TagList
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/GraphicsVideoSurface
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/GraphicsVideoWidget
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/VideoWidget
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/global.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/graphicsvideosurface.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/graphicsvideowidget.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Ui/videowidget.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/UriHandler
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Utils/ApplicationSink
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Utils/ApplicationSource
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Utils/applicationsink.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Utils/applicationsource.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/Utils/global.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/VideoOrientation
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/VideoOverlay
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/allocator.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/bin.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/buffer.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/bufferlist.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/bus.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/caps.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/childproxy.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/clock.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/clocktime.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/colorbalance.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/discoverer.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/element.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/elementfactory.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/enums.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/event.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/ghostpad.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/global.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/init.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/memory.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/message.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/miniobject.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/object.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/pad.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/parse.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/pipeline.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/pluginfeature.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/query.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/sample.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/segment.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/streamvolume.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/structs.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/structure.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/taglist.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/urihandler.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/videoorientation.h
+include/Qt%%QTVER_SUFFIX%%GStreamer/QGst/videooverlay.h
+lib/cmake/Qt%%QTVER_SUFFIX%%GStreamer/Qt%%QTVER_SUFFIX%%GStreamerConfig.cmake
+lib/cmake/Qt%%QTVER_SUFFIX%%GStreamer/QtGStreamerConfigCommon.cmake
+lib/cmake/Qt%%QTVER_SUFFIX%%GStreamer/Qt%%QTVER_SUFFIX%%GStreamerConfigVersion.cmake
+lib/cmake/Qt%%QTVER_SUFFIX%%GStreamer/Qt%%QTVER_SUFFIX%%GStreamerTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qt%%QTVER_SUFFIX%%GStreamer/Qt%%QTVER_SUFFIX%%GStreamerTargets.cmake
+lib/gstreamer-1.0/libgstqt%%QTVER_SUFFIX%%videosink.so
+lib/libQt%%QTVER_SUFFIX%%GLib-2.0.so
+lib/libQt%%QTVER_SUFFIX%%GLib-2.0.so.0
+lib/libQt%%QTVER_SUFFIX%%GLib-2.0.so.%%SHLIB_VER%%
+lib/libQt%%QTVER_SUFFIX%%GStreamer-1.0.so
+lib/libQt%%QTVER_SUFFIX%%GStreamer-1.0.so.0
+lib/libQt%%QTVER_SUFFIX%%GStreamer-1.0.so.%%SHLIB_VER%%
+lib/libQt%%QTVER_SUFFIX%%GStreamerUi-1.0.so
+lib/libQt%%QTVER_SUFFIX%%GStreamerUi-1.0.so.0
+lib/libQt%%QTVER_SUFFIX%%GStreamerUi-1.0.so.%%SHLIB_VER%%
+lib/libQt%%QTVER_SUFFIX%%GStreamerUtils-1.0.so
+lib/libQt%%QTVER_SUFFIX%%GStreamerUtils-1.0.so.0
+lib/libQt%%QTVER_SUFFIX%%GStreamerUtils-1.0.so.%%SHLIB_VER%%
+%%QT5_ONLY%%lib/libQt%%QTVER_SUFFIX%%GStreamerQuick-1.0.so
+%%QT5_ONLY%%lib/libQt%%QTVER_SUFFIX%%GStreamerQuick-1.0.so.0
+%%QT5_ONLY%%lib/libQt%%QTVER_SUFFIX%%GStreamerQuick-1.0.so.%%SHLIB_VER%%
+%%QT4_ONLY%%%%QT_IMPORTDIR%%/Qt%%QTVER_SUFFIX%%GStreamer/libQtGStreamerQuick1.so
+%%QT4_ONLY%%%%QT_IMPORTDIR%%/Qt%%QTVER_SUFFIX%%GStreamer/qmldir
+%%QT5_ONLY%%%%QT_QMLDIR%%/QtGStreamer/libQtGStreamerQuick2.so
+%%QT5_ONLY%%%%QT_QMLDIR%%/QtGStreamer/qmldir
+libdata/pkgconfig/Qt%%QTVER_SUFFIX%%GLib-2.0.pc
+libdata/pkgconfig/Qt%%QTVER_SUFFIX%%GStreamer-1.0.pc
+libdata/pkgconfig/Qt%%QTVER_SUFFIX%%GStreamerUi-1.0.pc
+libdata/pkgconfig/Qt%%QTVER_SUFFIX%%GStreamerUtils-1.0.pc
+%%QT5_ONLY%%libdata/pkgconfig/Qt%%QTVER_SUFFIX%%GStreamerQuick-1.0.pc