aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer1-validate
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-09-26 22:36:23 +0800
committerkwm <kwm@FreeBSD.org>2015-09-26 22:36:23 +0800
commit26e024bbdbff43dece4e929f6104deec587ed50b (patch)
tree6e57fabcf96c9308178f83f5236aab5d8f1b0127 /multimedia/gstreamer1-validate
parent4f5ebbd6dcc224be3e1964f0cd8ec898e31d3b69 (diff)
downloadfreebsd-ports-gnome-26e024bbdbff43dece4e929f6104deec587ed50b.tar.gz
freebsd-ports-gnome-26e024bbdbff43dece4e929f6104deec587ed50b.tar.zst
freebsd-ports-gnome-26e024bbdbff43dece4e929f6104deec587ed50b.zip
Update gstreamer1 ports to 1.6.0.
* gstreamer1-libav now uses ffmpeg from ports. * New ports: * gstreamer1-validate: Tools to detect if elements are not behaving as expected, mainly aimed at developers, or advanced debugging. * gstreamer1-rtsp-server: Base foundation for building a rtsp server ontop of GStreamer * Bunch of new plugins like: mpg123, rsvg, libde265, openh264, x265 and dtls. Release announcement: http://lists.freedesktop.org/archives/gstreamer-announce/2015-September/000357.html Obtained from: gnome devel repo
Diffstat (limited to 'multimedia/gstreamer1-validate')
-rw-r--r--multimedia/gstreamer1-validate/Makefile22
-rw-r--r--multimedia/gstreamer1-validate/distinfo2
-rw-r--r--multimedia/gstreamer1-validate/files/patch-Makefile10
-rw-r--r--multimedia/gstreamer1-validate/pkg-descr13
-rw-r--r--multimedia/gstreamer1-validate/pkg-plist110
5 files changed, 157 insertions, 0 deletions
diff --git a/multimedia/gstreamer1-validate/Makefile b/multimedia/gstreamer1-validate/Makefile
new file mode 100644
index 000000000000..ba4428daebbb
--- /dev/null
+++ b/multimedia/gstreamer1-validate/Makefile
@@ -0,0 +1,22 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gstreamer1-validate
+PORTVERSION= 1.6.0
+CATEGORIES= multimedia
+MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-validate/
+DISTNAME= gst-validate-${PORTVERSION}
+
+MAINTAINER= multimedia@FreeBSD.org
+COMMENT= Gstreamer element validation suite
+
+USES= gmake libtool pathfix pkgconfig python:2 tar:xz
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gtk30 introspection:build
+USE_GSTREAMER1= yes
+INSTALL_TARGET= install-strip
+
+PLIST_SUB= VERSION=1.0
+
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer1-validate/distinfo b/multimedia/gstreamer1-validate/distinfo
new file mode 100644
index 000000000000..665e22ef652a
--- /dev/null
+++ b/multimedia/gstreamer1-validate/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gst-validate-1.6.0.tar.xz) = 3baef8c7b5363293c20314a30afd54629849fc597669991fdcf92303602dafee
+SIZE (gst-validate-1.6.0.tar.xz) = 623012
diff --git a/multimedia/gstreamer1-validate/files/patch-Makefile b/multimedia/gstreamer1-validate/files/patch-Makefile
new file mode 100644
index 000000000000..e0c388eed13f
--- /dev/null
+++ b/multimedia/gstreamer1-validate/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.in.orig 2015-06-27 16:40:59.936055000 +0200
++++ Makefile.in 2015-06-27 16:41:12.766046000 +0200
+@@ -537,7 +537,6 @@
+ launcher \
+ tools \
+ pkgconfig \
+- docs \
+ tests \
+ po
+
diff --git a/multimedia/gstreamer1-validate/pkg-descr b/multimedia/gstreamer1-validate/pkg-descr
new file mode 100644
index 000000000000..ff707a0989f0
--- /dev/null
+++ b/multimedia/gstreamer1-validate/pkg-descr
@@ -0,0 +1,13 @@
+The goal of GstValidate is to be able to detect when elements are not
+behaving as expected and report it to the user so he knows how things
+are supposed to work inside a GstPipeline. In the end, fixing issues
+found by the tool will ensure that all elements behave all together in
+the expected way.
+
+The easiest way of using GstValidate is to use one of its command-line
+tools, located at tools/ directory. It is also possible to monitor
+GstPipelines from any application by using the LD_PRELOAD gstvalidate
+lib. The third way of using it is to write your own application that
+links and uses libgstvalidate.
+
+WWW: http://gstreamer.freedesktop.org/
diff --git a/multimedia/gstreamer1-validate/pkg-plist b/multimedia/gstreamer1-validate/pkg-plist
new file mode 100644
index 000000000000..37a78aa7ce87
--- /dev/null
+++ b/multimedia/gstreamer1-validate/pkg-plist
@@ -0,0 +1,110 @@
+bin/gst-validate-%%VERSION%%
+bin/gst-validate-images-check-%%VERSION%%
+bin/gst-validate-launcher
+bin/gst-validate-media-check-%%VERSION%%
+bin/gst-validate-transcoding-%%VERSION%%
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-bin-monitor.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-element-monitor.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-enums.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-media-info.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-monitor-factory.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-monitor.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-override-registry.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-override.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-pad-monitor.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-pipeline-monitor.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-report.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-reporter.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-runner.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-scenario.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-types.h
+include/gstreamer-%%VERSION%%/gst/validate/gst-validate-utils.h
+include/gstreamer-%%VERSION%%/gst/validate/media-descriptor-parser.h
+include/gstreamer-%%VERSION%%/gst/validate/media-descriptor-writer.h
+include/gstreamer-%%VERSION%%/gst/validate/media-descriptor.h
+include/gstreamer-%%VERSION%%/gst/validate/validate.h
+include/gstreamer-%%VERSION%%/lib/validate/video/gssim.h
+include/gstreamer-%%VERSION%%/lib/validate/video/gstvalidatessim.h
+lib/girepository-%%VERSION%%/GstValidate-%%VERSION%%.typelib
+lib/gst-validate-launcher/python/launcher/RangeHTTPServer.py
+lib/gst-validate-launcher/python/launcher/RangeHTTPServer.pyc
+lib/gst-validate-launcher/python/launcher/RangeHTTPServer.pyo
+lib/gst-validate-launcher/python/launcher/__init__.py
+lib/gst-validate-launcher/python/launcher/__init__.pyc
+lib/gst-validate-launcher/python/launcher/__init__.pyo
+lib/gst-validate-launcher/python/launcher/apps/__init__.py
+lib/gst-validate-launcher/python/launcher/apps/__init__.pyc
+lib/gst-validate-launcher/python/launcher/apps/__init__.pyo
+lib/gst-validate-launcher/python/launcher/apps/gstvalidate.py
+lib/gst-validate-launcher/python/launcher/apps/gstvalidate.pyc
+lib/gst-validate-launcher/python/launcher/apps/gstvalidate.pyo
+lib/gst-validate-launcher/python/launcher/baseclasses.py
+lib/gst-validate-launcher/python/launcher/baseclasses.pyc
+lib/gst-validate-launcher/python/launcher/baseclasses.pyo
+lib/gst-validate-launcher/python/launcher/config.py
+lib/gst-validate-launcher/python/launcher/config.pyc
+lib/gst-validate-launcher/python/launcher/config.pyo
+lib/gst-validate-launcher/python/launcher/httpserver.py
+lib/gst-validate-launcher/python/launcher/httpserver.pyc
+lib/gst-validate-launcher/python/launcher/httpserver.pyo
+lib/gst-validate-launcher/python/launcher/loggable.py
+lib/gst-validate-launcher/python/launcher/loggable.pyc
+lib/gst-validate-launcher/python/launcher/loggable.pyo
+lib/gst-validate-launcher/python/launcher/main.py
+lib/gst-validate-launcher/python/launcher/main.pyc
+lib/gst-validate-launcher/python/launcher/main.pyo
+lib/gst-validate-launcher/python/launcher/reporters.py
+lib/gst-validate-launcher/python/launcher/reporters.pyc
+lib/gst-validate-launcher/python/launcher/reporters.pyo
+lib/gst-validate-launcher/python/launcher/utils.py
+lib/gst-validate-launcher/python/launcher/utils.pyc
+lib/gst-validate-launcher/python/launcher/utils.pyo
+lib/gst-validate-launcher/python/launcher/vfb_server.py
+lib/gst-validate-launcher/python/launcher/vfb_server.pyc
+lib/gst-validate-launcher/python/launcher/vfb_server.pyo
+lib/gstreamer-%%VERSION%%/validate/libgstvalidatefaultinjection.so
+lib/gstreamer-%%VERSION%%/validate/libgstvalidategapplication.so
+lib/gstreamer-%%VERSION%%/validate/libgstvalidategtk.so
+lib/gstreamer-%%VERSION%%/validate/libgstvalidatessim.so
+lib/libgstvalidate-%%VERSION%%.so
+lib/libgstvalidate-%%VERSION%%.so.0
+lib/libgstvalidate-%%VERSION%%.so.0.0.0
+lib/libgstvalidate-default-overrides-%%VERSION%%.so
+lib/libgstvalidate-default-overrides-%%VERSION%%.so.0
+lib/libgstvalidate-default-overrides-%%VERSION%%.so.0.0.0
+lib/libgstvalidate_preload-%%VERSION%%.so
+lib/libgstvalidate_preload-%%VERSION%%.so.0
+lib/libgstvalidate_preload-%%VERSION%%.so.0.0.0
+lib/libgstvalidatevideo-%%VERSION%%.so
+lib/libgstvalidatevideo-%%VERSION%%.so.0
+lib/libgstvalidatevideo-%%VERSION%%.so.0.0.0
+libdata/pkgconfig/gst-validate-%%VERSION%%.pc
+share/gir-%%VERSION%%/GstValidate-%%VERSION%%.gir
+share/gstreamer-%%VERSION%%/validate/gst.supp
+share/gstreamer-%%VERSION%%/validate/gstvalidate.supp
+share/gstreamer-%%VERSION%%/validate/scenarios/adaptive_video_framerate.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/adaptive_video_framerate_size.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/adaptive_video_size.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/alternate_fast_backward_forward.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/change_state_intensive.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/disable_subtitle_track_while_paused.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/fast_backward.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/fast_forward.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/force_key_unit.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/pause_resume.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/play_15s.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/reverse_playback.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/scrub_backward_seeking.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/scrub_backward_seeking_full.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/scrub_forward_seeking.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/scrub_forward_seeking_full.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/seek_backward.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/seek_forward.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/seek_forward_backward.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/seek_with_stop.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/simple_seeks.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/switch_audio_track.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/switch_audio_track_while_paused.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/switch_subtitle_track.scenario
+share/gstreamer-%%VERSION%%/validate/scenarios/switch_subtitle_track_while_paused.scenario
+share/gstreamer-%%VERSION%%/validate/valgrind.config