aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-11-02 06:14:07 +0800
committerkwm <kwm@FreeBSD.org>2013-11-02 06:14:07 +0800
commit1a8785035bcea4385a2ef2b954860630a0805972 (patch)
treeb260b05e7fe7e534f08af61d8504ddf8a7ab5a49 /multimedia/gstreamer
parent77c3437069513ce4c186a3089baef619f66b5999 (diff)
downloadfreebsd-ports-gnome-1a8785035bcea4385a2ef2b954860630a0805972.tar.gz
freebsd-ports-gnome-1a8785035bcea4385a2ef2b954860630a0805972.tar.zst
freebsd-ports-gnome-1a8785035bcea4385a2ef2b954860630a0805972.zip
Stagify Gstreamer ports.
Fix build of gstreamer and gstreamer1 with glib 2.38.x [1]. Update gstreamer and gstreamer-plugins to new rules, USES=gmake pathfix, new LIB_DEPENDS syntax. Only pull in flex if base version is too old. Be more selective for which OSVERSIONS we need gcc due to the clang bug. Obtained from: Gstreamer upstream [1]
Diffstat (limited to 'multimedia/gstreamer')
-rw-r--r--multimedia/gstreamer/Makefile38
-rw-r--r--multimedia/gstreamer/files/patch-gst_gstdatetime.c12
-rw-r--r--multimedia/gstreamer/pkg-plist6
3 files changed, 38 insertions, 18 deletions
diff --git a/multimedia/gstreamer/Makefile b/multimedia/gstreamer/Makefile
index cd90c87c262d..f3d64e980c0b 100644
--- a/multimedia/gstreamer/Makefile
+++ b/multimedia/gstreamer/Makefile
@@ -10,19 +10,13 @@ MASTER_SITES= http://gstreamer.freedesktop.org/src/gstreamer/
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Development framework for creating media applications
-BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
- gobject-introspection>=0.9.12:${PORTSDIR}/devel/gobject-introspection
-RUN_DEPENDS= ${LOCALBASE}/share/gir-1.0/GLib-2.0.gir:${PORTSDIR}/devel/gobject-introspection
-
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
+
CFLAGS:= ${CFLAGS} -O2 -Wno-format
-USES= bison pathfix pkgconfig gettext
-# workaround a crash in clang 3.3 crash llvm bug # 15840
-USE_GCC= any
+USES= bison gettext gmake pathfix pkgconfig
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_GNOME= glib20 libxml2 ltverhack ltasneededhack
+USE_GNOME= glib20 introspection libxml2 ltverhack ltasneededhack
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --disable-tests \
--disable-examples \
@@ -30,33 +24,41 @@ CONFIGURE_ARGS= --disable-tests \
--disable-gtk-doc
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= ac_cv_func_register_printf_function="no" \
- FLEX_PATH="${LOCALBASE}/bin/flex"
+CONFIGURE_ENV= ac_cv_func_register_printf_function="no"
PLIST_SUB= VERSION="${GST_VERSION}"
USE_LDCONFIG= yes
GST_VERSION= 0.10
-MAN1= gst-feedback-${GST_VERSION}.1 gst-inspect-${GST_VERSION}.1 \
- gst-launch-${GST_VERSION}.1 \
- gst-typefind-${GST_VERSION}.1 gst-xmlinspect-${GST_VERSION}.1 \
- gst-xmllaunch-${GST_VERSION}.1
-
OPTIONS_DEFINE= LIBCHECK
LIBCHECK_DESC= Unit tests support
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MLIBCHECK}
-LIB_DEPENDS+= check:${PORTSDIR}/devel/libcheck
+LIB_DEPENDS+= libcheck.so:${PORTSDIR}/devel/libcheck
PLIST_SUB+= CHECK=""
.else
CONFIGURE_ARGS+=--disable-check
PLIST_SUB+= CHECK="@comment "
.endif
+# workaround a crash in clang 3.3 crash llvm bug # 15840
+.if ((${OSVERSION} >= 901504 && ${OSVERSION} < 902502) || \
+ (${OSVERSION} >= 1000037 && ${OSVERSION} < 1000056))
+USE_GCC= any
+.endif
+
+.if ${OSVERSION} < 1000033
+BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+CONFIGURE_ENV+= FLEX_PATH="${LOCALBASE}/bin/flex"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgst*.so*
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gstreamer-0.10/libgst*.so
+
.include <bsd.port.post.mk>
diff --git a/multimedia/gstreamer/files/patch-gst_gstdatetime.c b/multimedia/gstreamer/files/patch-gst_gstdatetime.c
new file mode 100644
index 000000000000..8eac4d8c76d4
--- /dev/null
+++ b/multimedia/gstreamer/files/patch-gst_gstdatetime.c
@@ -0,0 +1,12 @@
+--- gst/gstdatetime.c.orig 2013-10-20 16:05:12.000000000 +0200
++++ gst/gstdatetime.c 2013-10-20 16:05:24.000000000 +0200
+@@ -21,8 +21,8 @@
+ #include "config.h"
+ #endif
+
+-#include "glib-compat-private.h"
+ #include "gst_private.h"
++#include "glib-compat-private.h"
+ #include "gstdatetime.h"
+ #include "gstvalue.h"
+ #include <glib.h>
diff --git a/multimedia/gstreamer/pkg-plist b/multimedia/gstreamer/pkg-plist
index 50bd60265d69..a78167eaf032 100644
--- a/multimedia/gstreamer/pkg-plist
+++ b/multimedia/gstreamer/pkg-plist
@@ -135,6 +135,12 @@ libdata/pkgconfig/gstreamer-controller-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-dataprotocol-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-net-%%VERSION%%.pc
libexec/gstreamer-%%VERSION%%/gst-plugin-scanner
+man/man1/gst-feedback-0.10.1.gz
+man/man1/gst-inspect-0.10.1.gz
+man/man1/gst-launch-0.10.1.gz
+man/man1/gst-typefind-0.10.1.gz
+man/man1/gst-xmlinspect-0.10.1.gz
+man/man1/gst-xmllaunch-0.10.1.gz
share/aclocal/gst-element-check-%%VERSION%%.m4
share/gir-1.0/Gst-%%VERSION%%.gir
share/gir-1.0/GstBase-%%VERSION%%.gir