aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gsubedit/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-04-09 15:40:18 +0800
committerijliao <ijliao@FreeBSD.org>2002-04-09 15:40:18 +0800
commit120c5a42de1f531a61b8c57f4ff79c177125ab8a (patch)
tree6006fb873ee85c6e7a2ad2a39bbb4f30ae86975e /multimedia/gsubedit/Makefile
parentff0be53ec619c447851026ebdf7083d90ec873c5 (diff)
downloadfreebsd-ports-gnome-120c5a42de1f531a61b8c57f4ff79c177125ab8a.tar.gz
freebsd-ports-gnome-120c5a42de1f531a61b8c57f4ff79c177125ab8a.tar.zst
freebsd-ports-gnome-120c5a42de1f531a61b8c57f4ff79c177125ab8a.zip
- Support CFLAGS properly
- Remove unnecessary USE_BISON - Utilize NOPORTDOCS PR: 36892 Submitted by: Ports Fury
Diffstat (limited to 'multimedia/gsubedit/Makefile')
-rw-r--r--multimedia/gsubedit/Makefile25
1 files changed, 20 insertions, 5 deletions
diff --git a/multimedia/gsubedit/Makefile b/multimedia/gsubedit/Makefile
index 95cad49fa091..912598a18b4c 100644
--- a/multimedia/gsubedit/Makefile
+++ b/multimedia/gsubedit/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gsubedit
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,14 +16,28 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
USE_X_PREFIX= yes
-USE_BISON= yes
+USE_GMAKE= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gnome
-USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
post-patch:
- @${PERL} -pi -e "s,Bison ,Bison,g" ${WRKSRC}/configure
- @${PERL} -pi -e "s,doc/,share/doc/,g" ${WRKSRC}/Makefile.in
+ @${PERL} -pi -e 's|Bison |Bison|g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
+ s|share/pixmaps|share/gnome/pixmaps|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${PERL} -pi -e \
+ 's|^gsubeditdoc|#gsubeditdoc|g ; \
+ s|-g -O2|| ; \
+ s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|'
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in AUTHORS ChangeLog INSTALL README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>