aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gtksubtitler/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-11-22 02:52:53 +0800
committerlioux <lioux@FreeBSD.org>2002-11-22 02:52:53 +0800
commit91b3d835f3aecf355887ebada6cc0a1b7d6062da (patch)
treeb62fad4e0f00b1ad70e8386fc12029c9b68d1e6b /multimedia/gtksubtitler/Makefile
parent214b7945a59052de26770831de6623c2999a4955 (diff)
downloadfreebsd-ports-gnome-91b3d835f3aecf355887ebada6cc0a1b7d6062da.tar.gz
freebsd-ports-gnome-91b3d835f3aecf355887ebada6cc0a1b7d6062da.tar.zst
freebsd-ports-gnome-91b3d835f3aecf355887ebada6cc0a1b7d6062da.zip
New port GTKsubtitler version 0.1.3: A small GNOME program for
editing and converting subtitles
Diffstat (limited to 'multimedia/gtksubtitler/Makefile')
-rw-r--r--multimedia/gtksubtitler/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/multimedia/gtksubtitler/Makefile b/multimedia/gtksubtitler/Makefile
new file mode 100644
index 000000000000..58fd2f76a9a5
--- /dev/null
+++ b/multimedia/gtksubtitler/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: gtksubtitler
+# Date created: Thu Nov 21 15:05:53 UTC 2002
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GTKsubtitler
+PORTVERSION= 0.1.3
+CATEGORIES= multimedia gnome
+MASTER_SITES= http://dark.pkn.com.pl/~pawel/gtksubtitler/download/
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= lioux@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomelibs
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+post-patch:
+# disable GNU auto* tools
+ @${FIND} ${WRKSRC} -type f -name "Makefile.in" | \
+ ${XARGS} -x -n 10 ${REINPLACE_CMD} -E -e \
+ 's!^(ACLOCAL|AUTOCONF|AUTOMAKE|AUTOHEADER).+$$!\1=${TRUE}!'
+
+.include <bsd.port.mk>