aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gxine/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-04-20 02:34:23 +0800
committeradamw <adamw@FreeBSD.org>2003-04-20 02:34:23 +0800
commit625ff17f68bb93764151ba842a186907b3aad137 (patch)
treecae0dbe7af8991511de53828333c0bbc4c69a8b4 /multimedia/gxine/Makefile
parent0b938893d6492476b2153b4e742ec256cafbe02a (diff)
downloadfreebsd-ports-gnome-625ff17f68bb93764151ba842a186907b3aad137.tar.gz
freebsd-ports-gnome-625ff17f68bb93764151ba842a186907b3aad137.tar.zst
freebsd-ports-gnome-625ff17f68bb93764151ba842a186907b3aad137.zip
Add gxine, a GTK interface to xine. The interface is simple, but stable.
PR: 51156 Submitted by: Grigori Goronzy <greg@chown.ath.cx>
Diffstat (limited to 'multimedia/gxine/Makefile')
-rw-r--r--multimedia/gxine/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/multimedia/gxine/Makefile b/multimedia/gxine/Makefile
new file mode 100644
index 000000000000..86dcc561d6c4
--- /dev/null
+++ b/multimedia/gxine/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gxine
+# Date created: Sa 19 Apr 2003 01:34:06 CEST
+# Whom: Grigori Goronzy <greg@chown.ath.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gxine
+PORTVERSION= 0.3.3
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xine
+
+MAINTAINER= greg@chown.ath.cx
+COMMENT= An alternative GUI for the Xine media player
+
+LIB_DEPENDS= xine.6:${PORTSDIR}/multimedia/libxine
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GNOME= gtk20
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -I${X11BASE}/lib"
+
+MANLANG= "" de
+MAN1= gxine.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/browser-plugin//' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>