aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gxmms
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-11-04 21:56:44 +0800
committerpav <pav@FreeBSD.org>2004-11-04 21:56:44 +0800
commit59a10caebf50b5f8691c57db259b3428edbeb352 (patch)
tree6ae4f97cd34cad1c642eeb69c54c1c672ea6dee4 /multimedia/gxmms
parente2f4c404cfa2ffcaa8586f82f454d205856d59e1 (diff)
downloadfreebsd-ports-gnome-59a10caebf50b5f8691c57db259b3428edbeb352.tar.gz
freebsd-ports-gnome-59a10caebf50b5f8691c57db259b3428edbeb352.tar.zst
freebsd-ports-gnome-59a10caebf50b5f8691c57db259b3428edbeb352.zip
Add gxmms, a simple GNOME panel applet that lets you control the basic
functions of the X MultiMedia System (XMMS). It has the following features: * Scrollable track time progress bar * Volume control with mouse scrollwheel * Buttons: Previous track - Play / Pause - Stop - Next track - Eject * Real-time tooltips with track title and time * Control repeat and shuffle properties * Show/Hide main window, playlist editor, graphical eq and more * Internazionalization (i18n) PR: ports/73480 Submitted by: Radek Kozlowski <radek@raadradd.com>
Diffstat (limited to 'multimedia/gxmms')
-rw-r--r--multimedia/gxmms/Makefile27
-rw-r--r--multimedia/gxmms/distinfo2
-rw-r--r--multimedia/gxmms/files/patch-src-xmmsctrl.c18
-rw-r--r--multimedia/gxmms/pkg-descr13
-rw-r--r--multimedia/gxmms/pkg-plist14
5 files changed, 74 insertions, 0 deletions
diff --git a/multimedia/gxmms/Makefile b/multimedia/gxmms/Makefile
new file mode 100644
index 000000000000..fc9ff1ae8de7
--- /dev/null
+++ b/multimedia/gxmms/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gxmms
+# Date created: 3 November 2004
+# Whom: Radek Kozlowski <radek@raadradd.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gxmms
+PORTVERSION= 0.2.1
+CATEGORIES= multimedia gnome
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= radek@raadradd.com
+COMMENT= A simple GNOME panel applet for controlling XMMS
+
+BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomepanel gnomeprefix intlhack
+USE_LIBTOOL_VER=15
+USE_X_PREFIX= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/multimedia/gxmms/distinfo b/multimedia/gxmms/distinfo
new file mode 100644
index 000000000000..9fcfbefc3879
--- /dev/null
+++ b/multimedia/gxmms/distinfo
@@ -0,0 +1,2 @@
+MD5 (gxmms-0.2.1.tar.gz) = cdb986fa0545b787ac71ef6336823831
+SIZE (gxmms-0.2.1.tar.gz) = 129794
diff --git a/multimedia/gxmms/files/patch-src-xmmsctrl.c b/multimedia/gxmms/files/patch-src-xmmsctrl.c
new file mode 100644
index 000000000000..2e14c7e83b7d
--- /dev/null
+++ b/multimedia/gxmms/files/patch-src-xmmsctrl.c
@@ -0,0 +1,18 @@
+--- src/xmmsctrl.c.orig Fri Sep 3 00:19:54 2004
++++ src/xmmsctrl.c Thu Nov 4 14:36:56 2004
+@@ -48,13 +48,14 @@
+ static gchar *msg_error = _("Sorry, unable to launch XMMS.");
+ gint timer;
+ time_t lt;
++ gchar *exec_this;
+
+ if (xmms_remote_is_running(xmms->session))
+ {
+ return;
+ }
+
+- gchar *exec_this = g_strdup_printf("%s &", exec_cmd);
++ exec_this = g_strdup_printf("%s &", exec_cmd);
+
+ if (system(exec_this))
+ {
diff --git a/multimedia/gxmms/pkg-descr b/multimedia/gxmms/pkg-descr
new file mode 100644
index 000000000000..8c7cc24c1b49
--- /dev/null
+++ b/multimedia/gxmms/pkg-descr
@@ -0,0 +1,13 @@
+Gxmms is a simple GNOME panel applet that lets you control the basic
+functions of the X MultiMedia System (XMMS). It has the following
+features:
+
+ * Scrollable track time progress bar
+ * Volume control with mouse scrollwheel
+ * Buttons: Previous track - Play / Pause - Stop - Next track - Eject
+ * Real-time tooltips with track title and time
+ * Control repeat and shuffle properties
+ * Show/Hide main window, playlist editor, graphical eq and more
+ * Internazionalization (i18n)
+
+WWW: http://www.nongnu.org/gxmms/
diff --git a/multimedia/gxmms/pkg-plist b/multimedia/gxmms/pkg-plist
new file mode 100644
index 000000000000..1eae5f334dbb
--- /dev/null
+++ b/multimedia/gxmms/pkg-plist
@@ -0,0 +1,14 @@
+libdata/bonobo/servers/GNOME_gxmmsApplet.server
+libexec/gxmms_applet
+share/gnome/gnome-2.0/ui/GNOME_gxmmsApplet.xml
+share/gnome/gxmms/gxmms.png
+share/gnome/gxmms/gxmms_eject.png
+share/gnome/gxmms/gxmms_next.png
+share/gnome/gxmms/gxmms_play_pause.png
+share/gnome/gxmms/gxmms_prev.png
+share/gnome/gxmms/gxmms_stop.png
+share/gnome/pixmaps/gxmms_mini.png
+share/locale/ca/LC_MESSAGES/gxmms.mo
+share/locale/es/LC_MESSAGES/gxmms.mo
+share/locale/fr/LC_MESSAGES/gxmms.mo
+@dirrm share/gnome/gxmms