aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/helixplayer
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-11-27 22:18:19 +0800
committershaun <shaun@FreeBSD.org>2006-11-27 22:18:19 +0800
commitdfff7508c587ae47de672556febcd44ff529a537 (patch)
treea444e9489f5b2c03a5457d4d40c369e9ee7ea076 /multimedia/helixplayer
parentea6f64baabb488058b1ee0fd885c40ba0221c3de (diff)
downloadfreebsd-ports-gnome-dfff7508c587ae47de672556febcd44ff529a537.tar.gz
freebsd-ports-gnome-dfff7508c587ae47de672556febcd44ff529a537.tar.zst
freebsd-ports-gnome-dfff7508c587ae47de672556febcd44ff529a537.zip
Fix a crash in the plugin code, and use vfork(2) instead of fork(2).
Submitted by: mi
Diffstat (limited to 'multimedia/helixplayer')
-rw-r--r--multimedia/helixplayer/Makefile1
-rw-r--r--multimedia/helixplayer/files/patch-player_app_plugin_hxbackend.cpp16
2 files changed, 17 insertions, 0 deletions
diff --git a/multimedia/helixplayer/Makefile b/multimedia/helixplayer/Makefile
index 52442c612b87..b8d8cb5ef8ef 100644
--- a/multimedia/helixplayer/Makefile
+++ b/multimedia/helixplayer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hxplay
PORTVERSION= 1.0.7
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= https://helixcommunity.org/frs/download.php/1950/ \
${MASTER_SITE_LOCAL}
diff --git a/multimedia/helixplayer/files/patch-player_app_plugin_hxbackend.cpp b/multimedia/helixplayer/files/patch-player_app_plugin_hxbackend.cpp
new file mode 100644
index 000000000000..16829fcdf5a2
--- /dev/null
+++ b/multimedia/helixplayer/files/patch-player_app_plugin_hxbackend.cpp
@@ -0,0 +1,16 @@
+--- player/app/plugin/hxbackend.cpp.orig Sun Oct 22 13:50:24 2006
++++ player/app/plugin/hxbackend.cpp Sun Oct 22 13:50:24 2006
+@@ -358,5 +357,5 @@ nsresult CHXPlayerBackend::ReceiveMessag
+ {
+ /* Trim back the buffer to the size we actually used (plus NULL) */
+- pBuf = (char*)realloc(pBuf, nPos + 1);
++ *ppBuf = (char*)realloc(pBuf, nPos + 1);
+ }
+ else
+@@ -509,5 +500,5 @@
+ fcntl(cbsockets[1], F_SETFD, 0);
+
+- m_nChildPid = fork();
++ m_nChildPid = vfork();
+ if(m_nChildPid < 0)
+ {