aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/kdemultimedia3/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-04-22 07:47:50 +0800
committerwill <will@FreeBSD.org>2002-04-22 07:47:50 +0800
commit9a055e87611beb41b98be5a2fe9e0206e33101e8 (patch)
treec06250f8a52c1d8b199e541cd41068fe11b11219 /multimedia/kdemultimedia3/Makefile
parentb471bb2de2ef8435ad3f5071b5ba82d535385f85 (diff)
downloadfreebsd-ports-gnome-9a055e87611beb41b98be5a2fe9e0206e33101e8.tar.gz
freebsd-ports-gnome-9a055e87611beb41b98be5a2fe9e0206e33101e8.tar.zst
freebsd-ports-gnome-9a055e87611beb41b98be5a2fe9e0206e33101e8.zip
Please welcome Qt3/KDE3 to our ports tree. This includes work since the
original versions of these ports, so some PORTREVISIONs were bumped. See http://freebsd.kde.org/ and mailing lists linked to from there for info on the packages generated to test these ports. bsd.kde.mk has already been updated a few days ago to work with these. Some patches applied to fix a few bugs were: deskutils/kdepim3: [1] Remove kpilot from build because it wasn't ready at release. editors/koffice-kde3: [2] Fix compile time bugs for FreeBSD. misc/kdeedu3: [3] Fix compile problem with kvoctrain. x11/kdebase3: [4] Fix KDM CPU usage and login bug. Some caveats: * All PLISTs are broken for deinstall due to script bug that I didn't notice until very recently. This will be fixed when I commit an update tomorrow. These ports should still install perfectly fine though. They should also deinstall without giving errors, but will leave directories behind. * You can't install this with any other version of QT or KDE already installed. I am not sure the checks are 100% working, but fixes for these will be forthcoming. This is mainly due to a policy decision made by kde@ to make QT/KDE ports install the way the rest of the world expects it to while also still conforming to FreeBSD's hier(7). For reference on this decision, please consult the KDE/FreeBSD mailing list archives. This decision fixes 2-year-old bug reports relating to how we handled this for KDE2 vs KDE1. Submitted by: [1] Adrian de Groot <adridg@cs.kun.nl>, [2] David Faure <faure@kde.org>, Andy Fawcett <andy@athame.co.uk> Lauri Watts <lauri@kde.org> [3] Lauri Watts <lauri@kde.org> [4] Alan Eldridge <alane@geeksrus.net> Oswald Buddenhagen <ossi@kde.org> Reviewed by: kde
Diffstat (limited to 'multimedia/kdemultimedia3/Makefile')
-rw-r--r--multimedia/kdemultimedia3/Makefile44
1 files changed, 11 insertions, 33 deletions
diff --git a/multimedia/kdemultimedia3/Makefile b/multimedia/kdemultimedia3/Makefile
index d67ccbedea49..ac2b221f2d01 100644
--- a/multimedia/kdemultimedia3/Makefile
+++ b/multimedia/kdemultimedia3/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= kdemultimedia
-PORTVERSION= 2.2.2
-PORTREVISION= 2
+PORTVERSION= 3.0
+PORTREVISION= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -15,47 +15,25 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
-BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14
-LIB_DEPENDS= ogg.3:${PORTSDIR}/audio/libogg \
- vorbis.1:${PORTSDIR}/audio/libvorbis
RUN_DEPENDS= xanim:${PORTSDIR}/graphics/xanim
+LIB_DEPENDS+= ogg.3:${PORTSDIR}/audio/libogg \
+ vorbis.1:${PORTSDIR}/audio/libvorbis
-USE_KDELIBS_VER=2
+USE_KDELIBS_VER=3
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib
-
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
USE_GMAKE= yes
MAKE_ENV= ${CONFIGURE_ENV}
+# spurious, but i don't care
.include <bsd.port.pre.mk>
-_NO_KDE_FINAL= yes
-.if ${OSVERSION} >= 500029
-_NO_KDE_OBJPRELINK=yes
-.endif
-.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
-
-pre-configure:
- ${PERL} -pi -e "s@all_includes=\"@all_includes=\"-I/usr/include @g" \
- ${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4
- ${PERL} -pi -e \
- 's,kscd_compile=no,kscd_compile=yes,g; \
- s,kde_artsplug_compiles = xno,kde_artsplug_compiles = x,g' \
- ${WRKSRC}/kscd/configure.in.in
- ${MKDIR} ${WRKSRC}/auto-bin
-.for AC in autoconf autoheader
- ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
-.endfor
-.for AM in automake aclocal
- ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
-.endfor
- cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
- ${GMAKE} -f Makefile.cvs
-
post-install:
@${ECHO_MSG}
@${ECHO_MSG} "In order to run the kscd program properly, please run as root:"