aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/kino
diff options
context:
space:
mode:
authorpb <pb@FreeBSD.org>2007-01-16 17:59:27 +0800
committerpb <pb@FreeBSD.org>2007-01-16 17:59:27 +0800
commit6e30997061e68b66404a6d3bcb246ce2e61fb5d0 (patch)
treee0fecd41718c64359750e1a4b26b059528394dda /multimedia/kino
parent5c01627902e89a14df40bc6058dd5b3c74e52de8 (diff)
downloadfreebsd-ports-gnome-6e30997061e68b66404a6d3bcb246ce2e61fb5d0.tar.gz
freebsd-ports-gnome-6e30997061e68b66404a6d3bcb246ce2e61fb5d0.tar.zst
freebsd-ports-gnome-6e30997061e68b66404a6d3bcb246ce2e61fb5d0.zip
- update to 0.9.5
- add patch to fix bug in Xv mode when shmget() fails
Diffstat (limited to 'multimedia/kino')
-rw-r--r--multimedia/kino/Makefile6
-rw-r--r--multimedia/kino/distinfo6
-rw-r--r--multimedia/kino/files/patch-ak10
-rw-r--r--multimedia/kino/files/patch-src__displayer.cc37
-rw-r--r--multimedia/kino/pkg-plist88
5 files changed, 128 insertions, 19 deletions
diff --git a/multimedia/kino/Makefile b/multimedia/kino/Makefile
index 267b6cc64b65..429205d02eb7 100644
--- a/multimedia/kino/Makefile
+++ b/multimedia/kino/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kino
-PORTVERSION= 0.9.4
+PORTVERSION= 0.9.5
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -40,8 +40,8 @@ MAN1= kino.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500039
-USE_GCC= 3.4
+.if ${OSVERSION} < 500000
+IGNORE= Does not compile on FreeBSD 4.x
.endif
.if defined(WITH_QUICKTIME)
diff --git a/multimedia/kino/distinfo b/multimedia/kino/distinfo
index 74910d7dbb5c..765f5cdd081c 100644
--- a/multimedia/kino/distinfo
+++ b/multimedia/kino/distinfo
@@ -1,3 +1,3 @@
-MD5 (kino-0.9.4.tar.gz) = 7afb36c0c6d803b6d890ea5d3913bf0a
-SHA256 (kino-0.9.4.tar.gz) = 58c3812def324c02b8eee11655d883129ea710177395a458d43bb372517aa225
-SIZE (kino-0.9.4.tar.gz) = 1911931
+MD5 (kino-0.9.5.tar.gz) = e6a15f96523c2dcd8cc4a2f21c994687
+SHA256 (kino-0.9.5.tar.gz) = 0b0a9e879ae77b795e962c5a0272c8e387ce19e4a832d27b8d5a836ef9efcebe
+SIZE (kino-0.9.5.tar.gz) = 2449937
diff --git a/multimedia/kino/files/patch-ak b/multimedia/kino/files/patch-ak
deleted file mode 100644
index 64e86effe3ff..000000000000
--- a/multimedia/kino/files/patch-ak
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/image_filters.cc Tue Nov 25 21:51:18 2003
-+++ src/image_filters.cc Sat Apr 10 00:48:34 2004
-@@ -519,6 +519,7 @@
- GDKImageFilterRepository::GDKImageFilterRepository()
- {
- printf( ">> image filter repository created\n" );
-+ selected_filter = NULL;
-
- // Register an instance of each object (adapting raw filters to GDK filters where necessary)
- Register( new ImageFilterKeep() );
diff --git a/multimedia/kino/files/patch-src__displayer.cc b/multimedia/kino/files/patch-src__displayer.cc
new file mode 100644
index 000000000000..df759d03236e
--- /dev/null
+++ b/multimedia/kino/files/patch-src__displayer.cc
@@ -0,0 +1,37 @@
+--- src/displayer.cc.orig Tue Jan 16 01:52:01 2007
++++ src/displayer.cc Tue Jan 16 01:55:59 2007
+@@ -573,20 +573,23 @@
+ xvImage = ( XvImage * ) XvShmCreateImage( display, port, 0x32595559, 0, width, height, &shmInfo );
+
+ shmInfo.shmid = shmget( IPC_PRIVATE, xvImage->data_size, IPC_CREAT | 0777 );
+- shmInfo.shmaddr = ( char * ) shmat( shmInfo.shmid, 0, 0 );
+- xvImage->data = shmInfo.shmaddr;
+- shmInfo.readOnly = 0;
+- if ( !XShmAttach( gdk_display, &shmInfo ) )
+- {
++ if (shmInfo.shmid < 0) {
++ perror("shmget");
+ gotPort = false;
+- }
+- XSync( display, false );
+- shmctl( shmInfo.shmid, IPC_RMID, 0 );
++ } else {
++ shmInfo.shmaddr = ( char * ) shmat( shmInfo.shmid, 0, 0 );
++ xvImage->data = shmInfo.shmaddr;
++ shmInfo.readOnly = 0;
++ if ( !XShmAttach( gdk_display, &shmInfo ) )
++ {
++ gotPort = false;
++ }
++ XSync( display, false );
++ shmctl( shmInfo.shmid, IPC_RMID, 0 );
+ #if 0
+-
+- xvImage = ( XvImage * ) XvCreateImage( display, port, 0x32595559, pix, width , height );
++ xvImage = ( XvImage * ) XvCreateImage( display, port, 0x32595559, pix, width , height );
+ #endif
+-
++ }
+ }
+ }
+ else
diff --git a/multimedia/kino/pkg-plist b/multimedia/kino/pkg-plist
index 7bc3bd0b4a54..3e194b97773c 100644
--- a/multimedia/kino/pkg-plist
+++ b/multimedia/kino/pkg-plist
@@ -15,15 +15,12 @@ include/kino/time_map.h
lib/kino-gtk2/libdvtitler.a
lib/kino-gtk2/libdvtitler.la
lib/kino-gtk2/libdvtitler.so
-lib/kino-gtk2/libdvtitler.so.0
lib/kino-gtk2/libkinoplus.a
lib/kino-gtk2/libkinoplus.la
lib/kino-gtk2/libkinoplus.so
-lib/kino-gtk2/libkinoplus.so.0
lib/kino-gtk2/libtimfx.a
lib/kino-gtk2/libtimfx.la
lib/kino-gtk2/libtimfx.so
-lib/kino-gtk2/libtimfx.so.0
share/gnome/applications/Kino.desktop
share/gnome/kino/about.jpeg
share/gnome/kino/capture.png
@@ -89,6 +86,11 @@ share/gnome/kino/help/en/framedropping.html
share/gnome/kino/help/en/fx_audio.html
share/gnome/kino/help/en/fx_selection.html
share/gnome/kino/help/en/fx_video.html
+share/gnome/kino/help/en/images/caution.png
+share/gnome/kino/help/en/images/important.png
+share/gnome/kino/help/en/images/note.png
+share/gnome/kino/help/en/images/tip.png
+share/gnome/kino/help/en/images/warning.png
share/gnome/kino/help/en/index.html
share/gnome/kino/help/en/interfieldmotion.html
share/gnome/kino/help/en/interlace.html
@@ -137,6 +139,81 @@ share/gnome/kino/help/en/trim_storyboard.html
share/gnome/kino/help/en/trimloader.html
share/gnome/kino/help/en/ui.html
share/gnome/kino/help/en/vi.html
+share/gnome/kino/help/fr/AutoSplit.html
+share/gnome/kino/help/fr/FX.html
+share/gnome/kino/help/fr/GNU-FDL.html
+share/gnome/kino/help/fr/appendix.html
+share/gnome/kino/help/fr/aspectratio.html
+share/gnome/kino/help/fr/capture.html
+share/gnome/kino/help/fr/developers.html
+share/gnome/kino/help/fr/docbook.css
+share/gnome/kino/help/fr/dropframe.html
+share/gnome/kino/help/fr/droppedframes.html
+share/gnome/kino/help/fr/edit.html
+share/gnome/kino/help/fr/export.html
+share/gnome/kino/help/fr/export_audio.html
+share/gnome/kino/help/fr/export_dv.html
+share/gnome/kino/help/fr/export_export.html
+share/gnome/kino/help/fr/export_ieee1394.html
+share/gnome/kino/help/fr/export_other.html
+share/gnome/kino/help/fr/export_selection.html
+share/gnome/kino/help/fr/framedropping.html
+share/gnome/kino/help/fr/fx_audio.html
+share/gnome/kino/help/fr/fx_selection.html
+share/gnome/kino/help/fr/fx_video.html
+share/gnome/kino/help/fr/images/caution.png
+share/gnome/kino/help/fr/images/important.png
+share/gnome/kino/help/fr/images/note.png
+share/gnome/kino/help/fr/images/tip.png
+share/gnome/kino/help/fr/images/warning.png
+share/gnome/kino/help/fr/index.html
+share/gnome/kino/help/fr/interfieldmotion.html
+share/gnome/kino/help/fr/interlace.html
+share/gnome/kino/help/fr/intro.html
+share/gnome/kino/help/fr/jogshuttle.html
+share/gnome/kino/help/fr/keyboard.html
+share/gnome/kino/help/fr/kino.xml
+share/gnome/kino/help/fr/links.html
+share/gnome/kino/help/fr/locked.html
+share/gnome/kino/help/fr/media/ui/kinoui-fr.png
+share/gnome/kino/help/fr/metadata.html
+share/gnome/kino/help/fr/metadata_example.html
+share/gnome/kino/help/fr/metanames.html
+share/gnome/kino/help/fr/metavalues.html
+share/gnome/kino/help/fr/mode.html
+share/gnome/kino/help/fr/movie.html
+share/gnome/kino/help/fr/mpeg.html
+share/gnome/kino/help/fr/newprojecturi.html
+share/gnome/kino/help/fr/newprojectxpath.html
+share/gnome/kino/help/fr/overwrite_insert.html
+share/gnome/kino/help/fr/pointclick.html
+share/gnome/kino/help/fr/prefs.html
+share/gnome/kino/help/fr/prefs0.html
+share/gnome/kino/help/fr/prefs1.html
+share/gnome/kino/help/fr/prefs2.html
+share/gnome/kino/help/fr/prefs3.html
+share/gnome/kino/help/fr/prefs4.html
+share/gnome/kino/help/fr/prefs5.html
+share/gnome/kino/help/fr/prefs7.html
+share/gnome/kino/help/fr/preview.html
+share/gnome/kino/help/fr/publish.html
+share/gnome/kino/help/fr/render.html
+share/gnome/kino/help/fr/scene.html
+share/gnome/kino/help/fr/scrubbar.html
+share/gnome/kino/help/fr/shuttle.html
+share/gnome/kino/help/fr/stills.html
+share/gnome/kino/help/fr/terms.html
+share/gnome/kino/help/fr/time.html
+share/gnome/kino/help/fr/timecode.html
+share/gnome/kino/help/fr/timeentry.html
+share/gnome/kino/help/fr/timeformats.html
+share/gnome/kino/help/fr/transport.html
+share/gnome/kino/help/fr/trim.html
+share/gnome/kino/help/fr/trim_conclusion.html
+share/gnome/kino/help/fr/trim_storyboard.html
+share/gnome/kino/help/fr/trimloader.html
+share/gnome/kino/help/fr/ui.html
+share/gnome/kino/help/fr/vi.html
share/gnome/kino/scripts/help.sh
share/gnome/kino/scripts/dvdauthor/dvdauthor-k3b.sh
share/gnome/kino/scripts/dvdauthor/dvdauthor.sh
@@ -218,9 +295,14 @@ share/locale/sv/LC_MESSAGES/kino.mo
share/mime/packages/kino.xml
@dirrm include/kino
@dirrm lib/kino-gtk2
+@dirrm share/gnome/kino/help/en/images
@dirrm share/gnome/kino/help/en/media/ui
@dirrm share/gnome/kino/help/en/media
@dirrm share/gnome/kino/help/en
+@dirrm share/gnome/kino/help/fr/images
+@dirrm share/gnome/kino/help/fr/media/ui
+@dirrm share/gnome/kino/help/fr/media
+@dirrm share/gnome/kino/help/fr
@dirrm share/gnome/kino/help
@dirrm share/gnome/kino/lumas
@dirrm share/gnome/kino/scripts/dvdauthor