aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/kmplayer-kde4
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-03-01 06:16:10 +0800
committerahze <ahze@FreeBSD.org>2005-03-01 06:16:10 +0800
commit67b0bcb755f8b2e738f1628212a462100010232d (patch)
tree66219c98689ff4395c07681f6494f6d4f242fc09 /multimedia/kmplayer-kde4
parentaa4e4e91097b7da2ff4497ebcbbc802bddb95dc7 (diff)
downloadfreebsd-ports-gnome-67b0bcb755f8b2e738f1628212a462100010232d.tar.gz
freebsd-ports-gnome-67b0bcb755f8b2e738f1628212a462100010232d.tar.zst
freebsd-ports-gnome-67b0bcb755f8b2e738f1628212a462100010232d.zip
- split multimedia/gstreamer-plugins in to individual ports per
gstreamer plugin (52 new ports). - Chase changes to ports that used USE_GNOME=gstreamerplugisn to use new USE_GSTREAMER= macro, Bump PORTREVISION's -- Examples of new USE_GSTREAMER macro: USE_GSTREAMER= dvd lame flac .include <bsd.port.mk> If you want to use USE_GSTREAMER after <bsd.port.pre.mk> you must follow one of the examples listed below WANT_GSTREAMER= yes .include <bsd.port.pre.mk> .if defined(WITH_VORBIS) USE_GSTREAMER+= vorbis .endif or USE_GSTREAMER= yes .include <bsd.port.pre.mk> .if defined(WITH_FAAD) USE_GSTREAMER+= faad .endif Note: USE_GSTREAMER=yes will always add a dependency to ports/multimedia/gstreamer-plugins -- Thanks to krion for runing this on pointyhat Thanks to kwm for helping with this, and many bug fixes , and updates.
Diffstat (limited to 'multimedia/kmplayer-kde4')
-rw-r--r--multimedia/kmplayer-kde4/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/multimedia/kmplayer-kde4/Makefile b/multimedia/kmplayer-kde4/Makefile
index f8f01c8a09c3..a99d9f71d51b 100644
--- a/multimedia/kmplayer-kde4/Makefile
+++ b/multimedia/kmplayer-kde4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kmplayer
DISTVERSION= 0.8.4-rc5
+PORTREVISION= 1
CATEGORIES= multimedia audio kde
MASTER_SITES= http://www.xs4all.nl/%7Ejjvrieze/
#DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.r/-rc/}
@@ -29,7 +30,7 @@ CONFIGURE_ARGS+=--with-x=${X11BASE} --disable-debug
OPTIONS= GSTREAMER "Enable support for video playback using gstreamer" off \
XINE "Enable support for video playback using libxine" off
-WANT_GNOME= gstreamerplugins
+WANT_GSTREAMER= yes
###
## Lib Detection
@@ -57,20 +58,12 @@ post-patch:
.include <bsd.port.pre.mk>
###
-## Internal Detection
-###
-# gstreamer
-.if ${HAVE_GNOME:Mgstreamerplugins}
-WITH_GSTREAMER=yes
-.endif
-
-###
## Support Activation
###
# gstreamer
.undef WITH_GSTREAMER
.if defined(WITH_GSTREAMER)
-USE_GNOME+= gstreamerplugins
+USE_GSTREAMER+= yes
PLIST_FILES+= bin/kgstplayer
.else