aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/kodi
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2016-11-12 23:53:59 +0800
committercpm <cpm@FreeBSD.org>2016-11-12 23:53:59 +0800
commitd942d6726e7f296c31e8327b9a7a209fef4111fe (patch)
treea93bfa9d60a628f4856b2b097287bf41aaafb8d1 /multimedia/kodi
parent1dc4a97a96a1c9e86c0483932e96332f05eca925 (diff)
downloadfreebsd-ports-gnome-d942d6726e7f296c31e8327b9a7a209fef4111fe.tar.gz
freebsd-ports-gnome-d942d6726e7f296c31e8327b9a7a209fef4111fe.tar.zst
freebsd-ports-gnome-d942d6726e7f296c31e8327b9a7a209fef4111fe.zip
multimedia/kodi: Fix linking error on FreeBSD
gmake[3]: Leaving directory '/usr/ports/multimedia/kodi/work/xbmc-f4dda26/xbmc/cores/dvdplayer/DVDInputStreams' CPP xbmc/guilib/TextureManager.o CPP xbmc/guilib/VisibleEffect.o CPP xbmc/guilib/XBTF.o CPP xbmc/guilib/XBTFReader.o CPP xbmc/guilib/TextureGL.o CPP xbmc/guilib/GUIFontTTFGL.o CPP xbmc/guilib/GUITextureGL.o CPP xbmc/guilib/MatrixGLES.o AR xbmc/guilib/guilib.a gmake[3]: Leaving directory '/usr/ports/multimedia/kodi/work/xbmc-f4dda26/xbmc/guilib' LD kodi.bin xbmc/guilib/guilib.a(DDSImage.o): In function `CDDSImage::Compress(unsigned int, unsigned int, unsigned int, unsigned char const*, double)': DDSImage.cpp:(.text+0x5b0): undefined reference to `squish::CompressImage(unsigned char const*, int, int, int, void*, int, float*)' DDSImage.cpp:(.text+0x5e2): undefined reference to `squish::ComputeMSE(unsigned char const*, int, int, int, unsigned char const*, int, double&, double&)' DDSImage.cpp:(.text+0x6ea): undefined reference to `squish::CompressImage(unsigned char const*, int, int, int, void*, int, float*)' DDSImage.cpp:(.text+0x718): undefined reference to `squish::ComputeMSE(unsigned char const*, int, int, int, unsigned char const*, int, double&, double&)' DDSImage.cpp:(.text+0x75f): undefined reference to `squish::CompressImage(unsigned char const*, int, int, int, void*, int, float*)' DDSImage.cpp:(.text+0x78d): undefined reference to `squish::ComputeMSE(unsigned char const*, int, int, int, unsigned char const*, int, double&, double&)' xbmc/guilib/guilib.a(DDSImage.o): In function `CDDSImage::Decompress(unsigned char*, unsigned int, unsigned int, unsigned int, unsigned char const*, unsigned int)': DDSImage.cpp:(.text+0x9a5): undefined reference to `squish::DecompressImage(unsigned char*, int, int, int, void const*, int)' c++: error: linker command failed with exit code 1 (use -v to see invocation) Makefile:486: recipe for target 'kodi.bin' failed gmake[2]: *** [kodi.bin] Error 1 gmake[2]: Leaving directory '/usr/ports/multimedia/kodi/work/xbmc-f4dda26' ===> Compilation failed unexpectedly. Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to the maintainer. *** Error code 1 Stop. make[1]: stopped in /usr/ports/multimedia/kodi *** Error code 1 Stop. make: stopped in /usr/ports/multimedia/kodi PR: 204380 Submitted by: Tomasz Sowa <bugsfreebsd@ttmath.org> Reported by: Andrew <andrew_terekhov@yahoo.com> Reviewed by: feld, junovitch, koobs (mentors) Approved by: Mickael Maillot (maintainer timeout, 9 months), feld, junovitch, koobs (mentors) MFH: 2016Q4
Diffstat (limited to 'multimedia/kodi')
-rw-r--r--multimedia/kodi/Makefile2
-rw-r--r--multimedia/kodi/files/patch-Makefile.in11
2 files changed, 12 insertions, 1 deletions
diff --git a/multimedia/kodi/Makefile b/multimedia/kodi/Makefile
index 994d53fd177f..b616dddc8a0b 100644
--- a/multimedia/kodi/Makefile
+++ b/multimedia/kodi/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kodi
DISTVERSION= 16.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia java
MAINTAINER= mickael.maillot@gmail.com
diff --git a/multimedia/kodi/files/patch-Makefile.in b/multimedia/kodi/files/patch-Makefile.in
new file mode 100644
index 000000000000..bdec6dffb232
--- /dev/null
+++ b/multimedia/kodi/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2016-10-20 18:15:13 UTC
++++ Makefile.in
+@@ -434,7 +434,7 @@ endif
+ ifeq ($(findstring osx,@ARCH@), osx)
+ $(SILENT_LD) $(CXX) $(LDFLAGS) -o @APP_NAME_LC@.bin $(MAINOBJS) -Wl,-all_load,-ObjC $(MAINOBJS) $(DYNOBJSXBMC) $(NWAOBJSXBMC) $(OBJSXBMC) $(LIBS) -rdynamic
+ else
+- $(SILENT_LD) $(CXX) $(CXXFLAGS) $(LDFLAGS) -o @APP_NAME_LC@.bin $(MAINOBJS) -Wl,--start-group $(MAINOBJS) $(DYNOBJSXBMC) $(OBJSXBMC) -Wl,--end-group $(NWAOBJSXBMC) $(LIBS) -rdynamic
++ $(SILENT_LD) $(CXX) $(CXXFLAGS) $(LDFLAGS) -o @APP_NAME_LC@.bin $(MAINOBJS) -Wl,--start-group $(MAINOBJS) $(DYNOBJSXBMC) $(OBJSXBMC) -Wl,--end-group $(NWAOBJSXBMC) $(LIBS) -rdynamic ./tools/depends/native/libsquish-native/squish-install/lib/libsquish.a
+ endif
+
+ @APP_NAME_LC@-xrandr: xbmc-xrandr.c