aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/kodi
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2017-05-04 03:35:25 +0800
committerpawel <pawel@FreeBSD.org>2017-05-04 03:35:25 +0800
commitda4614e9abdf7e1dda3c0eb9c9c3889daf982b98 (patch)
tree62be5dd9a21e7f40131a040966acc614f0465c56 /multimedia/kodi
parentc5f5de73b83df2a75e39e19e8f10bc14188ba57b (diff)
downloadfreebsd-ports-gnome-da4614e9abdf7e1dda3c0eb9c9c3889daf982b98.tar.gz
freebsd-ports-gnome-da4614e9abdf7e1dda3c0eb9c9c3889daf982b98.tar.zst
freebsd-ports-gnome-da4614e9abdf7e1dda3c0eb9c9c3889daf982b98.zip
Fix build on systems with gcc installed by respecting CXX
JsonSchemaBuilder configure picks up g++ as compiler: g++ -DPACKAGE_NAME=\"JsonSchemaBuilder\" -DPACKAGE_TARNAME=\"jsonschemabuilder\" -DPACKAGE_VERSION=\"1.0\" -DPACKAGE_STRING=\"JsonSchemaBuilder\ 1.0\" -DPACKAGE_BUGREPORT=\"me@mail.com\" -DPACKAGE_URL=\"\" -DPACKAGE=\"jsonschemabuilder\" -DVERSION=\"1.0\" -I. -g -O2 -MT JsonSchemaBuilder.o -MD -MP -MF .deps/JsonSchemaBuilder.Tpo -c -o JsonSchemaBuilder.o JsonSchemaBuilder.cpp Later compiled binary fails to execute: ../../../tools/depends/native/JsonSchemaBuilder/bin/JsonSchemaBuilder schema/version.txt schema/license.txt schema/methods.json schema/types.json schema/notifications.json /usr/local/lib/gcc49/libstdc++.so.6: version GLIBCXX_3.4.21 required by /hdd/ports/multimedia/kodi/work/xbmc-fc1619b/tools/depends/native/ JsonSchemaBuilder/bin/JsonSchemaBuilder not found PR: 218714 Submitted by: myself Approved by: maintainer timeout
Diffstat (limited to 'multimedia/kodi')
-rw-r--r--multimedia/kodi/files/patch-tools_depends_native_JsonSchemaBuilder_Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/multimedia/kodi/files/patch-tools_depends_native_JsonSchemaBuilder_Makefile b/multimedia/kodi/files/patch-tools_depends_native_JsonSchemaBuilder_Makefile
new file mode 100644
index 000000000000..f49f1ad50b85
--- /dev/null
+++ b/multimedia/kodi/files/patch-tools_depends_native_JsonSchemaBuilder_Makefile
@@ -0,0 +1,11 @@
+--- tools/depends/native/JsonSchemaBuilder/Makefile.orig 2017-04-13 17:25:58 UTC
++++ tools/depends/native/JsonSchemaBuilder/Makefile
+@@ -25,7 +25,7 @@ $(PLATFORM):
+ -rm -rf $(PLATFORM)/*; mkdir -p $(PLATFORM)
+ cd $(PLATFORM); cp -a $(SOURCE)/* .
+ cd $(PLATFORM); ./autogen.sh
+- cd $(PLATFORM); $(CONFIGURE)
++ cd $(PLATFORM); env CXX=${CXX} $(CONFIGURE)
+
+
+ $(APP): $(PLATFORM)