aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libdvdcss/Makefile
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-05-15 18:41:21 +0800
committertijl <tijl@FreeBSD.org>2014-05-15 18:41:21 +0800
commitf8dc1dc520228b478ffe74983a2c60954aeb9260 (patch)
treeb6a409b9bb593b6095faf58489616fb0fb210d1b /multimedia/libdvdcss/Makefile
parent01fd5f8b88847bdf0ddb48d594f591524db8c8c3 (diff)
downloadfreebsd-ports-gnome-f8dc1dc520228b478ffe74983a2c60954aeb9260.tar.gz
freebsd-ports-gnome-f8dc1dc520228b478ffe74983a2c60954aeb9260.tar.zst
freebsd-ports-gnome-f8dc1dc520228b478ffe74983a2c60954aeb9260.zip
multimedia/libdvdcss:
- USES=gmake libtool pathfix tar:bzip2. - INSTALL_TARGET=install-strip. - Use options. - Staging. - Simplify post-patch commands. - This update changes the library version but this allows removing libdvdcss related patches from dependent ports. multimedia/libxine: [1] - Add USES=libtool:keepla and remove libtool related patches and post-patch commands. - Move bsd.port.pre.mk include down and remove WANT_GNOME. - Remove USE_XORG=sm. libxine doesn't link to it. - Remove CONFIGURE_ENV. Not needed. - Clean up CPPFLAGS and CFLAGS. - Rename the GTK2 option PIXBUF and depend on gdkpixbuf2 instead of gtk20. - Remove PATCH_DIST_ARGS. Leftover from when there were external patches. - Remove -fno-force-addr clang hack. Modern gcc does not support the flag either and it was only added in case the user has -fforce-addr in CFLAGS in make.conf. - Fix IMAGEMAGICK option. - Merge pre-configure with post-patch and remove most commands because they don't do anything. multimedia/libdvdread: - USES=libtool:oldver pathfix. - INSTALL_TARGET=install-strip. multimedia/handbrake: - Add build dependency on devel/libtool because configure script expects to find existing libtool program. - Turn dependency on libdvdcss into library dependency such that headers are available during build. - Add USES=libtool to patch libtool scripts in contrib code. - Remove run-autotools-aclocal target and replace USE_AUTOTOOLS=aclocal with "autoconf:env automake:env" to indicate only build dependencies are needed and the tools don't have to be run. Approved by: nox [1]
Diffstat (limited to 'multimedia/libdvdcss/Makefile')
-rw-r--r--multimedia/libdvdcss/Makefile43
1 files changed, 14 insertions, 29 deletions
diff --git a/multimedia/libdvdcss/Makefile b/multimedia/libdvdcss/Makefile
index 9e63dd73666e..9a2abaf109cb 100644
--- a/multimedia/libdvdcss/Makefile
+++ b/multimedia/libdvdcss/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libdvdcss
PORTVERSION= 1.2.12
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://download.videolan.org/pub/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
@@ -12,49 +13,33 @@ COMMENT= Portable abstraction library for DVD decryption
RESTRICTED= CSS code may violate the DMCA
-USE_AUTOTOOLS= libtool
-USE_BZIP2= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= gmake libtool pathfix tar:bzip2
USE_LDCONFIG= yes
-.ifndef(WITH_DOXYGEN)
-NOPORTDOCS= yes
-.endif
+OPTIONS_DEFINE= DOXYGEN
-.ifndef(NOPORTDOCS)
-BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MDOXYGEN}
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
PORTDOCS= *
.endif
-NO_STAGE= yes
-pre-everything::
-.if !defined(WITH_DOXYGEN)
- @${ECHO_MSG} '==> Define WITH_DOXYGEN to build API documentation'
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/ioctl.c
- ${REINPLACE_CMD} -e '/^pkgconfigdir/s|$$(libdir)|$$(libdir)data|' \
- ${WRKSRC}/src/Makefile.in
-# should we disable doc building?
-.ifdef(NOPORTDOCS)
- @${REINPLACE_CMD} -E \
- -e 's|^([[:space:]]*SUBDIRS[[:space:]]*=.*)doc|\1|' \
- ${BUILD_WRKSRC}/Makefile.in
-.else
+.if ${PORT_OPTIONS:MDOXYGEN}
# we do not want the latex documents... too many dependencies just
# to get in ps what we already have in html
- @${REINPLACE_CMD} -E \
- -e 's|^([[:space:]]*all:[[:space:]]*.*)stamp-latex|\1|' \
- ${BUILD_WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} '/^all:/s/stamp-latex//' ${WRKSRC}/doc/Makefile.in
+.else
+ @${REINPLACE_CMD} '/^SUBDIRS =/s/doc//' ${WRKSRC}/Makefile.in
.endif
post-install:
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${INSTALL_WRKSRC}/doc/html/* ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOXYGEN}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/doc/html/* ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>