aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libdvdread/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-06-05 00:34:59 +0800
committerlioux <lioux@FreeBSD.org>2002-06-05 00:34:59 +0800
commit1b60882f79999af062bf943c34f93b9f12d84c82 (patch)
tree335474327732613934af2d3c50e2058fb48455eb /multimedia/libdvdread/Makefile
parent01d1f9403ae7ea4902872cb49e254dac95ee4a61 (diff)
downloadfreebsd-ports-gnome-1b60882f79999af062bf943c34f93b9f12d84c82.tar.gz
freebsd-ports-gnome-1b60882f79999af062bf943c34f93b9f12d84c82.tar.zst
freebsd-ports-gnome-1b60882f79999af062bf943c34f93b9f12d84c82.zip
o Update to 0.9.3
o Take over maintainership due to maintainer time out in the last 6 months Approved by: 3d (maintainer timeout)
Diffstat (limited to 'multimedia/libdvdread/Makefile')
-rw-r--r--multimedia/libdvdread/Makefile22
1 files changed, 5 insertions, 17 deletions
diff --git a/multimedia/libdvdread/Makefile b/multimedia/libdvdread/Makefile
index 10b95728be06..b2868a2fb51e 100644
--- a/multimedia/libdvdread/Makefile
+++ b/multimedia/libdvdread/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= libdvdread
-PORTVERSION= 0.9.2
-PORTREVISION= 2
+PORTVERSION= 0.9.3
CATEGORIES= graphics
MASTER_SITES= http://www.dtek.chalmers.se/groups/dvd/dist/
-MAINTAINER= 3d@FreeBSD.org
+MAINTAINER= lioux@FreeBSD.org
LIB_DEPENDS= dvdcss.${DVDCSS_LIBVERSION}:${PORTSDIR}/graphics/libdvdcss
@@ -19,32 +18,21 @@ GNU_CONFIGURE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-DOC_FILES= AUTHORS NEWS README TODO
+DOC_FILES= AUTHORS COPYING NEWS README TODO
# ugly hack to have libdvdread directly depend on libdvdcss since
# it already does for practical reasons even though not for compile
# time ones
DVDCSS_LIBVERSION= 2
-# optional CFLAGS safeness
-.if !defined(WITH_OPTIMIZED_CFLAGS)
-USE_AUTOCONF= yes
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure.in
-.endif
-
-pre-everything::
-.if !defined(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} "====> If you want to enable optimizations, please define WITH_OPTIMIZED_CFLAGS"
-.endif
-
post-patch:
.for p in Makefile.in dvdread/Makefile.in src/Makefile.in
@${PERL} -pi -e 's|cd \$$\(top_srcdir\) && \$$\(AUTOMAKE\)|\#|; \
s|cd \$$\(srcdir\) && \$$\(ACLOCAL\)|\#|' ${WRKSRC}/${p}
.endfor
# update this in sync with libdvdcss shared library version
- @${PERL} -pi -e 's|(libdvdcss.so).0|\1.${DVDCSS_LIBVERSION}|' \
- ${WRKSRC}/dvdread/dvd_reader.c
+ @${PERL} -pi -e 's|(libdvdcss.so).2|\1.${DVDCSS_LIBVERSION}|' \
+ ${WRKSRC}/dvdread/dvd_input.c
post-configure:
@${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}