aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libmpeg2
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
committerobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
commit6b02d1b35c173832c085697cf76aa156d04ad843 (patch)
tree195cb55f1eda849521409154920849cf102b91fa /multimedia/libmpeg2
parent93ea51bfc3219265c52c39374430d10201b8f436 (diff)
downloadfreebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.gz
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.zst
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.zip
Assist getting more ports working on AMD64 by obeying the
Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'.
Diffstat (limited to 'multimedia/libmpeg2')
-rw-r--r--multimedia/libmpeg2/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/multimedia/libmpeg2/Makefile b/multimedia/libmpeg2/Makefile
index 321e9e0b7eeb..783baac87dc5 100644
--- a/multimedia/libmpeg2/Makefile
+++ b/multimedia/libmpeg2/Makefile
@@ -49,7 +49,7 @@ CONFIGURE_ARGS+= --disable-warnings
# We must be able to build EV6 code; actual CPU-type optimizations
# are chosen at runtime.
-.if ${MACHINE_ARCH:L} == "alpha"
+.if ${ARCH:L} == "alpha"
CFLAGS:= ${CFLAGS:N-mcpu=*}
.endif
@@ -73,7 +73,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|<SDL/|<SDL11/|' ${WRKSRC}/libvo/*
@${REINPLACE_CMD} -e 's|-O3||;s|<termio.h>|<termios.h>|' ${WRKSRC}/configure
# AMD64 prefers position independent code
-.if ${MACHINE_ARCH:L} == "amd64"
+.if ${ARCH:L} == "amd64"
@${REINPLACE_CMD} -e 's|-prefer-non-pic||' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif