aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libquicktime
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-05-16 02:31:03 +0800
committerahze <ahze@FreeBSD.org>2005-05-16 02:31:03 +0800
commita1aa8ce8f3af0b268d2ed92afccd96953e592cea (patch)
tree90c2e4dda9817613161af13d7be87f454e198c42 /multimedia/libquicktime
parent3e8c2e9328db01ec0d3a27ca6832e8e6b5dc6d7a (diff)
downloadfreebsd-ports-gnome-a1aa8ce8f3af0b268d2ed92afccd96953e592cea.tar.gz
freebsd-ports-gnome-a1aa8ce8f3af0b268d2ed92afccd96953e592cea.tar.zst
freebsd-ports-gnome-a1aa8ce8f3af0b268d2ed92afccd96953e592cea.zip
- Update to 0.9.5
Note: Does not build with ffmpeg-devel, but will run w/ ffmpeg-devel.
Diffstat (limited to 'multimedia/libquicktime')
-rw-r--r--multimedia/libquicktime/Makefile34
-rw-r--r--multimedia/libquicktime/distinfo4
-rw-r--r--multimedia/libquicktime/files/patch-configure51
-rw-r--r--multimedia/libquicktime/files/patch-plugins::rtjpeg::RTjpeg.h15
-rw-r--r--multimedia/libquicktime/pkg-plist18
5 files changed, 29 insertions, 93 deletions
diff --git a/multimedia/libquicktime/Makefile b/multimedia/libquicktime/Makefile
index 0049517fca19..dda443047e5f 100644
--- a/multimedia/libquicktime/Makefile
+++ b/multimedia/libquicktime/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= libquicktime
-PORTVERSION= 0.9.4
-PORTREVISION= 1
+PORTVERSION= 0.9.5
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -34,25 +33,20 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
CONFIGURE_ARGS= --disable-firewire
CFLAGS+= -fPIC
-OPTIONS= LAME "Enable Lame mp3 encoding support" Off
+OPTIONS= LAME "Enable Lame mp3 encoding support" Off \
+ GTK "Enable Gtk+2 Frontend" Off
MAN1= lqtplay.1
-PORTDOCS= codecs.html \
- qt4l_building.html \
- qt4l_codecs.html \
- qt4l_firewire.html \
- qt4l_index.html \
- qt4l_license.html \
- qt4l_opening.html \
- qt4l_positioning.html \
- qt4l_reading.html \
- qt4l_util.html \
- qt4l_writing.html
+
+PORTDOCS= api_usage.html codecs.html qt4l_building.html \
+ qt4l_codecs.html qt4l_firewire.html qt4l_index.html \
+ qt4l_license.html qt4l_opening.html qt4l_positioning.html \
+ qt4l_reading.html qt4l_util.html qt4l_writing.html
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgtk12}!=""
-USE_GNOME+= gtk12
+.if ${HAVE_GNOME:Mgtk20}!="" || defined(WITH_GTK)
+USE_GNOME+= gtk20
PLIST_SUB+= GTK=""
.else
PLIST_SUB+= GTK="@comment "
@@ -65,9 +59,11 @@ PLIST_SUB+= LAME=""
PLIST_SUB+= LAME="@comment "
.endif
-.if ${MACHINE_CPU:Mmmx} && ${ARCH}=="i386"
+.if ${MACHINE_CPU:Mmmx}
CONFIGURE_ARGS+= --enable-mmx
+.if ${ARCH}=="i386"
LIB_DEPENDS+= jpeg-mmx.62:${PORTSDIR}/graphics/jpeg-mmx
+.endif
.else
CONFIGURE_ARGS+= --disable-mmx
.endif
@@ -80,8 +76,8 @@ post-extract:
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
.endfor
.endif
diff --git a/multimedia/libquicktime/distinfo b/multimedia/libquicktime/distinfo
index 1c52a9230c64..a784d6ba6e53 100644
--- a/multimedia/libquicktime/distinfo
+++ b/multimedia/libquicktime/distinfo
@@ -1,2 +1,2 @@
-MD5 (libquicktime-0.9.4.tar.gz) = 8d93e4e3393942edc35511dd2e51a32d
-SIZE (libquicktime-0.9.4.tar.gz) = 782651
+MD5 (libquicktime-0.9.5.tar.gz) = 7b2f0b51a65ac460819bc9b5991264a9
+SIZE (libquicktime-0.9.5.tar.gz) = 765981
diff --git a/multimedia/libquicktime/files/patch-configure b/multimedia/libquicktime/files/patch-configure
index c19ae9d39446..f66f91a09cbc 100644
--- a/multimedia/libquicktime/files/patch-configure
+++ b/multimedia/libquicktime/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Wed Jan 12 17:17:29 2005
-+++ configure Wed Jan 12 20:19:58 2005
-@@ -21041,7 +21041,7 @@
+--- configure.orig Sun May 15 13:27:04 2005
++++ configure Sun May 15 13:27:04 2005
+@@ -26794,7 +26794,7 @@
fi
case $compile_mode in
@@ -9,48 +9,3 @@
#define NDEBUG 1
_ACEOF
;;
-@@ -26120,42 +26120,12 @@
- echo "*** to the full path to pkg-config."
- echo "*** Or see http://www.freedesktop.org/software/pkgconfig to get pkg-config."
- else
-- PKG_CONFIG_MIN_VERSION=0.9.0
-- if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
-- echo "$as_me:$LINENO: checking for avcodec_acl >= \"0.4.8acl\"" >&5
--echo $ECHO_N "checking for avcodec_acl >= \"0.4.8acl\"... $ECHO_C" >&6
--
-- if $PKG_CONFIG --exists "avcodec_acl >= "0.4.8acl"" ; then
-- echo "$as_me:$LINENO: result: yes" >&5
--echo "${ECHO_T}yes" >&6
-- succeeded=yes
--
-- echo "$as_me:$LINENO: checking AVCODEC_ACL_CFLAGS" >&5
--echo $ECHO_N "checking AVCODEC_ACL_CFLAGS... $ECHO_C" >&6
-- AVCODEC_ACL_CFLAGS=`$PKG_CONFIG --cflags "avcodec_acl >= "0.4.8acl""`
-- echo "$as_me:$LINENO: result: $AVCODEC_ACL_CFLAGS" >&5
--echo "${ECHO_T}$AVCODEC_ACL_CFLAGS" >&6
--
-- echo "$as_me:$LINENO: checking AVCODEC_ACL_LIBS" >&5
--echo $ECHO_N "checking AVCODEC_ACL_LIBS... $ECHO_C" >&6
-- AVCODEC_ACL_LIBS=`$PKG_CONFIG --libs "avcodec_acl >= "0.4.8acl""`
-- echo "$as_me:$LINENO: result: $AVCODEC_ACL_LIBS" >&5
--echo "${ECHO_T}$AVCODEC_ACL_LIBS" >&6
-- else
- AVCODEC_ACL_CFLAGS=""
-- AVCODEC_ACL_LIBS=""
-+ AVCODEC_ACL_LIBS="-lavcodec"
-+ succeeded="yes"
- ## If we have a custom action on failure, don't print errors, but
- ## do set a variable so people can do so.
-- AVCODEC_ACL_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "avcodec_acl >= "0.4.8acl""`
-
-- fi
--
--
--
-- else
-- echo "*** Your version of pkg-config is too old. You need version $PKG_CONFIG_MIN_VERSION or newer."
-- echo "*** See http://www.freedesktop.org/software/pkgconfig"
-- fi
- fi
-
- if test $succeeded = yes; then
diff --git a/multimedia/libquicktime/files/patch-plugins::rtjpeg::RTjpeg.h b/multimedia/libquicktime/files/patch-plugins::rtjpeg::RTjpeg.h
deleted file mode 100644
index 11551e8204a8..000000000000
--- a/multimedia/libquicktime/files/patch-plugins::rtjpeg::RTjpeg.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- plugins/rtjpeg/RTjpeg.h.orig Tue Jun 4 05:04:22 2002
-+++ plugins/rtjpeg/RTjpeg.h Sat Aug 10 03:35:52 2002
-@@ -31,8 +31,12 @@
- South Africa
- */
-
-+#ifdef HAVE_STDINT_H
- #ifndef _STDINT_H
- #include <stdint.h>
-+#endif
-+#else
-+#include <inttypes.h>
- #endif
-
- #ifdef __RTJPEG_INTERNAL__
diff --git a/multimedia/libquicktime/pkg-plist b/multimedia/libquicktime/pkg-plist
index 69fb20e5c88f..710608b364a6 100644
--- a/multimedia/libquicktime/pkg-plist
+++ b/multimedia/libquicktime/pkg-plist
@@ -9,14 +9,14 @@ bin/qtinfo
bin/qtrechunk
bin/qtstreamize
bin/qtyuv4toyuv
-include/quicktime/colormodels.h
-include/quicktime/lqt.h
-include/quicktime/lqt1394_config.h
-include/quicktime/lqt_codecapi.h
-include/quicktime/lqt_codecinfo.h
-include/quicktime/lqt_version.h
-include/quicktime/qtprivate.h
-include/quicktime/quicktime.h
+include/lqt/colormodels.h
+include/lqt/lqt.h
+include/lqt/lqt1394_config.h
+include/lqt/lqt_codecapi.h
+include/lqt/lqt_codecinfo.h
+include/lqt/lqt_version.h
+include/lqt/qtprivate.h
+include/lqt/quicktime.h
lib/libquicktime.a
lib/libquicktime.so
lib/libquicktime.so.0
@@ -32,4 +32,4 @@ lib/libquicktime/lqt_vorbis.so
libdata/pkgconfig/libquicktime.pc
share/aclocal/lqt.m4
@dirrm lib/libquicktime
-@dirrm include/quicktime
+@dirrm include/lqt